locked
Programs hang when using files from mapped network drives. RRS feed

  • General discussion

  • I run and use a Windows 7 network for a very small office. 5 computers total, one acting as a server, all running windows 7 professional. A D-link 10/100 unmanaged switch does all the networking, and all computers have Realtek 10/100/1000 adapters.

    We basically run three main programs that use mapped network files; Sage Peachtree(accounting), and Autodesk Inventor(Drafting), and basic MS office programs.

    Peachtree performance is poor at times, fine at times. It seems to "hang" sometimes, especially after even a short time away from the program. Wait times when it "hangs" are anywhere from a few seconds to what seems like MUCH longer than that.

    Inventor problems are very similar, opening, saving, and browsing for files all cause short pauses, and larger compound operations cause significant wait times.

    These problems strangely enough popped up AFTER we upgraded the hardware on our server machine. The new machine has 8gb the ram, a quad core AMD processor, SATA drives, and a 1000Mbps onboard networking. All major improvements over the old hardware, but the network seems slower than ever.

    Our cabling is only cat 5, and I'm under the impression that gigabit Ethernet doesn't work fully on cat5 cable? So a faster switch wouldn't be doing us much good?

    Below is a mostly complete log of things I've tried so far, I've omitted some of the Peachtree specific setting that are needed on all computers running Peachtree.

    Sorry for the lengthy post, I'm just trying to get all this info out there and maybe get some help and help somebody else.

    --"Change advanced sharing settings" on all computers..

                    network discovery on

                    File and printer sharing on

                    Public folder sharing on

                    Media streaming off

                    128 Bit encryption

                    Turn OFF password protected sharing

    --Make sure folder with company data file is shared.

    --Set folder permissions for "everyone" to full control.

    --Set static IP on server

    --Add server static IP address and name to hosts file on client computers

    --Disabled IPV6 on Client and servers

    --Disable SMB 2.0 on server and clients

    Realtek NIC Adapter settings:

                    IPV4 checksum offload: Rx and Tx Enabled

                    Speed and duplex: 100mps full duplex

                    Flow Control: Disabled

                    Green Ethernet: Disabled

    Following command line stuff from: http://clintboessen.blogspot.com/2012/04/windows-7-slow-access-to-network-shares.html

                    netsh int tcp set global autotuninglevel=restricted

                    ocsetup MSRDC-Infrastructure /uninstall

    Set the following registry key to ‘1′ on the Windows Server:

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    and set the following registry key to ‘3′:

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    • Changed type tracycai Tuesday, February 19, 2013 5:36 AM
    Friday, February 15, 2013 6:22 PM

All replies

  • Hi,

    Does the issue occur on all the computers? Please check if this helps:

    Files on network shares open slowly, open as read-only, or you receive an error message

    http://support.microsoft.com/kb/814112

    Try to disable third-party antivirus programs or firewall temporarily to check the issue. You can also check in clean boot mode to see if it is caused by software conflicts:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/929135


    Tracy Cai
    TechNet Community Support

    Tuesday, February 19, 2013 8:28 AM
  • Hi All,

      When i logon to the PC keep getting the  ocsetup MSRDC-Infrastructure /uninstall Pop up Windows to enter admin details?

    How do we stop this even  remove the MSRDC-Infrastructure keep pop in?

    As

     

    Wednesday, April 9, 2014 4:35 AM