none
Outlook hides SharePoint Calendars RRS feed

  • Question

  • Hi,

    A few weeks ago, an install of Outlook 2013 started hiding all synced SharePoint (2013) calendars from the Calendar view. Their appointments no longer show up, and the calendar names themselves don't appear in the list with checkboxes. The calendars still appear in the SharePoint Lists tab of Account Settings. Deleting them from the list and re-adding them causes them to reappear, but the next time Outlook is reopened, they disappear again.

    I tried enabling Outlook logging, but I don't see anything that looks like an obvious culprit. 

    I tried adding the calendars to a fresh profile, and the problem seemed to go away, but the profile has several email accounts, and I'd prefer to fix the problem rather than try re-creating the whole profile if possible.

    Monday, November 4, 2019 10:01 PM

Answers

  • Hi Perry,

    Yes, it seemed to be limited to one client. I just created a new Outlook profile for that user and it seems to have fixed the problem. I hope the problem does not occur again, but for now it seems okay.

    Thanks for your help.

    • Marked as answer by felipet Friday, November 8, 2019 5:07 PM
    Friday, November 8, 2019 5:07 PM

All replies

  • Hi felipet,

    Do you mean SharePoint calendar do not sync with Outlook client well?

    We can try recreating the local data file to see if it helps. You can check the location of your Outlook Data Files in Outlook.

    • Select File > Account Settings > Account Settings.
    • Select the Data Files tab.
    • Choose the data file and click Open File Locations
    • Rename it to .old and then restart Outlook client

    As far as I know, SharePoint Calendars will normally be cached to local data file. In case its local cache keeps getting corrupted, let’s try access SharePoint Calendars online to check the results:

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    1. Press Win + R to open Run. Type regedit and click Enter.

    2. locate this path:

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Cached Mode

    or

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\Cached Mode

    (Note If you configure the registry value in the \Policies registry key, the change is applied to all existing Outlook profiles. If you configure the registry value in the non-Policies key, the change only applies to new Outlook profiles that you create.)

    3. Click Editor > New > DWORD.

    4. Type the name: CacheOthersMail

    5. set the value to 0

    Hope the information is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 5, 2019 2:49 AM
    Moderator
  • Hi Perry,

    I tried re-creating the PST file, but it did not make a difference. The calendars that should have been synchronized were still totally hidden. I added both registry keys, and that also did not seem to make a difference. Furthermore, based on the Sysinternals Process Monitor tool, it doesn't look like Outlook is actually reading either key.

    Thanks

    Tuesday, November 5, 2019 4:25 AM
  • Could I know what's your account type? Exchange, POP or IMAP?

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 5, 2019 4:43 AM
    Moderator
  • Hi Perry,

    Thanks for your quick response. The profile contains two Exchange accounts and two IMAP accounts. The SharePoint calendar list data is stored in a separate PST file though.


    Tuesday, November 5, 2019 5:06 AM
  • Normally, SharePoint calendar will be cached to local .ost file and the registry is used to prevent caching to .ost files.

    Could I know how do you set it to save in PST file?

    Try these steps to see if it helps:

    1. Reset View settings

    Calendar items could be hidden by corrupted view settings. Exit Outlook, press Win key + R to open the Run command, type outlook /cleanviews and then press Enter.

    2. third-party add-in

    Please exit Outlook, press Win key + R to open the Run command, type outlook /safe:3 and then press Enter. This helps eliminate whether the problem lies on any third party add-ins.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 5, 2019 8:04 AM
    Moderator
  • Hi Perry,

    I believe SharePoint lists are normally stored in a file called SharePoint Lists.pst. I do not believe I did anything special to make it save in a pst instead of an ost.

    Even with /cleanviews and /safe:3, the calendar still disappears.

    Thanks,

    Philip

    Tuesday, November 5, 2019 4:04 PM
  • Hi Perry,

    I believe SharePoint lists are normally stored in a file called SharePoint Lists.pst. I do not believe I did anything special to make it save in a pst instead of an ost.

    Even with /cleanviews and /safe:3, the calendar still disappears.

    Thanks,

    Philip

    Hi Philip,

    Does this issue only happen to your client? We can test this issue on another computer.



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, November 7, 2019 1:25 AM
    Moderator
  • Hi Perry,

    Yes, it seemed to be limited to one client. I just created a new Outlook profile for that user and it seems to have fixed the problem. I hope the problem does not occur again, but for now it seems okay.

    Thanks for your help.

    • Marked as answer by felipet Friday, November 8, 2019 5:07 PM
    Friday, November 8, 2019 5:07 PM
  • That's great. So glad to see that it was fixed :)

    Here I will provide a brief summary of this post for your information.

    [Issue Symptiom]

    ====================

    After adding SharePoint List to Outlook, user cannot see items in this calendar. Deleting and re-adding them causes them to reappear, but the next time Outlook is reopened, they disappear again.

     

    [Possible Cause]

    ====================

    • Third-party add-in
    • Local Data file Corrupted
    • Personal settings in profile is broken.

           

    [Solution]

    ====================

    Create a new profile

         

    [Reference Link]

    ====================

    https://support.office.com/en-us/article/Create-an-Outlook-profile-f544c1ba-3352-4b3b-be0b-8d42a540459d

    Saturday, November 9, 2019 2:46 AM
    Moderator