locked
Mapped Drive RED "X" Solved by Microsoft (Finally!) But Solution as Provided cannot be replicated RRS feed

  • Question

  • The notorious "RED X Mapped Drive Syndrome" is well documented and has gone on for more that 7 years to my knowledge. When I installed my first NAS and could not get it to connect due to the Mapped Drives failing to be accessible, I embarked on a long struggle to find an answer. When on Win 7,  one of the last links I discovered was from a software writer who identified the issue and decided to produce a Batch File to address the problem. This batch file called MAPDRIVE  worked flawlessly throughout my use of Win 7. Unfortunately moving to WINDOWS 10 revealed that it was not compatible, and brought the grief back.   I then took a chance and called Microsoft's Help desk and managed to find a knowledgeable rep named Ariel. He did a Remote into my PC and after a short while and many re-boots, the RED X Syndrome was no more!  I then repeatedly rebooted many times as I could not believe he actually solved what no one else prior (again to what I and many others could find) could accomplish.

    The final request I made of him was to email the Step By Step he took to insure that all the Mapped Drives would be available each time I booted up. Unfortunately these original instructions never reached me and after multiple phone calls back to the Help Desk did a rep cobble together supposedly from his notes what one needed to do to perform this.

    The Original text was a bit sketchy ( "?" in several places and other steps) so I did a Step By Step myself as I rewrote the instructions as I would be using them regularly, 

    The problem is I cannot get the procedure (as written) to work. when I pull up the CMD command, I get no Mapped Drives shown. When I use the "net use" command, no Mapped Drives appear in explorer.

    So I'm hoping others with more knowledge than I can make whatever corrections are required to make this work. Below are my instructions (Top ) and the original Help Desk instructions.....

    Please just Add/Subtract to the below if you see any error:

    Thanks!

    Marc

    Step-by-step instructions to correct inability for Mapped Drives in Windows 10 to be loaded automatically after each boot

     Before beginning Procedure, go to Start> Run> MSCONFIG> Services> Hide All Microsoft     Services>  Disable All > Apply> General Tab> Selective Startup

    The Above is to Insure there is no 3rd Party Software that can inhibit this Map Drive resolution process.

    1. Start> File Explorer> This PC> Select Properties> Computer Name> Change Settings
    2. Change Computer Name from Name Displayed (Required for Step 8) Note New Name
    3. Re-Boot PC
    4. Start > Run> CMD> Type “nbtstat –R”
    5. Close Window> Press Enter> Re-Boot PC
    6. Open Command Prompt (Start> Task Manager> File> Run New Task> CMD> Tick Box for “Create with Administrative Privileges
    7. Type “net use”
      1. Look at all the connections in there, and remove the one that has the same name that you're trying to connect to by typing the following:

                   “net use \\server\drive/d

               Or this:    “net use driveLetter /d

               Where drive letter is for example m: or y:  

    1. Re-Boot Computer

    10)   Check Results to insure Mapped Drives are loading automatically.

    :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

    Original Instructions from Microsoft Help Desk Below:

    • ? Right click on "This PC", select Properties, Computer name tab, click on the change button. After changing it, you will have to restart the computer. Then on both computer, go to Start Menu, select RUN, type in cmd. Type nbtstat -R > then press enter ? then restart the computer ? Open up a command prompt  again (start -> run -> cmd)  then type "net use" ? then look at all the connections in there, and remove the one that has the same name that you're trying to connect to by typing this:

     net use \\server\drive /d

     or

     net use driveLetter /d

     where drive letter is something like m: or y:   ? after that restart the computer


    Marc

    Wednesday, June 15, 2016 1:25 PM

All replies

  • Funny how the rep suggests NBTStat -R and then a reboot ....

    NBTStat -R purges the contents of the NetBIOS name cache and then reloads the #PRE-tagged entries from the Lmhosts file (if any).

    Seems pretty useless to do that before a reboot ....


    Best regards, George

    Wednesday, June 15, 2016 1:54 PM
  • Hi Marc Rob,

    When the issue occurred next time, please try to the following command line to reset the tcp/ip stack.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot

    Use this command line to delete all the mapped drive.
    net use * /Delete

    Then use this command line to re-map the drive.
    net use s: \\networkdrivepath /user username Pa$$word /p:yes

    Disable the "server" autodisconnect feature with the following command line "net config server /autodisconnect:-1".

    To troubleshoot whether the issue is related to the specific NAS device, please try to share a folder on another Windows system and try to map that folder to have a test.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com



    Thursday, June 16, 2016 3:21 AM
  • Meipo..

    Many thanks for the above.... 

    Though I was observing the techs screen processes, I evidently missed some steps as the fact that the Mapped Drive issue resolved itself. The frustrating part is that the instructions supplied failed me.

    May I ask if you ever tried your the steps your provided yourself for this exact issue? I'm in the process now of cloning several drives so I can sandbox the attempts and determine what actually works. 

    Just Googling "RED X" will result in an overwhelming array of suggestions, though 99.9% never worked across the board for all those who brought this issue to light.

    I'll certainly try your steps and report back as soon as I can.

    Marc


    Marc

    Thursday, June 16, 2016 1:33 PM
  • Hi Marc Rob,

    We are looking forward to your good news.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, June 17, 2016 7:56 AM
  • MeipoXu..

    So here's what I performed and the results thus far....

    I started with a newly cloned drive that was "virginal", i.e a fresh copy of WIN 10 with no software that might cause conflicts with the MAP X procedure.

    Following your suggested steps and the results of each:

    nbtstat -RR  : "Failed to Purge the NBT Remote Cache

    netsh int ip reset  : Reset Failed Run as Admin

    netsh winsock reset  : Requires Elevation to Admin

    Now its obvious that I am attempting to perform your steps without ADMIN privileges, and I would ask your help in the steps that would allow me ADMIN in this case.

    I would also like to confirm that any steps that you have offered require them to be performed BEFORE any attempts to Map Drives, Yes?

    The Map Drive issue (I'm sure you either did a search on the topic or knew of it Before) is  a tough one to crack as you obviously are at a disadvantage if you can't perform the steps yourself to confirm which ones are actually working towards the repair.

    I am not a Windows Network Pro so I appreciate your patience in providing steps that a lay person can apply.

    And out of curiosity, you had not suggested ANY of the steps the reps at MS provided. Do you believe they are not applicable in this case?

    Thanks!

    Marc



    Marc


    • Edited by Marc Rob Saturday, June 18, 2016 10:52 PM
    Saturday, June 18, 2016 10:52 PM
  • Marc, The Moderators are parrots, they repeat what they have heard before. They have no clue to your solution apart from the parrot chat. That is very sad but accepted as a part of the Moderator scheme.
    If you want help from professionals, please start over and tell me and the other professionals here the current details.

    Best regards, George


    Sunday, June 19, 2016 3:09 PM
  • George.....

    I appreciate your thoughts on the issue, and simply the fact is as I detailed on my opening request above, the issue of RED "X" on Mapped Drives Upon Boot is as old as Windows. Do a quick Google Search on "RED X Map drive" and you will see.

    The irony here is that a VERY competent rep at the MS Help Desk actually solved the issue within 20 minutes.. something that no one else ever had to my knowledge.

    I am presently still attempting to extract the step by step from him.

    Unless you are actually able to TEST the steps you advise, anyone can offer advice. It's the results that are needed of course.

    marc


    Marc

    Sunday, June 19, 2016 4:55 PM
  • The Help Desk at MS who originally solved this issue and was supposed to email me the specific steps to do this on subsequent installations has failed repeatedly to deliver what they promised. I've made 6 phone calls and spoken with various departments who continue to tell me that they will be contacting the original tech, but I am still waiting. 

    I've been cloning drives that are of WIN 10 with no other added software and using them as a test bed to try to replicate the steps that will solve this.. so far I cannot do so.

    The frustrating part here is that we have both the Case# and the Tech's name, yet most of the "Supervisors" I have spoken with have been somewhat reticent to resolve this by contacting the needed department. Some have flatly told me they cannot assist me further.

    Why is the KNOWN cure for this so elusive?



    Marc

    Thursday, June 23, 2016 1:23 PM
  • Hi George.B.Summers,

    I just post what I knew and I just want to be of help to OP`s issue. If you have good idea or you have some good ideas to troubleshoot this issue. I would appreciate it if you could share it with us. I am always eager to learn something.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, June 24, 2016 6:46 AM
  • MeipoXu,

    As you can see from my reply to you that the commands you offered as a possible solution require me to invoke "ADMIN"Privileges.....  This is a stand alone PC, so since you provided those suggestions, what is the steps/procedure to turn on ADMIN so I can test them?  

    I would appreciate your continued help in this...

    marc


    Marc

    Friday, June 24, 2016 1:15 PM
  • Hi Marc Rob,

    "what is the steps/procedure to turn on ADMIN so I can test them"
    Are you the administrator of this machine?
    If you are administrator of this machine, please right click the start menu and choose "command prompt(admin)".


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com


    Monday, June 27, 2016 7:08 AM
  •  "command prompt(admin)" does NOT allow me permission.  Sorry if I had not stated that earlier.

    All multiple attempts to execute your commands results in the same refusals.

    As I stated earlier, all attempts to perform these commands are done on a clean install with no other software installed.

    I have not placed ANY passwords in the machine whatsoever.

    What other ADMIN gates must be cleared before these commands are accepted?

     


    Marc

    Monday, June 27, 2016 2:13 PM
  • Hi Marc Rob,

    Are you the administrator of this computer(this is very important)? Have you got other administrator account on this machine?

    ""command prompt(admin)" does NOT allow me permission. "
    What is the exact symptom? Have you got any error messages or warnings?

    The key point is that we should have the administrator privilages of this computer. If you have login with the administrator account, I am afraid the present user account has been corrupted. Please try to create a new administrator account and login with that administrator account then try the steps again.
    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Tuesday, June 28, 2016 2:31 AM
  • The failure to gain access appears to be my error, as I was not using the ADMIN version of the Command Prompt.  What is more curious is that I’m using the SAME Win 10 version for my working copy that I use daily, and a 2<sup>nd</sup> version that has only the basic installation on it which I clone each time I test the procedure to MAP Drives. What I just discovered is that my “work” copy shows Windows POWER SHELL instead of the Command Prompt with and without ADMIN, but on my Basic TEST SSD, it only shows the expected Command Prompt. Why the disparity between the two copies as I made no changes (that I know of) to show either as a preference.

    UPDATE: I’m continuing using all the suggested command prompts from the original MS Help Desk call, plus those suggested in this column. I’m methodically testing them all to determine which actually solve the issue of RED X Access.

    I also found this informative page and I believe it addresses exactly the problems I have been encountering:   http://montgomeryminds.com/blog/mapped-drives-incl-net-use-missing-from-elevated-processes-eg-uac-cmd-run-as-administrator/

    Once I prove what steps work for me on a basic (no added software that might be interfering with the loading at boot-up) install, then I will need to test the same steps with a fully installed WIN 10 and  complete compliment of software as that will ultimately be the true test.


    Marc

    Wednesday, June 29, 2016 2:42 PM
  • Hi Marc Rob,

    How about the issue, is there anything to update?

    So you have run my suggested command lines? Did it work well?

    "and a 2<sup>nd</sup> version that has only the basic installation on it which I clone each time I test the procedure to MAP Drives"
    Are you using a cloned system?
    It is not recommended to use a cloned image. It may result in un-expected behavior.

    "What I just discovered is that my “work” copy shows Windows POWER SHELL instead of the Command Prompt with and without ADMIN"
    Right click the taskbar and choose "Properties". Check the following configuration.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, July 4, 2016 6:56 AM
  • This is the first I've heard that Image Clones can be faulty... And I would agree with that if one used software from some companies. However I've been using MACRIUM and have been very impressed with it's features and my reliable image and clone results. I've been dealing with Map Drive issues over at least 8 different hardware builds over the years and too many to count WIN operating systems... many not involving Clones so that issue is very low on my Radar of contributing errors.

    As far a Power Shell is concerned, I found the Registry entry to change back to the Command Prompt.

    It's been 2 weeks since my last call to MS Tech Support Desk so I ventured again to call them since all of my attempts failed to provide consistent Map Drive Boot using the various CMD prompts.

    After 4 attempts to get to the correct Help Desk I got through and supplied them the 3 Case #'s.... The Rep did a remote into my PC and he basically did the same steps as I could follow.... except 2 net use commands.  We did one Re-Boot and it appeared to hold but it sometimes requires at least 2 cold boots to expose any indication of Map Drive Red X failure. I thanked him, convinced he solved it and we ended the call.

    Sure enough, the issue returned the next Boot Up.... I immediately called back and after 4 more calls to get to the right desk (again) they could only schedule a call for today in a 2 hour window as they said the "Call Volume" was too busy at that time.

    So here I wait............


    Marc


    • Edited by Marc Rob Monday, July 4, 2016 2:31 PM
    Monday, July 4, 2016 2:29 PM
  • MS  Called as promised and after a short time of having to convince the tech that she should just NOT follow the same past instructions left for me, she went in a did a single REGEDIT entry:

    Locate:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters

    Name: KeepConn

    Type: DWORD

    Base: decimal

    Value: 65535

    I rebooted 5 times and it appeared all was now well, I thanked her.

    I turned off the computer for 30 minutes. Upon Re-Boot the problem returned. Did I mention I have another stand alone PC that I have done these same steps on to eliminate any chance of software/hardware issues

    I again placed a follow up call to MS and am now awaiting a return call.....


    Marc

    Monday, July 4, 2016 4:18 PM
  • RED "X" Mapped Drive

    If you search the Internet for a solution for RED "X" Mapped Drive, you will find old information that does not relate to the current problem of the RED "X" Mapped Drive. The problem is starting to show up again with faster Computers. Especially people who have a faster processor, memory and SSD in possession. They can get affected with RED "X" on Mapped Drive, depending on the type of network card. Because my Windows desktop starts up faster than my Network adapter I always got a Red "X" on my Mapped Drive.

    I simply changed "Wait for link" Default "value:Auto Detect" to "value:ON". Under Network card properties TAB: Advanced
    This ensures a forced network link negotiation, this setting should create network link, before your desktop starts.. Problem solved. At least for me. Hopefully this solution will pay for many people who have this problem.

    Saturday, February 24, 2018 11:22 PM
  • Microsoft never would respond to me and assist me in any further way to resolve this. The issue remains for many users on various levels. For a problem that is widely reported on hundreds of posts, it still amazes me the corporate policy on refusing to acknowledge these type of problems.  I was eventually able to do a work around by aiming my NAS Systems to the I.P. Addresses as opposed to the Mapped Drives via Win 10.




    Marc

    Saturday, February 24, 2018 11:38 PM
  • Thank you so much :) "Wait for link" Default "value:Auto Detect" to "value:ON". Under Network card properties TAB: Advanced worked for me !
    Saturday, April 14, 2018 10:38 AM
  • I'm wondering if this solution applies to my situation, for 2 reasons:

    1. I have a Win 10 Pro laptop and I have Mapped Drives to folders on my own laptop for when I connect into Remote Servers using RDP. For example I have the C:\Temp folder mapped as "T:" and in my RDP Properties I connect only that T: Drive when I connect into some servers. What is annoying to me is that before I can connect using an RDP I have to open Windows Explorer and click on the "Temp (\\desktop-####)(T:)" link. This instantly removes the Red X and allows me to connect that drive through the RDP. If I forget to do that the drive isn't available in the RDP. Kind of a pain.

    2. I don't understand the steps above and how to get there. I've looked at the properties of my Network Interface (Ethernet 3) but I don't see the "Wait for link" anywhere.

    Am I barking up the wrong tree here? Should this solution work for me or this a horse of a different color?

    TIA,
    Cullen

    Friday, May 3, 2019 1:21 PM
  • Cullen,

    Not being an IT PRO, I can tell you that Microsoft's solution consistently failed and they had no apparent interest at the time to resolve it.

    How I solve d the issue for myself is the following:

    I began using Synology's Products and there Software. I also use Allway Sync as a separate Backup Method.

    The issue was always the RED X as you are aware of appearing in the Windows Explorer Tree. When setting up my Backup Devices to either SYNC or Copy from the Mapped Drives in Windows 10 (and others using Window Mapped Drive Feature) I would use these RED X issue drive locations which caused all the frustration.

    When I did the following to BYPASS Windows Map Drives, I no longer had any problems.

    1) Using "Synology's Assistant" Desktop Setup for Mapping Drives appears to bypass the the Microsoft Link and even though RED X's still appear in the tree , Backups connect without any issues.

    2) For example when using ALLWAY SYNC (or for that matter any other software for Backup) I had always ran into the RED X issue because I attempted to point the Backup using the "Windows Folder" Choices,,, which of course is much easier to do. However this is the problem! This method required the Backup to have Access to the Folder that inevitably will have a RED X. 

    To solve this I finally realized that I should point the Backup using UNC NETWORK FOLDER PATH instead.

    This access route seems to bypass those folders in the explorer tree that are RED X'd, and accesses them without issue.

    Hoping this is of help and I explained my working method adequately.


     


    Marc

    Friday, May 3, 2019 2:06 PM