locked
Free busy status not working in Exchange 2003 RRS feed

  • Question

  • Hi,

    Free/busy status not working on our Exchange 2003 SP2 server. earlier we were on exchange 2000 & it was working fine. When i am trying to check properties of Schedule+ Free Busy Information public folder in EMC, mmc hangs & i need to close it forcely. there is no error related to public folder in eventvwr.

    Dhiraj

    Tuesday, April 12, 2011 1:42 PM

All replies


  • Make sure your Exchange Server is configured to talk to valid DC/GC , check TCP/IP properties on the new Exchange server to make sure correct TCP/IP settings configured.

    Make sure you have replicated your PF folders from E2000 to Exchange 2003 correctly. Check your application logs once again and if you find anything red post back her...

    Couple good links below might help you narrow your problem

     

    PF Info:

    In exchange 2000/2003 Free Busy is stored in dedicated public folder called SCHEDULE+FREE BUSY. This folder also contains several subfolders for each administrative group. When user publishes FB data (outlook calendar appointment, etc) this information gets stored suitable FB subfolder

     

    Public Folder Migration tool

    http://support.microsoft.com/kb/822895

     

    Schedule+ Free/Busy system folder is missing

    http://support.microsoft.com/kb/284200




    Oz Casey, Dedeal, Microsoft MVP - Exchange Server, MCITP (EMA), MCITP (EA), MCITP (SA) Visit smtp25.blogspot.com Visit Telnet25.wordpress.com   This posting is provided AS-IS with no warranties or guarantees and confers no rights.
    Tuesday, April 12, 2011 2:05 PM
  • Hi Dhiraj,

    Its looking that you are having issue with Exchange 2007 SP2 as you said, problem is with EMC. OZ has provided enough into to troubleshoot this, PLease post back updates.


    Anil
    Tuesday, April 12, 2011 6:09 PM
  • Thanks OZ.

    I don't have any error in Application logs related to Public Folder also ADSIEDIT showing correct entry for Sitefolderserver key. Infact tried to enable diagnostics logging for Public Folder Incoming & Outgoing Replication, but no events in Eventvwr.

    Anil,

    I am using Exchange 2003 SP2 not Ex2K7.

    Dhiraj

    Wednesday, April 13, 2011 7:21 AM
  • What else could be the reason & what to check

    Dhiraj


    Friday, April 15, 2011 9:18 AM
  • could you check and ensure that you have pointed the correct public folder store on the property of mailbox store where users are residing.

    Open ESM -> expand your Adminisrative Group -> Servers -> Storage Group

    Select the db from right pane and right click -> Properties, on the General tab -> Default public store.

    Also check if you have atleast one public folder store in your Administrative Group.

    Tarun Verma

    Friday, April 15, 2011 11:54 AM
  • Those settings are pointing to correct server. i am suspecting some permissions issue as it's having 100's of Exchange servers in the Exch Organization & this server is in a child site. as i have mentioned in my first post, when i clicked on properties of Public Folders, Schedule+Free Busy folder, mmc get hanged.

    Dhiraj

    Friday, April 15, 2011 2:16 PM
  • Hello,

     

    Try to fix the system folder’s DACLs by the PFDAVADMIN tool.

     

    a. Download PFDAVAdmin from:

     

    Microsoft Exchange Server Public Folder DAV-based Administration Tool

    http://www.microsoft.com/downloads/details.aspx?FamilyID=635be792-d8ad-49e3-ada4-e2422c0ab424&DisplayLang=en

     

    b. Double click it to uncompress the contents into a folder on the exchange server.

    c. Open PFDavAdmin.exe and go to File > Connect > Type the Exchange Server Name and GC name > In the Authentication box, type or use an user exchange administrator account. Then, in the connection field frame select 'Public Folders' and click OK.

    d. Expand System Folders -> "Schedule+ Free Busy".

    e. Right click on the Schedule+ Free Busy and select “Check DACL state”

    f. In the Fix Folder DACLs window, select “The selected folder and all subfolders”, “Read-Write” option then click “Execute” button.

    g. Please check if you can see the contents under the Schedule+ Free folder.

     

    Thanks,

    Simon

     

    Tuesday, April 19, 2011 1:47 AM
    Moderator
  • Seems you do not have public folder store in your administrative group which is causing this issue. You need to have at least one public folder store in administrative group where your mailbox stores are residing. We had this issue in our environment and sorted by setting up a PF replica to store free/busy info in same AG.

    Tarun Verma


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Tarun Verma Wednesday, April 20, 2011 12:16 PM
    • Unproposed as answer by DhirajHaritwal Wednesday, April 20, 2011 4:53 PM
    Wednesday, April 20, 2011 12:15 PM
  • Thanks Simon,

    PFDavAdmin showing some error while connecting to Public Folder. actually OWA/OMA also not working on this server. continously asking for password & after three time, showing access denied. below thread.

    http://social.technet.microsoft.com/Forums/en/exchangesvrdeploy/thread/581e16d1-b97f-432e-8ec3-7874fc07a22d

     

    Thanks, Tarun. i already have one Public Folder store on this server.

     

    Dhiraj



    Wednesday, April 20, 2011 4:52 PM
  • Hey, Simon. Any suggesion to resolve it.

     

    Dhiraj

    Tuesday, May 3, 2011 7:50 AM