I am an Administrator, but I keep getting errors like, "You require permission from Administrators to make changes to this file." RRS feed

  • Question

  • I have run into this more than once before, and I'm looking for a straight answer as to why this is happening.

    There is an avi file in C:\some folder, and I can't rename it.  The message is, "You require permission from Administrators to make changes to this file."  The problem is that I am using an administrator account, and when I look at the permissions for that file, Administrators is granted Full control.  (I don't know whether an administrator account implies membership in the Administrators group in Windows 7, but I am in that group, in this case).

    I also saw that Everyone had Read and Read & Execute permissions, so I tried just granting that group Full control.  This just gave the error message, "Unable to save permission changes on 3441.avi.  Access is denied."

    I just want to get an authoritative answer on why this happening and on how to fix it.  Thanks.


    I am able to access that file with user Administrator, but not with my own personal Administrators account.  I tried using Administrator to explicitly add my personal account to the permissions for the file, granting it Full control, but I am still unable to use the personal account to change the file; only Administrator works.

    • Edited by Panzercrisis Monday, May 12, 2014 1:18 PM more information
    Monday, May 12, 2014 1:15 PM


  • Hi,

    This situation happens because you are not the owner of this folder of file, The default owner of a file or folder is the person who creates the resource.

    Log on the computer with the account which created the folder of file, namely the owner, then you are permitted to modify the file or folder.

    Also, you can follow this article to assign ownership of files and folders:
    Tuesday, May 13, 2014 8:13 AM

All replies

  • Hello, 1. Are you accessing the path in witch the file is located by by UNC-path like \\servername\c$\test.avi or are you just accessing the file from the local path like C:\test.avi 2. If you click the file while holding down SHIFT-key and right clicking the file choose run as administrator and see what happens 3. Who is the owner of the file?
    Monday, May 12, 2014 3:49 PM
  • While assigning permissions, was your user account added to the ownership of the folder?

    Assigning permissions to full control alone does not work in all cases.

    Balaji Kundalam

    Tuesday, May 13, 2014 3:35 AM
  • Hi,

    This situation happens because you are not the owner of this folder of file, The default owner of a file or folder is the person who creates the resource.

    Log on the computer with the account which created the folder of file, namely the owner, then you are permitted to modify the file or folder.

    Also, you can follow this article to assign ownership of files and folders:
    Tuesday, May 13, 2014 8:13 AM
  • The issue is with UAC.

    You can disable the UAC feature that triggers this.


    Computer Configuration -- windows settings --Security Settings -- Local Policies -- Security Options

    Scroll down to:

    User Account Control: Run all administrators in Admin Approval Mode - Set to DISABLED.



    • Proposed as answer by Kappa-Gooner Friday, June 24, 2016 12:51 AM
    Wednesday, April 15, 2015 3:47 PM
  • I simply change the file's directory; for example move the file or folder you need to modify to Documents Library and then rename it. After that, move it again.
    • Proposed as answer by PhillyUrbs Thursday, June 20, 2019 1:55 PM
    Tuesday, September 29, 2015 11:28 AM
  • i set my User Account Control: Run all administrators in Admin Approval Mode - to DISABLED and i am still getting the "you'll need to provide administrator permission to delete this file" when i am trying to delete folders, or files. also my user account settings is set to "never notify". this is driving me nuts trying to delete my windows files from my windows 7 installation from a secondary drive that i had to replace because somehow my windows installation got corrupted and would not start or repair. what is this? apple? microsoft doesnt need to protect me from myself, if i needed someone to hold my hand, i would have gotten a mac.
    Friday, October 30, 2015 7:56 PM
  • I love that the only answer is to violate the security model that this feature is set to protect.
    Thursday, March 3, 2016 5:01 PM
  • The solution to this problem is by allowing/enabling "inheritance" in the security options of the folder and replacing all subfolders security permissions from the parent folder and taking the ownership in group or user level. If inheritance is disabled, and even the administrator is administrators group, it does not imply that subfolders also have same security settings. For me this resolved the problem, may be someone else will benefit from this fix.
    Sunday, March 6, 2016 6:35 PM
  • Turn off the preview pane in windows explorer - this causes the file to be locked.

    • Proposed as answer by James Hannam Friday, March 18, 2016 5:03 AM
    Friday, March 18, 2016 5:03 AM
  • I found that my problem ended up being to do with Google Drive.

    I was trying to clear some tmp files and it wouldn't let me remove them, no matter what I tried.

    It didn't take me long to realise I could just open the web interface of Drive and delete the folder, and Google synced the delete across my multiple systems. The file was created/synced by my laptop so there was no user on my current system (except Google, essentially) that would ever have permission to delete it.

    Tuesday, May 17, 2016 3:00 AM
  • Just rename the file and Delete it...Simple as that...

    • Proposed as answer by Nicster205 Tuesday, February 20, 2018 9:49 PM
    Monday, October 3, 2016 12:38 PM
  • ( typo in my user name btw..) I tried that run command and windows couldnt find it.

    Tuesday, October 25, 2016 10:39 PM
  • Just rename the file and Delete it...Simple as that...

    Didn't work for me. In my case it was a rebuilt computer with the hard disk taken from the original build. Even taking ownership of the folder doesn't seem to work.


    • Edited by mfr28 Sunday, November 6, 2016 11:44 PM
    Sunday, November 6, 2016 11:42 PM
  • I've seen this answer many times, so it must have some merit to it.

    What I would like to know is--what if the OWNER (me) creates the folder/file--but STILL receives this message?

    What excuse could there be, then?  

    It certainly couldn't be true that I am NOT the owner of the folder/file--if I am the one that actually creates it--right?  (Unless it's possible for someone to create a folder/file--yet NOT be the owner!)

    So, I (the owner of not only the folder/file--but also the machine!!!), am NOT able to effect any changes to my folder/file, even if I create it (and YES--I AM an administrator)--unless I receive permission from...wait for it...MYSELF!!!!

    Thursday, November 17, 2016 11:54 AM
  • ...what if it's ALREADY disabled?
    Thursday, November 17, 2016 12:24 PM
  • Thanks, the inheritance fix worked for me!  
    Saturday, December 31, 2016 5:55 PM
  • For me the problem was caused by the fact that I wasn't owner of the source file.

    This was NOT a problem at the destination folder level.

    It was a disk just attached to that server, that came from another VM.

    Hope that helps

    Tuesday, March 7, 2017 10:12 AM
  • I am currently having the same problem as the guy is, but in my case, I AM using the account that was used to download this file, which is also the administrator, yet I am not allowed to delete this file. Could you help?
    Monday, March 13, 2017 12:21 PM
  • This is my own PC, I own and am in complete control of every single thing on this PC, and it tells me I require permission from Administrators to make changes or access this file. WHY?! MY ACCOUNT IS THE ONLY ACCOUNT ON THIS PC!! I AM THE ONLY, FULL, COMPLETE ADMINISTRATOR OF THIS PC!!!!!
    Wednesday, March 15, 2017 10:18 PM
  • anyone find a fix for this yet? I have tried all the suggestions here.  I created the files. The owner was Administrators, which I am but I still decided to try making myself the owner.  The only thing that changed is the error.  Now the error says I need permission from myself instead of administrators. 
    Thursday, March 30, 2017 9:40 AM
  • i Solved it. Here it's How :

    right click on the folder then ( secuirty ) , ( Advanced ) then you will see the name of the owner and ( Change )

    Click Change then ( Advanced ) Then Click ( Find Now )  And change it to ur Admin Account. The only account u Use.
    Then Mark The Box ( Replace owner on Subcontainers and objects )

    Then you MUST CLICK ( Enable inheritance )

    And Mark The box Under-it. then ok and apply. and now delete the file

    Saturday, April 1, 2017 10:26 PM
  • BEFORE YOU BEGIN: Remember to never, ever let anything to do with computers cause you to compromise your peace of mind, let alone your sanity. No, keep the insanity at its source - where it originates: with the programmers and coders of the operating systems and software we are all essentially forced to use and/or have our lives interface with and, unfortunately, come to rely and depend upon.
    Thursday, April 6, 2017 9:14 PM
  • NONE of the above solutions work for me.  I've got an unwanted "backup" file created by that I cannot delete, move, rename, or open because I "don't have permission."

    Mine is THE administrator account on this machine; the ONLY account on this whole bloody machine!  When I first set it up, I disabled that crap UAC so I shouldn't even be experiencing the slightest bit of file permission management.

    If I try to change permissions via file properties, all I get is "You do not have permission to view or edit this object's permission settings."

    While I'm flying off the deep end about this, let me tell you what else about this whole experience is pushing me off the edge right now:

    I had to log into my rarely used hotmail account to comment here, and I was told that my account had been suspended for sending out craptons of junk mail.  I had to get a reactivation code sent to my phone to log in (it prompted me for the phone number), and then yet ANOTHER code had to be sent to me to view my "recent activity," but this time I had to confirm the secret phone number before they would send the code out.   Sounds real secure, Microsoft!  The recent activity?  ABSOLUTELY NO HISTORY ON FILE.

    Meanwhile, I've got a "featured message" in my inbox which is a phishing scam posing as Paypal.  That right there is some really effective and reliable detection of incoming scams and outgoing spam activity!

    Tuesday, June 6, 2017 9:27 PM
  • I struggled to delete a system folder (inside windows folder) I'm login as admin, but when when I set the folder ownership as admin, and apply the ownership to subfolders ('inheritance') I got the **"Failed to enumerate objects in the container. Access is denied"**. It should have worked but no, I guess it's a windows 10 bu. I finally made it by changing the folder ownership to the basic user, then apply it to subfolder and it works. I'm not shure but if you encouter the "Failed to enumerate objects..." I suggest you apply first the ownership as admin (and try it), then apply it to (non admin) "users", (and try it again). It's possible that changing the ownership 2 times soved a bug.
    Sunday, July 2, 2017 3:49 PM
  • My situation is much like many of the reports above. I am using Windows 10 Pro, Version 1607, OS Build  14393.1358.  I am the only user of the system using a local account that had Administrator rights, verified. 

    One manifestation of the problem: There is a shortcut on the desktop. I want to rename it.  When I try to rename the shortcut I get a box that says "You'll need to provide administrator permission to rename this file".

    The desktop is MY desktop, located in C:\Users\MyName.  When I check the Properties, Security tab for the Desktop all the permissions are checked for me (MyName (ComputerName\MyName)) and for Administrators (Administrators (ComputerName\Administrators).  All the Allow items are checked for both my name and Administrators for the Deskop.  From everything I can gather those all mean I should be able to do anything on the Desktop without further permissions.

    I checked the Properties, Security tab for the shortcut itself, it is all exactly the same as I described for the Desktop.  I have all rights.  I am the owner.  I can not rename it because I "need to provide administrator permission".  Or so it tells me.

    Saturday, July 8, 2017 5:44 PM
  • Come to think of it--ALL windows-based machines should come with a disclaimer:

    "Caution!  Continued use of the windows operating system WILL cause side effects such as: loss of peace of mind, loss of sanity, high blood pressure, extreme confusion and highly-aggressive behavior.  Consult your therapist before use."

    Sunday, July 9, 2017 12:17 PM
  • I get the same nonsense. More unnecessary "security" from Microsoft. Tried various solutions and they DO NOT WORK. Things like "Trusted Installer" are totally unnecessary for private use

    Friday, August 4, 2017 8:46 PM
  • You´re exactly right. I have assigned full ownership and still get these ridiculous messages

    Friday, August 4, 2017 8:48 PM
  • doesn't work
    Friday, August 4, 2017 8:50 PM
  • Dude... you can't rename it if you don't have permissions

    Wednesday, August 9, 2017 5:49 PM
  • I had a process that was "holding" the folder and got the same error. When I killed it with task manager I managed to delete the folder. Hope it helps someone! :)
    • Proposed as answer by Tyler Tran Thursday, June 21, 2018 12:23 AM
    Wednesday, August 16, 2017 11:56 AM
  • This worked great! Even after taking ownership of the folder (SoftwareDistribution for windows update issues) it still would prompt me to get permission...from my self. After the GPO edit I was able to edit the folder.

    Thanks again!

    Wednesday, August 30, 2017 4:43 PM
  • I struggled with an issue similar to this for a while, but mine wouldn't allow me to delete a folder that I had created myself because I "needed permission from (myself)". Eventually, what worked for me was selecting the "Shred" option from the right-click menu that my anti-virus (McAfee) provided- after the shredding and a restart, the folder deleted with no issues. I don't know if this would work as a fix for others, but it did the trick for me.
    Monday, September 11, 2017 3:31 AM
  • I just worked through an instance of this problem.

    The same issue occurred when I tried to modify some files on a remote server.  Working from my main computer, I connected to the remote server using the fully qualified path to the directory (\\{server_name}\TM1\TM1App\Files\) that I needed file maintenance.  When trying to copy/paste/delete/etc.,  I would get the same error.  Remote connecting to the server and browsing the file locally (C:\Data\NonCritical\0398\TM1\TM1App\Files\) gave me full connectivity and no errors when manipulating the files.

    It's not quite the same issue but may be connected.

    Friday, September 15, 2017 3:37 PM
  • 1. Open File Explorer.
    2. Browse and find the file or folder you want to have full access.
    3. Right-click it, and select Properties.
    4. Click the Security tab to access the NTFS permissions.
    5. Click the Advanced button.
    6. On the "Advanced Security Settings" page, you need to click the Change link, in the Owner's field.
    7.Click the Advanced button.
    8.On the "Select User or Group" page, click the Find Now button.
    9.From the search result, select your user account, and click OK.
    10.On the "Select User or Group" page, click OK.
    11.Click Apply.
    12.Click OK.
    13.Click OK again.
    14.Click OK one more time to complete this task.
    • Proposed as answer by Gdn S Thursday, July 30, 2020 8:59 PM
    Wednesday, October 11, 2017 4:14 AM
  • On Windows 10, i just tried this and all these other suggestions and none of them worked... it wont let me click "ok" after i change the security properties, i need permission to do even that... i'm trying to delete the Black Desert Online, i only downloaded it cuz i thought it was free to play. When the uninstaller finished it left 2 files behind in its designation folder, both are launcher files, one's an application an the other is an E_ file whatever that is. I tried all the different suggestions but none of them worked...  None of the property settings allow me to change anything. Not having permission when my account  and profile is the only one on here is fucking ridiculous.
    Tuesday, October 31, 2017 12:36 AM
  • This has been going on for years. Microsoft should be utterly ashamed of themselves. The orphaned files were created by a crash in the XPS printer driver. I AM the freaking Administrator. I DO give myself (and, indeed, the entire universe) permission to delete them, if only I could!

    I need working files with the same names, so I'll have to workaround it, something which isn't always possible : move everything else out to a new folder, and just leave these until the day I can take a hammer to the HDD - and even that probably won't get rid of them. If only I could make a suit of armour out of these indestructible files!

    Sunday, November 19, 2017 4:03 AM
  • I just used spybot to kill file. I had tried all the above. But in the end i just wanted to delete the file so I just used spybot kill file by right clicking, assuming you have spybot installed.

    It may help some of you.

    Tuesday, November 28, 2017 7:21 PM
  • This worked like a charm for me. Thank you so much!
    Saturday, December 16, 2017 11:07 AM
  • Thank You, This was the only solution that worked for me.
    Wednesday, January 10, 2018 5:43 AM
  • Wow! That actually worked! Thanks. It's insane that I have to do that, just to delete my own folder, but it worked! Thanks.
    Wednesday, February 7, 2018 12:12 AM
  • Wow! That actually worked! Thanks. It's insane that I have to do that, just to delete my own folder, but it worked! Thanks.
    Wednesday, February 7, 2018 12:12 AM
  • I run into the same problem and the files were created by me and saved in my documents folder. This time I suddenly can't save or edit anything in my own document folder! Permissions weren't changed. Yesterday I was in... today it won't let me in. It says My Documents don't belong to me.

    • Edited by Harht4God Thursday, February 8, 2018 7:25 PM
    Thursday, February 8, 2018 7:23 PM
  • This is a bit of a strange one that happens to me from time to time. I am not sure why this worked but I noticed one time that it was telling me I needed to have permission from [MyComputer]\\[Me], which was who I logged in as. It is actually the only account on this computer except the default [Administrator] who still has the default desktop because I have not logged into it for almost a year, so there is no chance to "Mistake" who I am logged in as. I also do not have a domain or domain account, so that stuck me as strange.

    But basically I just did a "switch user" then on the login screen I clicked on my account which it said was already logged in. once I was back in my desktop I could delete the files again just as normal.

    Like I said though this happens maybe once in 2 to 3 months so I have not really though about it much till today. I am not going to give it much though after this unless it starts to become a more constant problem.

    Sunday, February 25, 2018 9:49 AM
  • This happen when u start sharing folder and delete some sub-folder(inherated) from other device. An image or a shadow of the previously existing folder still exists so that's why u can neither give permission to that folder nor and delete or edit it.(as previously stated that actually that folder does not exists).
    Monday, February 26, 2018 9:05 AM
  • The simplest way if you have an non-encrypted drive is to boot form a Linux CD or DVD.

    Then mount the Windows hard drive

    Login to Linux as root and do as you wish to the Windows drive.


    • Good: You can also run virus or malware scan from Linux and cleanup the Windows drive
    • Bad: It will NOT work if your drive is encrypted. You get an error that Linux cannot read the drive
    • Ugly: It is a pain for some who are not familiar with Linux
    Tuesday, February 27, 2018 11:21 PM
  • Please read mine. There is no need to mess up Microsoft settings. They are there for a reason. Nor should you need to move stuff or use Google. If you read my reply here there is a simple non-disruptive way.

    Tuesday, February 27, 2018 11:30 PM
  • Hi everyone,

    I had the similar issue, where inheritance properties didnt work.  I was the only account (and admin) on the computer and every suggestion I tried did not work from this thread.  

    If you're still in need, I downloaded File Assassin by Malwarebytes (Prominent Antivirus company, look it up for your own peace of mind, I did)  File Assassin removed the file in about 3 seconds, and made me feel silly for wasting so much time on it.  You just have to type in the entire file in the directory and check delete file.

    It is a free program, and trusted by the Norton Community.

    Enjoy and good luck.  

    • Edited by Greenday2301 Thursday, March 22, 2018 9:13 PM
    • Proposed as answer by Greenday2301 Thursday, March 22, 2018 9:13 PM
    Thursday, March 22, 2018 9:13 PM
  • I have a folder under my downloads folder (C:\Users\Richard\Downloads\Photos (1)) that I can't delete. Tried the Malware File Assassin, but it only works on files and can't select the folder. I also tried the Spybot option, and while that one gave me a success window, the folder is still there. I'm logged in as Admin and all the same stuff everyone mentioned above. I also tried messing with all of the folder security options and none of those suggested helped either. I believe the file was made by another program at some point which is why it's a second photos folder. I don't know what program did that though and the folder is empty and just needs to be deleted. Any idea how to do this when all suggestions above failed?


    Saturday, April 21, 2018 11:33 PM
  • Didn't work for me
    Sunday, May 13, 2018 12:25 AM
  • That's worked, Thanks, but can it be bad for my pc security?

    Thursday, May 17, 2018 3:05 PM
  • YES. Thank you. I've been having this issue intermittently and had no idea what would cause it.
    Thursday, May 24, 2018 3:51 PM
  • Hi Kappa-Gooner,

    Many people suggest change the Owner of the folder or file, that's kind of awkward.  Your solution is much practical.  Thanks.

    Thursday, May 31, 2018 3:23 PM
  • Well,  genius, I'm having the exact same problem and I created the file and am the only user on the computer with the only account so I am the administrator. There is no other "default owner." 
    Friday, June 1, 2018 11:40 AM
  • I've come to the conclusion that--in situations like this, it's best to just live with the folder(s)/file(s) that we, as administrators (and some of us as owners), to which we have been denied access.  It's far less hair-pulling and stressful to just walk away--than to try to find a useful, yet workable solution.

    Perhaps, we should try speaking with a bonafide computer hacker.  They don't appear to have any problem, remotely reading and writing to our supposed "secure" systems.  I guess microsoft WILL allow writing to a directory and/or file--as long as it is done remotely?

    Maybe there is a "secret" security level ABOVE administrator, of which we are unaware?  There MUST be, how else would it be possible to:

    1.  Be the OWNER of the machine;

    2.  Be an administrator;

    3.  Take ownership of a folder/file;

    ...yet STILL receive the "access denied" error when attempting to delete/rename/move it????

    Saturday, June 2, 2018 12:59 PM
  • so what if i cant run GPedit.msc 

    any advise regarding that task is useless to me because i cannot run it 
    Sunday, June 24, 2018 12:04 PM
  • Up with this , Thanks Sir , Problem solved ...

    Tuesday, June 26, 2018 11:54 PM
  • These could be my words exactly.  Same damn thing.  Doesn't make sense.  If I install Windows I should automatically own it and be able to do whatever the hell I want to whatever the hell I want.  It's mine, damn it.
    Friday, July 20, 2018 12:05 AM
  • Sorry; NOT TRUE.

    I have just created a new file (.txt) and I get the same message when trying to transfer it from the Desktop to any other folder!

    Monday, July 30, 2018 12:52 PM
  • there is neither "Local Policies" nor "Security Options" in Win10 (Settings/Security)!
    Monday, July 30, 2018 12:55 PM
  • and after I've gone through all of this - EVERY TIME I RUN INTO THIS PROBLEM (10 or 12 TIMES A DAY),

    I'll be ready for the shrink....


    Monday, July 30, 2018 1:10 PM
  • So I have wasted about three hours, trying EVERYTHING that's listed here: TO NO AVAIL.


    Monday, July 30, 2018 1:18 PM
  • NO: IT'S NOT!

    I have just created the file - and advanced properties does list me as owner!

    Monday, July 30, 2018 1:22 PM
  • Ok, Ok, so you, Liu Wade ARE with Microsoft.

    BUT YOU'RE ANSWER DOES NOT HOLD WATER:  The files in question ARE created by me and PROPERTIES does list me as "Owner"!!!

    So what IS your answer? Your solutions? 

    As you can readily see, quite a lot of us are struggling not to be driven NUTS by this nonsensical problem!

    Monday, July 30, 2018 1:28 PM
  • Sometimes, to solve a STUPID problem--it takes a STUPID solution!
    Monday, July 30, 2018 11:52 PM
  • This, of course, does not work in my case as I am trying to follow the advice and steps given at

    Any ideas?

    Monday, August 27, 2018 5:12 PM
  • I've tried that too, no help. I even get to the point where it keeps telling <g class="gr_ gr_54 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" data-gr-id="54" id="54"><g class="gr_ gr_68 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="68" id="68">my</g></g> I can't move/delete/rename the file and when I try EVERYTHING and it rejects it, the 'Properties' window won't go away
    Friday, August 31, 2018 3:51 AM
  • Sorry about that, tried a 'soft return.'

    My point is:

    My computer.

    My purchased copy of Windows 7 Professional.

    Only person EVER to log on to the computer.

    Why don't I OWN my files?

    --- Why not a setting that allows me to OWN every folder/file on the machine?

    Friday, August 31, 2018 3:55 AM
  • I have a single account for Windows. I am the administrator. How is it possible I'm not the owner of a the files on my computer?

    Wednesday, October 24, 2018 4:49 PM
  • That worked for me. But first had disable inheritance and remove a few repeated accounts that were causing the mess. Then deleted it ok.

    Saturday, November 10, 2018 6:55 PM
  • I encountered the same problem.  For me the problem was that my trying to get my top level folder to 'replace all child object permission entries with inheritable permission entries from this object' just didn't work.  However, when I did the same thing dropping down a layer and using advanced security settings (properties>security>advanced), I could then replace child object permissions, delete all the files and folders contained in it and then delete the folder.  My user only had 10 subfolders one layer down so it didn't take too long.

    No idea why it got into this mess though.

    Hope this helps others

    Cheers, Al

    • Proposed as answer by Alan Lee 2 Thursday, January 3, 2019 5:03 PM
    Thursday, January 3, 2019 5:03 PM
  • It's very simple. Microsoft is f***** six ways from breakfast. Their software has become so complex, and customer support has been reduced to asking questions from outsourced "experts" who don't even have a handle on what user-friendly, simple solution would work for the average user. It's like they expect us all to be able to recompile our own kernel before we can understand the answers they provide - that is, when they're not totally wrong or unrelated to the original question.

    I have the same problem. No answer here is useful to me. I don't give a rat's south-40 about inheritance or permissions; all I know is this is my computer, there's only one account, I'm the administrator, and I should be able to access, move, rename, or delete any file I want to without all this hassle. Judas Priest, Microsoft is hardly worth the hassle any more.
    • Proposed as answer by robertd9031 Tuesday, September 17, 2019 6:20 PM
    Saturday, January 12, 2019 11:03 PM
  • Okay this has now consumed most of my day maybe 7 hours of my time!!!

    I have tried to get my old parents computer to work so they have a working backup,, there tech must have been correct as now I realise he gave up and they bought another computer.

    There are two programs with the same issue of not being able to acces user profiles to delete them,

    Thunderbird is installed but will not work as comes up with missing profiles. (don't ask me why they use thunderbird, but theyre used to it)

    Now I need to delete the profiles ini file in the hidden files user directory so it can reset itself

    However it comes up with the same error as above.

    My parents are the only user of the computer and are the only admin.

    Howevever when you go into  right click properties options etc there is no way to enable the delete authority on the file it comes up with access denied..... The only one that shows that does have the right to delete is "trusted installer" whatever that is. If you try look at enable enheritance and other boxes they are simply greyed out and cannot be opted.

    Okay so If I go into to change the properties of the file or folder, its the same thing, the authority do delete is greyed out in the advanced options. any attempt to try gives back the access is denied message.

    I had tried the go to start type run then  gpedit.msc   fix mentioned above,,,

    to change under//  windows settings / security settings / local policies / security policies/ 

    run all admins in administrator mode

    this doesn't work either...  

    If I try to kill with spybot that doesn't do anything either.

    At this point I have basically given up... The above suggestions may work for other users who don't have files burried in hidden directories like myself..

    The computer at the time was using a fully paid version of Nortons. I have since deleted and installed other antivirus to see whether it picked up anything but hasn't shown any issues.

    IN ALL OF THIS IT AMAZES ME THAT MICROSOFT seems to be silent on the issue...... Normal people like myself shouldn't have to spend a whole day to sort through issues like this....... It really is a joke....

    You have answers like this but of course doesn't work and doesn't answer a thing!!!!!

    Solved,,, well haven't moved onto the other program,,, but at least in the case of thunderbird

    type into bottom left of screen.....  thunderbird.exe -p then you can delete the profile....

    So solved but is more like a workaround!!!!!


    Monday, January 14, 2019 11:11 AM
  • It would be really nice if microsoft supplied a means to turn off all of this permissions crap!

    (I mean, REALLY turn it off--not by way of the ACCOUNT settings, because that, too, doesn't work!)

    It's getting to a point where I can't even install an application--because of the apparent lack of permissions and/or privileges!!!! 

    (Application doesn't have permissions to write to and/or create the necessary directories/files that it needs!)

    Thursday, June 20, 2019 5:43 PM
  • thank you

    Wednesday, June 26, 2019 1:06 AM
  • So you want a method to turn off all Security on the file, which then circumvents the reason Security exists on the files in the first place?  Hmmm....

    Wednesday, July 10, 2019 12:25 PM
  • Your information is incorrect. I am the owner, the creator of the file, the folder. Every file and folder on the entire drive in fact. I am THE administrator for this computer and SHOULD have permissions to do anything I want. BUT I DON'T. How does that make sense? Oh, and every folder and file has been created UNDER the same account and usename. Also I'll just mention all the changes I'm trying to make are on a local drive no network involved. Also I took ownership of the folder just to check even though I can't imagine how I wouldn't be already.


    • Edited by DH888 Sunday, September 1, 2019 2:52 AM
    Sunday, September 1, 2019 2:45 AM
  • Your information is incorrect. I am the owner, the creator of the file, the folder. Every file and folder on the entire drive in fact. I am THE administrator for this computer and SHOULD have permissions to do anything I want. BUT I DON'T. How does that make sense? Oh, and every folder and file has been created UNDER the same account and usename. Also I'll just mention all the changes I'm trying to make are on a local drive no network involved. Also I took ownership of the folder just to check even though I can't imagine how I wouldn't be already.


    So, it's NOT just me?

    I never understood the concept of being "restricted" from accessing one's OWN personal file(s)!!  If I want to (for example) delete EVERYTHING under the WINDOWS directory of MY machine, although it may NOT be a good idea--I should be able to do it!!!

    Sunday, September 1, 2019 8:25 AM
  • Unable to rename the file. It says you do not have permission to perform this action.
    Saturday, September 7, 2019 2:08 PM
  • When this happens to me i boot up linux. Linux does not care about windows permissions.

    you do not have to install linux. Run a live version from dvd or usb flash drive. you can do anything with any file or folder you wish.

    • Edited by Treyiii Friday, September 13, 2019 1:19 AM
    Friday, September 13, 2019 1:08 AM
  • when this happens to me I do not fight with it. I have one right now. I boot to linux and take care of it.

    you do not have to install linux. run a live version from usb or dvd will take care of it.

    • Edited by Treyiii Friday, September 13, 2019 1:15 AM
    Friday, September 13, 2019 1:12 AM
  • When this happens to me i boot up linux. Linux does not care about windows permissions.

    you do not have to install linux. Run a live version from dvd or usb flash drive. you can do anything with any file or folder you wish.

    Friday, September 13, 2019 1:21 AM
  • ...and now, this "permissions virus"--is making its way into other areas of my life:


    • Edited by robertd9031 Tuesday, September 17, 2019 1:04 PM
    Tuesday, September 17, 2019 1:03 PM
  • Not always the case. I am the owner of the folder, an administrator, and the only one who uses this pc and I recently received this message on an empty folder that I created when attempting to delete it. 
    Tuesday, September 17, 2019 5:53 PM
  • This whole discussion for a way to rename an .avi file?

    C'mon Microsoft.  An OS doesn't have to be this difficult. 

    • Edited by tmgrood Sunday, December 8, 2019 6:31 PM
    • Proposed as answer by Nick Smuts Monday, December 16, 2019 7:59 AM
    • Unproposed as answer by Nick Smuts Monday, December 16, 2019 7:59 AM
    Sunday, December 8, 2019 6:29 PM
  • THANKS John !  After spending all morning and much of the afternoon in fruitless attemts to delete two empty folders with WIN10 and the suggested solutions posed by others, I stumbled onto your suggestion to use spybot (Spybot-S&D).  5 minutes after completing the installation, those two useless folders are now history.

    Thanks again!

    Monday, December 9, 2019 10:54 PM
  • Hi there.

    After spending a morning trying to copy, move, del, rename a autorun.inf file on an external.

    User Account control setting in Windows 10 pro. Set it to the lowest possible setting and I could do all of the above.

    Please, don't ask me why. I'm replying here as it was one of the forums I searched for a solution.  



    Monday, December 16, 2019 8:05 AM
  • Totally random troubleshoot.

    I have a new install windows 10 pro 1909 (OS Build 18363.657)

    During install I configured the OS one way then I screwed up the the username so i created a new admin account once and deleted the old account since I didn't want to reinstall.  When I went to enable Hyper-V on the new account via windows features I got an error message that lead to a google search that landed me on this thread.

    You're write up fixed this immediately on first attempt, thank you for your sharing of knowledge.

    Sunday, February 23, 2020 3:44 PM
  • I am the Administrator, I am the Owner of the File, I am the owner of the Folder, I am an Authenticated User, and I'm a Regular User on my system and I still get this error.   If I assign Ownership to "Joey", it says I need Administrator Approval.  If I assign Ownership to "Administrator"  it says I need permission from "Joey".  If I assign Ownership to "User" it says I need permission from "Administrator".  It's a vicious cycle.  No matter who I assign ownership to, it says I need someone else, even though I am all of those People.
    Monday, February 24, 2020 10:40 PM
  • What finally worked for me:

    1. Changed owner in 'Advanced settings' to my current user id (not just 'Administrators' account).

    2. elevated DOS prompt - deletes most of what is there.

    3. Click into folders that are left, it properly asks for admin permission

    4. elevated DOS prompt or delete in Explorer - gone.

    Thursday, March 5, 2020 12:57 PM
  • because its a stupid feature
    Thursday, July 9, 2020 7:10 PM
  • I have read all the posts, and none of the solutions work for me. 

    Right-click > properties > security  I do not see the ownership summary, but a message "You must have Read permission to view the properties of this object"  ... clicking advanced gives the same message...   "click continue to attempt the operation with administrative permissions" > click > "you do not have permission...". 

    I can't even see the owner: "unable to display current owner" or change owner "you do not have permission..." 

    In elevated dos box "access is denied". 

    Explicitly adding owner and propagating: "Failed to enumerate objects in the container: Access is denied"

    I cannot change directory into this directory, I cannot see who the owner is, I cannot do anything with it.

    Maybe there's a process still using it?  I'll reboot and see if that helps.

    1 hour 24 minutes ago