none
Access to HIS 2.0 via IIS process returns An application unsuccessfully tried to connect a session using TN3270 (hr=0x80040218) RRS feed

  • Question

  • Greetings,

    I have WCF service deployed under IIS 7 that is unable to connect to HIS 2.0.  The error message (in the subject above is) 

    An application unsuccessfully tried to connect a session using TN3270 (hr=0x80040218)

    I can successfully access both the TN3270 emulator and an custom windows form application logging in using the Same user account that is currently associated with the application under IIS.

    Is there a short list of places where security needs to be configured to allow this to work from IIS ?

     

    Thanks in advance,

     

    Gary Bartlett

    Tuesday, June 29, 2010 7:13 PM

Answers

  • I was able to resolve the issue, I missed the fact the AppPool was not running under the identity of the user that is configured for HIS.

    Thanks to everyone for your suggestions.

    Gary

    • Marked as answer by gbartlett Wednesday, July 14, 2010 6:19 PM
    Wednesday, June 30, 2010 7:52 PM

All replies

  • Gary,
    In web.config of your application add the <identity
    impersonate="true" userName="" password="">. Use the Server
    user Credentials for this.
     
     
    Also check out
    integrator-log-event-id-6-and-event-id-24-warnings.aspx
     
     

    Neil Pike
    Wednesday, June 30, 2010 6:02 AM
  • Neil 

    Thanks for the suggestion.  I added the impersonate=true using the same credentials that are setup in the Session Integrator Server NT Service, but I am still getting the same error.  I know that the impersonate tag is being used because I modified it to use a bad password and the WCF service would not start.

    With regards to DCOMCNFG - I added this same user as described in the blog posting.

    As I mentioned earlier, I can login to the server with these credentials and successfully use both the 3270 emulator and a windows form based solution that I developed, so I think everything from a HIS standpoint is setup.

    One thing to mention is that I did not configure Data Integration or Transaction Integration on this HIS Server since I did not have a local database instance to use.  I don't think that should matter (especially since the windows form solution works fine).

    Any help is appreciated.

    Gary

     

    Wednesday, June 30, 2010 1:37 PM
  • Hi Gary,

    Have you already taken a look on that article written by Stephen : http://blogs.msdn.com/b/sjackson/archive/2008/11/21/why-does-session-integrator-log-event-id-6-and-event-id-24-warnings.aspx ?

    Best Regards


    Steve Melan - BCEE
    Wednesday, June 30, 2010 2:01 PM
  • Yes I have looked at that article and followed the steps related to DCOMCNFG.  

    One question - in the article step #5 is

     In the Access Permission dialog box, click Add to add the Server user context.

    What exactly is "Server user context" ?  I made sure the user I am using is setup there  Allow for Local and Remote Access.

    Note I am using the same credentials for the impersonate as the Session Integrator Server is using.

    Wednesday, June 30, 2010 2:28 PM
  • Session Integrator might fail when you use two different user accounts - The Session Integrator features currently exhibit problems when the Client application and the Service component are running under two different user accounts. The problem is related to a DCOM callback that is made from the Server components to the client. The Server user account must have Local and/or Remote access to the DCOM classes.

    Server user context : on that dialog add the user under which the Session Integrator service is running.

    Best Regards,


    Steve Melan - BCEE
    Wednesday, June 30, 2010 7:36 PM
  • I was able to resolve the issue, I missed the fact the AppPool was not running under the identity of the user that is configured for HIS.

    Thanks to everyone for your suggestions.

    Gary

    • Marked as answer by gbartlett Wednesday, July 14, 2010 6:19 PM
    Wednesday, June 30, 2010 7:52 PM
  • You're welcome !

    Could you please flag the question as answered !

    Best Regards,


    Steve Melan - BCEE
    Wednesday, June 30, 2010 7:56 PM