none
configserver process status showing dead. RRS feed

  • Question

  • Hello Experts,

    I have FS4SP and SP 2010 both are on same server and i have standalone deployment configured.

    I am able to perform searches, but when i check the status of services using nctrl status command on fast search shell then configserver process status showing dead.

    I restart all the processes but still enable to run configserver process. still it showing dead status.

    Thanks and Regards,

    Uday

    Wednesday, September 7, 2011 7:05 PM

All replies

  • Hello Uday,

    Anything in the Windows event log, or in <FASTSearchFolder>\var\log\syslog?

    Have you tried: "nctrl stop configserver", and "nctrl start configserver"?

    Regards,
    Mikael Svenson 


    Search Enthusiast - SharePoint MVP/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Wednesday, September 7, 2011 8:08 PM
  • Hi Mikael,

    Tried the commands as you suggested, nctrl stop configserver, this stop the process successfully but when I executed the command (nctrl start configserver) it gave a message like "Process configserver terminated shortly after starting"

    Event Viewer shows

     

    System
    - Provider
    [ Name] FAST Search Config Server
    - EventID 1000
    [ Qualifiers] 0
    Level 2
    Task 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2011-09-09T05:25:24.000Z
    EventRecordID 12302
    Channel FAST Search
    Computer dev-env.devhome
    Security
    - EventData
          Error loading universal config file: ConfigParseError: Line 1, Column 0, Error: not well-formed (invalid token)

    Thanks and Regards,
    Uday

    Thursday, September 8, 2011 4:57 PM
  • Hi,

    My initial thought was that <FASTSearchFolder>\etc\CSConfig.xml was corrupt, but a corrupt CSConfig.xml gives me "Error loading configuration file", not "Error loading universal config file".

    You could open CSConfig.xml and check that it is indeed in UTF-8 mode. If that file is not the culprit you have to try to hunt down which xml file has become corrupt, and is prevented from loading. If you use for example Process Monitor, and filter on what configserver is trying to load, you might figure it out.

    Or if someone know which file is the "universal config file" then they will save you the time :)

    Regards,
    Mikael Svenson 


    Search Enthusiast - SharePoint MVP/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Thursday, September 8, 2011 7:00 PM