locked
App-V 5 package of MS Dynamics AX 2009 crashes on exit RRS feed

  • Question

  • Hi All,

    I sequenced MS Dynamics AX 2009 With App-V 5. The application works fine but I get an appcrash when I exit the application.

    I know it has nothing to do with the back-end. When I launch the app without a back-end and I close the first application window, I get the same error.

    I tried all Local interaction settings and also I tried to terminate all child processes. No succes...

    Any ideas how to go from here?

    This is the error message I get:

    -----------------------------------------------------------------------------------------------------------------

    Description:

      Stopped working

    Problem signature:

      Problem Event Name: APPCRASH

      Application Name: Ax32.exe

      Application Version: 5.0.593.0

    Application Timestamp: 4831b016

      Fault Module Name: mscorwks.dll

      Fault Module Version: 2.0.50727.5485

      Fault Module Timestamp: 53a121fa

      Exception Code: c0000005

      Exception Offset: 00001978

      OS Version: 6.1.7601.2.1.0.272.7

      Locale ID: 1033

    Read our privacy statement online:

     

    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409


    If the online privacy statement is not available, please read our privacy statement offline:

     

    C:\Windows\system32\en-US\erofflps.txt

    ---------------------------------------------------------------------------------------------------------------------------------------

    Wednesday, February 11, 2015 10:29 AM

Answers

  • I found out what the problem is...

    I opened a command prompt in the virtual environment and ran the application from the command line.

    Then when I close the application all goes well. So it seems that the virtual environment closes too quickly for the application to shut down properly.

    When the command prompt keeps the virtual environment running, the application can shut down properly.

    Thursday, February 12, 2015 8:50 AM

All replies

  • I found this pretty interest thread about that errror:

    https://community.dynamics.com/ax/f/33/t/116129.aspx

    A Citrix User was claiming the same type of behavior...

    Are you using Global Publishing or User Publishing? Have you tried Mounting the application to the local machine or are you using Shared Content Store mode?

    Anything re-directed in your environment?

    Have you attempted to run a ProcMon trace on Shutdown? Perhaps you can see if the application is reading\writing to files outside of the VFS or perhaps inside the VFS in a user location e.g. AppData (in which case you could try excluding that folder from sequencing and test again)


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, February 11, 2015 5:19 PM
  • Collecting the user mode dump would be the next logical step to find out what is happening. It could be something interfering with the process exit. 

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Thursday, February 12, 2015 5:37 AM
  • I found out what the problem is...

    I opened a command prompt in the virtual environment and ran the application from the command line.

    Then when I close the application all goes well. So it seems that the virtual environment closes too quickly for the application to shut down properly.

    When the command prompt keeps the virtual environment running, the application can shut down properly.

    Thursday, February 12, 2015 8:50 AM
  • Hello,

    Any remaining process that needs to be specified within TERMiNATE CHILDREN?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, February 12, 2015 8:31 PM
  • We're having the same problem.

    Dynamics AX 2009 is crashing on closure and I can't find any real solution to the problem. We've tried with both using cmds and vbscripts inside the package that makes sure it virtual environment doesn't close before the application closes. But it doesn't seem to fix the problem, it still crash on closure even before the vbscript/cmd finishes.

    A real solution would be greatly appreciated.

    Wednesday, December 9, 2015 1:22 PM
  • You could create a vbscript which starts the application (instead of the direct shortcut), and stays open until the exe shuts down.
    Wednesday, December 9, 2015 1:44 PM
  • We did that, didn't help. As I said in my previous post.

    Wednesday, December 9, 2015 3:05 PM