locked
Task Scheduler - Cannot view task history RRS feed

  • Question

  • Suddenly the Administrator account cannot view the task history of all tasks on my computer.  It says: The user account does not have permission to view task history on this computer.  It happens even if the task Author (as shown in the General tab) is Administrator.

    Task Scheduler

    An hour ago it was still working.  How can I regain the rights to view task history?  Thanks.

    Friday, July 30, 2010 1:59 PM

All replies

  • Have you tried logging out or rebooting since the problem happened?

    You could also try running it as an administrator. Right-click on it in the Start Menu and choose "Run as administrator"

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    • Proposed as answer by Ron McCarthy Tuesday, May 14, 2013 1:53 PM
    Friday, July 30, 2010 2:14 PM
  • When I log in anew, I am able see the History tab and the list of events for about one second before the tab clears itself and a dialog box pops up that says:

    Task Scheduler
    ---------------------------
    The user account does not have permission to view task history on this computer.
    ---------------------------
    OK  
    ---------------------------

     

    Friday, July 30, 2010 2:26 PM
  • Try to repair the install of your operating system. This is the only solution for your problem.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    Friday, July 30, 2010 2:29 PM
  • I wouldn't follow Malek's advice here, as a repair may be completely
    unnecessary; however if you choose to go that route, open an
    administrative command prompt and execute
     
    sfc /scannow
     
    Are you getting any errors or warnings in the event logs related to
    scheduled tasks?
     
    If you enable the logs for the TaskScheduler service
     
    Start -> Search, type eventvwr
     
    On the view menu, select "Show Analytic and Debug Logs"
     
    Expand the node "Applications and Service
    Logs\Microsoft\Windows\TaskScheduler" Right click the Debug, Diagnostic,
    and Operational logs and select Enable log. I would also set the Maximum
    log size between 5 and 10 MB to ensure that relevant events are not
    overwritten or omitted while we are looking at a relevant time frame.
     
    Can you give us more info about the system, is the Administrator account
    for the local system or for a domain? Is the system a standalone server,
    member server, or domain controller?
     

    -- Mike Burr
    Friday, July 30, 2010 5:08 PM
  • Thanks.  System is a standalone Server 2008 SE with SP2.

    I am logged in remotely using the Administrator account.

    All my tasks were all running in the Administrator's account.  I was creating another non-administrator account to run my tasks when suddenly this problem happened.

    Friday, July 30, 2010 5:21 PM
  • After the creation of the account, what have you done?

    Best regards.

    Friday, July 30, 2010 5:45 PM
  • I merely tried switching the account of one task to the new account.  But it didn't work as there appear to be insufficient rights even though I included the account in Allow run as batch and Allow run as Service.  Then I included that account in the Administrators group and the problem happened.

    Anyway the server has now gone cranky. Rebooting...

    Friday, July 30, 2010 5:56 PM
  • a. Rebooting cleared the problem.

    b. But it came back after my PC was disconnected abruptly from the RDP session and I went back in. 

    c. Logging out and re-logging in cleared the problem.

    d. But History then refused to show any new activity, ie it got stuck at approximately the time of b above, even though each task showed a more recent and the latest Last Run Time.

    e. Rebooting again cleared the problem.

    Saturday, July 31, 2010 3:41 PM
  • I said too soon.  Suddenly the does not have permission to view history pop-up came up again.
    Saturday, July 31, 2010 3:52 PM
  • Haven't you tried to repair your operating system install?

    Best regards.

    Saturday, July 31, 2010 4:06 PM
  • I'd check the permissions on C:\Windows\Tasks and C:\Windows\System32\Tasks folder.

     

     


    Regards, Dave Patrick .... Microsoft Certified Professional -Microsoft MVP [Windows]
    • Proposed as answer by amtwister Tuesday, March 4, 2014 5:31 AM
    • Unproposed as answer by amtwister Tuesday, March 4, 2014 6:09 AM
    Saturday, July 31, 2010 4:53 PM
  • Haven't you tried to repair your operating system install?

    Best regards.


    I don't intend to.  I don't think Server 2008 is that fragile.
    Sunday, August 1, 2010 7:57 AM
  • I'd check the permissions on C:\Windows\Tasks and C:\Windows\System32\Tasks folder.


    The group Administrators is already there.

    Or do you mean the account that is running the task?  Anyway I have just added.

    Sunday, August 1, 2010 8:01 AM
  • Does it change anything if you logon at the console?

     

     


    Regards, Dave Patrick .... Microsoft Certified Professional -Microsoft MVP [Windows]
    Sunday, August 1, 2010 3:09 PM
  • I am having a very similar problem and have been unable to resolve it. I'd hate to hijack an old thread, but I see no reason to duplicate the diagnostic steps already taken. And am holding out home the original poster was able to solve his problem and remembers the solution.

    I can see that the tasks are in fact running. The Last Run Time and Last Run Result are populated in the list of tasks. But I am unable to see any history before a specific date two weeks ago. But after opening a few items I will start getting the error message "The user accoun does not have permission to view task history on this computer". Even though this is an administrator account and I am running the Task Scheduler as an administrator.

    The one thing I can add is maybe this - The related incident I can find in the event log is a login failure for an account which may have needed to be reset. This account is sometimes used to run scheduled tasks and the person may have failed the login when choosing the account for the scheduled task to run under.

    Any help with this problem would be appreciated more than you know.

    Thursday, October 6, 2011 4:35 PM
  • I could really use some assistance on this problem. Does anyone have any suggestions on a route to take to fix this?
    Wednesday, October 19, 2011 3:12 PM
  • I've seen this same error on our production task servers.

    The issue we found was that the server was running low on disk space and it can't open the log files on edit more to update them when a task runs.

    I've cleared disk space but that doesn't resolve the problem because the above incident caused Task Manager to disable login.

    after making room on the disk, open Event Viewer.

    Open Applications and Services Logs.

    Drill down the following path :   Microsoft / Windows / TaskScheduler

    you should see an Operational node inside TaskScheduler.

    Right click on it and select "Clear log..."

    Right click on it again and select properties.

    make sure "Enabled Logging" is checked and adjust the maximum size of the event log to something that will fit confortably on available disk space ( 10% of available space is a good option).

    Now, select "Overwrite events as needed ", which will prevent the file from loking up again if the log grow also past its own limits.

    Stop and Start Task Manager if you had it opened.

    RUn a test task and you should be able to see the task history.

    Hope this helps!

    Friday, June 21, 2013 5:07 PM
  • "The issue we found was that the server was running low on disk space and it can't open the log files on edit more to update them when a task runs."

    This was our problem as well. Thank you
    Sunday, January 27, 2019 6:06 PM