none
Access denied in default.aspx for users having appropriate permission in SharePoint 2010

    Question

  • Hi Team,

    We are getting access denied error in default.aspx for users having access

    We copied the page to Site pages Library and we are not getting access denied error.

    We coopies the pages to Pages Library, we are getting access denied error. Please help

    Friday, March 24, 2017 8:22 AM

Answers

  • Access denied issue got resolved by adding batch="false" in compilation tag in web.config

    https://blogs.technet.microsoft.com/stefan_gossner/2012/07/20/sharepoint-memory-leak-caused-by-incorrect-web-config-settings/

    Monday, April 03, 2017 11:34 AM

All replies

    • Log into the SharePoint 2013 Central Administration site.
    • Open Application Management.
    • Open Manage web applications.
    • Select the web application that has the problem and open Authentication Providers from the ribbon bar.
    • Open the authentication provider zone that you are using (it is probably just Default).
    • Check the Enable anonymous access option and then Save the Authentication settings. It can take a minute or two to save the settings, so after you click Save just wait for the Authentication Setting window to close.
    • After the Authentication Setting window closes and you can see the Authentication Providers window again then try to access your root site again and now you should be able to get to the home page without any Access Denied errors.
    • Now we don't want to leave anonymous access enabled so once again open the authentication provider zone that you are using and now uncheck Enable anonymous access and then Save the Authentication settings.
    • You should now still be able to access the root site of your web application and the issue has been fixed.
    • Edited by Stark365 Friday, March 24, 2017 12:19 PM
    • Proposed as answer by Kazarludba - MCP Friday, March 24, 2017 2:14 PM
    Friday, March 24, 2017 12:18 PM
  • Any microsoft link which says there is no major imapct on sharepoitn security based on enabling and disabling anonymous access

    Friday, March 24, 2017 1:36 PM
  • Hi Athulya,

    Out of the box getting access denied is not expected. i am sure there must be some customization. If you are not comfortable with refreshing the anonymous access then you may also detach and re-attach the content database(Refer - https://technet.microsoft.com/en-us/library/ff628582.aspx).

    Please make sure to take necessary backups and snapshot.

    Thank you..

    Friday, March 24, 2017 2:20 PM
  • Thank you Stark and Kazarludba

    We observed users with read permissions are getting access denied in default.aspx.

    We added browse directories permission in read permission level. and now users are not getting access denied error.

    Adding Browse directories permission has any side effects which may imapct the security. 

    Please help


    • Edited by Athulya Pillai Monday, March 27, 2017 7:03 AM spell mistake
    Monday, March 27, 2017 7:03 AM
  • Access denied issue got resolved by adding batch="false" in compilation tag in web.config

    https://blogs.technet.microsoft.com/stefan_gossner/2012/07/20/sharepoint-memory-leak-caused-by-incorrect-web-config-settings/

    Monday, April 03, 2017 11:34 AM