locked
Incoming Email in Library breaks editing in Office RRS feed

  • Question

  • Hi everyone,

    we're currently evaluating incoming email for document libraries in detail and stumbled across the following issue inSharePoint 2010. The scenarios occur in English and German environments, the server local (for formatting) is German in either case:

    1. Set up incoming email, routing, drop folder, address for library, etc.
    2. Send email to document library with a .docx/.xlsx attachment. They are properly processed.
    3. Open the library's Word/Excel file in Office 2007/2010 (client). A warning will appear as yellow bar:
      'To save to the server, correct the invalid or missing required properties.'
    4. There are no missing properties, this occurs in a vanilla document library which as "Title" as the only field and is optional.
    5. Office will display the "Document Properties" top pane which allows filling in column fields from SharePoint (just "Title" here in our case).
    6. To properly save the document, I have to delete all custom XML/Metadata.
    7. After deleting all custom XML/saving and reopening the file again in Office, the situation is unchanged.

    These are the steps to reproduce this issue, it has occured in 3 environments so far. To recapitulate:

    1. This is not about setting up Incoming Email. Mails work, attachments get added.
    2. There are no external/BCS/Metadata/whatever fields involved. The issues can be seen on a stock out-of-the-box Document Library with no frills.
    3. This issue does not occur in SharePoint 2007 with neither Office 2007 nor 2010. However, in SharePoint 2007, the "Document Properties" top pane is never displayed when opening the file in Office 2007/2010.
    4. The issue has been tested with docx/xlsx-files in all SP/Office 2007/2010 combinations.
    5. The issue does not occur with manually uploaded files.
    6. It has been tested on an Office/SharePoint SP1+CU10/2011 system.
    7. When changing the library to use Content Types and examining, it can be seem that the content type "Document" has been extended by several columns for Email. These columns however are not listed for the library, nor can they be displayed.
    8. I strongly suspect that those columns are responsible for the issue.

    Does anyone else have this issue? Or is anyone else able to receive Office2010 files in a library by mail and edit them in Office afterwards?

    Kind regards,
    Adrian


    Monday, November 21, 2011 2:31 PM

Answers

  • Apparently, the following does provide a solution:

    1. Go to library settings, advanced settings, enable management of content types.
    2. Check, which content types have the additional email columns.
    3. Option 1: Set the email columns from Optional to Hidden.
    4. Option 2: Delete the existing content types and add them again from site content types.
    5. In content type, enable displaying the property panel in office.
    6. Test again, it is now possible to edit emailed documents in office.

    I think self-proposing answers is frowned upon, so I'll leave this issue open and wait for confirmation.

    Kind regards,
    Adrian

    Update: Instead of recreating the content type, it is also possible to solve the issue by setting the Email columns to Hidden. Thanks, Nico!

    Thursday, November 24, 2011 5:04 PM