none
SDELETE 2.02 stuck on Purging MFT files

    Question

  • Hi, i've tried to clean the free space on a VM disk to retrieve some unused space for the VMDK file.

    The drive is about 250GB in size with 180GB of free space.

    I downloaded SDELETE version 2.02 and tried to launch the command : sdelete64.exe -z d:

    SDelete v2.02 - Secure file delete

    Copyright (C) 1999-2018 Mark Russinovich

    Sysinternals - www.sysinternals.com

    SDelete is set for 1 pass.

    Purging MFT files 7841% complete

    The process is running since about 24 hours...

    Is it normal that the Purging MFT step takes so long and runs above 100% like this ?

    Thanks to get back to me as soon as possible.

    Thanks

    Wednesday, January 30, 2019 5:39 PM

All replies

  • Hmm this strange. I will take a look. 

    This is the stage where sdelete walks through the MFT and deletes any MFT resident files. This can take a long time and we had several people think the delay was a hang so for 2.02 I added the counter you are seeing there. Seems like there is an error in the calculation somewhere so I will take a look and see if I can figure out what's going on. 

    If it's still running would you consider taking a process dump (you can do this directly from task manager by right clicking on the sdelete process)? If so please contact me offline at syssite@microsoft.com and I will provide you with an upload location

    MarkC (MSFT)

    Thursday, January 31, 2019 7:43 PM
  • I run sdelete on a virtual machine.

    The purging MFT goes to 100% when the drive was not compressed

    After compress the system drive, the purge of MFT files seems never stop... Actually more than 4000%

    Monday, March 18, 2019 10:21 PM
  • I'm also having this same problem. Do you still need logs? Also, is this miscalculation just for output to the console? (meaning the actual process is still working correctly?) Please let me know, asap.
    Saturday, March 30, 2019 8:03 AM
  • Hello

    I was actually looking at this problem last week after another user provided us with a dump file. From the dump we can see that there was an issue with the calculation for the number of clusters in the MFT. I am working on a fix for this and also looking to address the performance issue so will provide an update shortly.

    Thanks for raising this and for your continued patience.

    MarkC (MSFT)

    Monday, April 1, 2019 8:10 AM