locked
an unhandled exception occurred in the silverlight application sharepoint 2010 RRS feed

  • Question

  • An unhandled exception occurred on the page when Try to create the Announcement List in SP 2010 site which is upgraded from SP 2007,

    Any body have faced this issue?
    Tuesday, February 23, 2010 4:01 PM

Answers

  • OK Guys... Resolved this...

    I guess it's a product bug. Just Enable the Security Validation from Manage Web Applications --> General Settings (from ribbon).

    Silverlight Application is unable to connect to the WCF endpoint configured by the product for enabling Client Object Model, if Security validation is set to Off.

    Enjoy...

     


    Anupam Shrivastava
    Tuesday, June 8, 2010 9:05 AM

All replies

  • Hi,

    I also have this problem. This occurs on four different Sharepoint 2010 servers, so I believe the problem is on my client.  It only fails in IE8, FireFox works OK. I did uninstall Silverlight an installed it again, but still the same error...

    The Silverlight box is loading and counts to 99%, then "an unhandled exception occured in the silverlight application"

    Regards
    Roar Kristiansen
    Skill AS

    Wednesday, February 24, 2010 5:46 PM
  • OK Guys... Resolved this...

    I guess it's a product bug. Just Enable the Security Validation from Manage Web Applications --> General Settings (from ribbon).

    Silverlight Application is unable to connect to the WCF endpoint configured by the product for enabling Client Object Model, if Security validation is set to Off.

    Enjoy...

     


    Anupam Shrivastava
    Tuesday, June 8, 2010 9:05 AM
  • This solution worked for me also.  Thanks!

    Thursday, July 22, 2010 8:26 PM
  • Worked for me too! Thanks.
    Thursday, September 16, 2010 6:01 PM
  • You can mark this thread as answered, if it resolved your issue. :)
    Anupam Shrivastava
    Friday, September 17, 2010 6:15 AM
  • You can mark this thread as answered, if it resolved your issue. :)
    Anupam Shrivastava
    This works for me
    Thanks, Sam
    Tuesday, November 2, 2010 8:48 PM
  • I will vote for closed if you tell me how to navigate to the setting.  I am using SharePoint 2010  and don't see a choice for Enable Security Validation at the menu location in Central Administration.  Maybe a screenshot would help.  Thanks,

    Tricia Wilcox Almas


    Tricia Wilcox Almas

    Found the right config page and this setting does indeed resolve the Silverlight issue.  I vote for answered!

    Saturday, November 20, 2010 3:48 AM
  • Tricia, you need to browse to your web application overview page: Application Management --> Manage web applications. Select the web application you'd like to change the settings of. Click General Settings in the ribbon. Half way the Web Application General Settings dialog, you'll find the Web Page Security Validation section. Turn the Security validation On.
    Maarten Eekels
    Lead SharePoint Architect
    Blog: http://www.eekels.net
    Twitter: maarteneekels
    Wednesday, December 1, 2010 8:31 AM
  • Does anyone know how to fix this if you want to keep the Security Validation set to "Off"

    Friday, March 4, 2011 7:01 PM
  • HMAC:  can you simply turn off Security Validation while you create the site?  I tried other methods to handle this before the solution was found, and tried others since then and haven't had any luck.   

    On the Ribbon, by the way...you see General Settings two times:  its the blue gears Icon on the left of that ribbon section , and then the Text Item in the Drop Down. The drop down is what you have to select. I'm voting "Resolved" for Anupam, but getting pretty interested in HMAC's questions and ones like it.  Any ideas on what a wider forum topic would be good for dealing with Silverlight?  After I saw Telerik and VIBlend's control suite, and talking with some colleagues, we're thinking of using Silverlight a lot more.  Obviously not, though, if there's funky security problems that make it hard to use it if you clients are going mobile in SharePoint.

    Bruce (aka dansker34...)



    • Edited by Bruce Byers Thursday, April 28, 2011 5:58 PM Had to edit reference to the icon. Posting clarifies problem with finding the dropdown and thanks to Anupam.
    Thursday, April 28, 2011 5:52 PM
  • I put the exact steps with screen shots to fix the problem here:

    http://imperfectit.blogspot.com/2011/05/error-unhandled-exception-occured-in.html

    Hope this helps


    Imperfect IT - Because when does anything work the way it's supposed to? http://imperfectit.blogspot.com/
    • Proposed as answer by Imperfect IT Tuesday, September 6, 2011 3:44 PM
    Wednesday, May 4, 2011 6:29 PM
  • http://imperfectit.blogspot.com/2011/05/error-unhandled-exception-occured-in.html


    Imperfect IT - Because when does anything work the way it's supposed to? http://imperfectit.blogspot.com/
    Wednesday, May 4, 2011 6:30 PM
  • It works!!! Thanks-
    Monday, September 5, 2011 9:52 PM
  • thanks man alot

    it works for me too

     

    Tuesday, September 20, 2011 12:46 PM
  • Hi Anupam,

    I also faced the same problem and after enabling the security validation, it got resolved. Thanks for posting the solution.

    But i am not sure if it will break any other thing while solution / web part deployment.

    Thanks

    Mahesh


    Thanks Mahesh Dhinge

    • Proposed as answer by Mahesh Dhinge Sunday, June 17, 2012 7:45 AM
    Sunday, June 17, 2012 7:45 AM
  • Thanks.. this Worked .. :)
    Thursday, June 28, 2012 6:23 AM
  • Thank you!
    Tuesday, July 24, 2012 7:37 PM
  • it work for me...thanks

    Thanks and Regards

    Er.Pradipta Nayak
    Visit my Blog
    ISHIR

    Friday, August 24, 2012 3:15 PM
  • I am having this issue, but we already have Security Validation turned ON. We have many site collections, but it only happens on one of them. Not only that, but it only happens on the top level site collection and not any of the subsites that have already been created. This issue just popped up for this one site collection recently and was not an issue before, which is how all the document libraries and subsites were created in the past. Anyone have any other solutions????
    Wednesday, September 19, 2012 9:33 PM
  • It happened to me once. The site collections started showing this error while security validation was already ON. I just toggled it to OFF and then ON which resolved the issue.
    Wednesday, September 19, 2012 9:37 PM
  • Hi Anupam,

    This worked for me. thanks a lot

    Yudy

    Thursday, September 27, 2012 3:52 AM
  • Thank you so much!  This solved our issue!
    Friday, October 19, 2012 7:13 PM
  • sim funciona 100% obrigado
    Thursday, November 27, 2014 3:03 PM