locked
6.3 installation error: IIS Port Invalid RRS feed

  • Question

  • "IIS Port InvalidThe IIS prot for the default directory is invalid."

    I looked on the help site and there are two "fixes" for this problem, one to change an environmental var and the other to muck around with your metadata.  I did both and still get the error.  Is there any way to actually install ProClarity 6.3?

    Thanks.

    Friday, January 18, 2008 1:30 PM

Answers

  • On further exploration it appears as if it is IIS that is screwed up.  I apparently made the cardnial mistake of believeing Microsoft support pages.......I should have known better.  I did have an SSRS report server running on this machine and now it no longer functions....it has lost it's web service identity.....now I'll have to figure out how I set that up nearly a year ago.....hey THANKS Microsoft!

     

    Friday, January 18, 2008 8:27 PM

All replies

  • Hi John,

    Sorry to hear that you are experiencing diffuculties installing the Analytics Server.  Can you provide some additional details, OS version, any infrastructural or environmental details that may be pertinent or helpful to our attempts to troublehshoot the issue?

     

    Thanks,

     

    Bob

     

    Friday, January 18, 2008 7:26 PM
  • OS - Vista Ultimate 6.0.6000

    I have IIS Admin Service running.

     

     

    There are two reported problems that trigger this error message on the support site....one deals with setting a C:\temp environmentla var and the other deals with setting the metadata.  I tried them both with no change.

     

    I just downloaded ProClarity from MSDN yesterday.

     

    The first time I tried to load it the error message said it couldn't shut down IIS.  I manually shut down IIS and it didn't like that.  I restarted IIS and it produces the current error message.  I've rebooted several times, tried to find how to uninstall/reinstall IIS with no success.

     

    Friday, January 18, 2008 7:39 PM
  • On further exploration it appears as if it is IIS that is screwed up.  I apparently made the cardnial mistake of believeing Microsoft support pages.......I should have known better.  I did have an SSRS report server running on this machine and now it no longer functions....it has lost it's web service identity.....now I'll have to figure out how I set that up nearly a year ago.....hey THANKS Microsoft!

     

    Friday, January 18, 2008 8:27 PM
  • Make sure SSL is disabled.  Install to the Default Web Site on port 80 and make sure the site is running.  Check that other sites are not interfering with the Default Web Site or port 80 by refreshing IIS and verifying that the Default is still running.  Use Metabase Explorer, part of the IIS 6 Resource Kit, to verify that the Default Web Site has and ID of 1, and that its ServerBindings value at W3SVC node is set to :80 and that there are no other characters in the string.  If you have changed Web Site IDs, make sure that the Web Site you are installing to has ID 1.  Restart IIS and retry the installation. 

     

    Also, try changing the Environment Variables:
    Right-click My Computer, and then click Properties.
    On the Advanced tab, click Environment Variables.
    Under the User Variables for Administrator, locate either the TEMP or the TMP variable (both may exist).
    Click the TEMP or TMP variable, and then click Edit.
    Change to c:\temp (make sure the directory exists on your machine; if not, you'll need to create it).

     

    If these steps do not work, you may have a corrupt installation of IIS and may want to remove and reinstall IIS or retry the installation on a clean OS test image.

     

    -Joey    

     

     

    The resource kit can be found here:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=56fc92ee-a71a-4c73-b628-ade629c89499&DisplayLang=en

     

    Wednesday, March 12, 2008 5:28 PM
  • This is BAD!

     

    After receiving this "invalid" message, I Googled the error and found this thread. After reading it I understood what the problem was.  In this case it was my SharePoint Intranet site that got clobbered.

     

    This is not only a bug in the ProClarity setup (It should have tested port 80 before attempting to do ANYTHING!) but is a tremendous inconvenience to us.

     

    Wednesday, October 22, 2008 1:56 PM
  • We agree this portion of the install could be better.  In fact, there have been discussion for years about also providing a feature in the install that allows for installation to a site other than the default, generally port 80 site, but for the various reasons that go into making software development decisions, it hasn't made it in to date.  One of those reasons is that the message for the invalid port is generally a support issue, but doesn't actually disrupt applications already running on the server.  If in your case you've found that the ProClarity install actually disabled your Sharepoint site, and you can reproduce the problem on a test machine, I would request that you open a support case for that, as that should most certainly be looked at.  If it does indeed turn out to be a product issue, the cost of opening the case should be refunded to you.

     

    Please let me know if you have any questions on this at all.

     

    Thursday, November 13, 2008 1:00 AM
  • Ben

    We are installing ProClarity on Windows 2008 R2 64-bit,  is running SQL 2005 64-Bit and MOSS 2007 64-bit.

    We are having the same problem as reported, tried all the setting issues described here without success, we still get -

    "IIS Port InvalidThe IIS prot for the default directory is invalid."


    Defaut IIS sharepoint works without issues - we can see the Sharepoint team site home page.

    http://localhost/default.aspx


    We're installing as administrator etc... pretty vanilla install to see how the pieces work.

    Anyway appreciate any suggestions to get the install up.

    Nilesh
    Sunday, October 25, 2009 6:12 PM
  • After bit more reviewing yes we did install by updating the default server port.



    Sunday, October 25, 2009 8:16 PM