none
"The Exchange server address list service failed to respond. This could be because of an address list or email address policy configuration error". RRS feed

  • Question

  • Hi,

    we are running SBS server 2008, in which we are facing issue with exchange 2007,from few days while creating any new mailbox we are recieving following error

    "The Exchange server address list service failed to respond. This could be because of an address list or email address policy configuration error".

    we followed below article to solve this issue but no use, we restarted the system attendant service and restarted the server.

    http://forums.msexchange.org/m_1800463003/mpage_1/key_/tm.htm#1800463003

    please any help to resolve this issue,

    Regards

    Asha

    Wednesday, May 23, 2012 7:44 AM

Answers

All replies

  • Hi

    After researching, the Generally solution is restart system attendant, but you said it could not solve the problem.

    Another reason that migh cause this error is the DC is having more than 15 characters.

    Also, this issue willl also happen if The email address policy was not upgraded after migrating from e2K3 server.

    I fould a solution that might be helpful, after Restarted the exchange system attendant services, please run the command to upgrade policy

    Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients

    And then, Ran commands the following commands to upgrade the address lists

    Set-GlobalAddressList "Default Global Address List" -RecipientFilter {(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))}

    # All Users
    Set-AddressList "All Users" –IncludedRecipients MailboxUsers

    # All Contacts
    Set-AddressList "All Contacts" –IncludedRecipients MailContacts

    # All Groups
    Set-AddressList "All Groups" –IncludedRecipients MailGroups

    # All Public Folders
    Set-AddressList "Public Folders" –RecipientFilter { RecipientType -eq 'PublicFolder' }

    Hope it helps

    Cheers


    Zi Feng

    TechNet Community Support

    Thursday, May 24, 2012 5:54 AM
    Moderator
  • Hi,

    our exchange server 2007 is not migrated from exchange server 2003, its installed with SBS server 2008. i am getting below error after running above commands.

    [PS] C:\Windows\System32>Set-EmailAddressPolicy "Default Policy" -IncludedRecipi
    ents AllRecipients
    Set-EmailAddressPolicy : The operation cannot be completed on the default e-mai
    l address policy.
    At line:1 char:23
    + Set-EmailAddressPolicy  <<<< "Default Policy" -IncludedRecipients AllRecipien
    ts

    [PS] C:\Windows\System32>Set-GlobalAddressList "Default Global Address List" -Re
    cipientFilter {(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq
     'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExch
    DynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'public
    Folder'))}
    Set-GlobalAddressList : You cannot perfrom the operation on the default global
    address list object, "Default Global Address List".
    At line:1 char:22
    + Set-GlobalAddressList  <<<< "Default Global Address List" -RecipientFilter {(
    Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or
    ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistrib
    utionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))}

    Regards

    Asha

    Thursday, May 24, 2012 10:37 AM
  • Hi

    Did you check the DC name, is it more than 15 characters.

    Also, due to it is on SBS 2008, you could also post your question on SBS Forum and find some help there

    http://social.technet.microsoft.com/Forums/en/smallbusinessserver/threads

    Cheers


    Zi Feng

    TechNet Community Support

    Friday, May 25, 2012 6:06 AM
    Moderator
  • Hey Zi,

    I ran into the same error message while trying to make changes to Exchange Server 2007 (migrated from 2003 and worked great for about 4 months).  EXBPA is really clean with all HelthCheck, COnnectivity and Readiness checks, disabled Chimney on all Exchange and DC/GCs, all lists have checked out fine (gone through a lot on other forums).

    Exchange is functioning very well with everything else, mailflow is fine.  I still have a OAB issue where the files are not being created and continuing to investigate that BUT everything else has been working great since we migrated.  In February I was able to make changes at will (enable/disable OWA, POP3 access for example) but then 1 month ago I tried to re-enable access for one user and that is when I discovered this issue.

    DCDiag is not reporting any sync issue between DCs (2 2003 and 1 2008 - all GCs and the 2008 server holds all FSMO roles)...

    I was able to allow access to that specific user by removing restrictions in ADSIedit (Protocolsettings) and that allowed the user to remotely log onto their account through OWA to change their Out of office settings...

    I uninstalled SP3 RU10 to test if this was the issue but still ran into this issue.  I did the obvious restart the SA but to na avail... Running out of things to try, it won't even let me recreate new address list...

    Any Thoughts?

    Muhnster,


    Muhnster


    • Edited by Dan Muhn Tuesday, April 16, 2013 5:11 PM
    Tuesday, April 16, 2013 5:09 PM