locked
Office 2007 Saving Issue on Windows 7 Public Release RRS feed

  • Question

  • I'm running Windows 7 32-bit (same result on 64-bit) Professional of the actual release (access to it early due to Enterprise Licensing). I have Office 2007 Professional installed.

    When saving a Word (.docx) file, Excel (.xlsx) file, or PowerPoint (.pptx) file, occasionally (more often then not) it will attempt to save the file, then prompt you again for save location. It will then auto change the name of the file from FileName.docx to FileNam1.docx. After you save (the 2nd time), FileName.docx is deleted and FileNam1.docx is the saved file. The work around is to just rename the file before you save the 2nd time.

    It is rather annoying, sometimes it will fail to save the first time, prompting you to manually go back and save the second time. It does not matter what I am saving to (hard drive, different partition, folder location, flash drive, etc). This happened to me in the Beta (most recent build 7100 I believe) on both 32-bit and 64-bit editions. I've tried this on numerous different computers (custom builds, Dell PCs, Laptops, etc) all having the same effect.

    I am shocked that no one else has come across this issue, either that or people aren't running tests like the situation in which I am using it. This is obviously a problem (compatibilty issue) between the OS and the Software package. With less than 1 month to go, would not be a bad idea for M$oft to look into this issue to try to patch it before the public actually gets their hands on this puppy.

    Otherwise I LOVE WINDOWS 7!
    Monday, September 28, 2009 6:19 PM

Answers

  • Hi,

    Based on my experience, this kind of issue may be related to the following factors.

    Third party add-in
    Antivirus software conflict
    File name length

    I recommend you to switch any security software on your computer and test to see if it works. Meanwhile, you start Windows in Safe Mode to launch Office and save files, then tell us how it works. You can also try to save files with the format of name: name+number.docx.

    BTW, I noticed that this issue occurred on both 32-bit and 64-bit of  Windows 7 build 7100. Have you tried to install Office 2007 Professional in Windows Vista compatible mode to see how it behaviors?

    Best Regards.
    Dale
    • Marked as answer by hatty324 Wednesday, September 30, 2009 12:47 PM
    Wednesday, September 30, 2009 4:47 AM

All replies

  • Hi,

    Based on my experience, this kind of issue may be related to the following factors.

    Third party add-in
    Antivirus software conflict
    File name length

    I recommend you to switch any security software on your computer and test to see if it works. Meanwhile, you start Windows in Safe Mode to launch Office and save files, then tell us how it works. You can also try to save files with the format of name: name+number.docx.

    BTW, I noticed that this issue occurred on both 32-bit and 64-bit of  Windows 7 build 7100. Have you tried to install Office 2007 Professional in Windows Vista compatible mode to see how it behaviors?

    Best Regards.
    Dale
    • Marked as answer by hatty324 Wednesday, September 30, 2009 12:47 PM
    Wednesday, September 30, 2009 4:47 AM
  • Wow....that was simple! Why didn't I think of that? In my haste, on each computer I tried this on, I had installed a copy of Adobe Acrobat Pro (in some cases 8.X, in other cases 9.x). With each version the issue applied.

    I went into Word and removed the Adobe Acrobat COM Add-In, closed and re-opened Word and problem went away.

    One interesting thing....after removing the COM Add-In, and closing the application (e.g. Word, Excel, PowerPoint), the application closed with an error. After that, no more errors on saving, opening, closing, etc.

    I did the same above to Excel and PowerPoint. In case someone comes across this down the road, here is the exact fix:

    1. Open each application (Word 2007, Excel 2007, and PowerPoint 2007) individually.
    2. Office Pearl > Word Options (or Excel/PowerPoint depending on which app you are in).
    3. Select the Add-Ins tab on the left.
    4. On the bottom under Manage, make sure COM Add-ins is selected. Click Go.
    5. Uncheck Acrobat PDFMaker Office COM Addin.
    6. Click OK.
    7. Close Out. If prompted with error, cancel out of error.
    8. Re-open application, problem solved.
    Wednesday, September 30, 2009 12:47 PM
  • Might have been premature....still having issue. Will try other suggestions.
    Wednesday, September 30, 2009 5:02 PM