none
ADS MA : the XML exported file (export to log file) doesn't export Distinguished Name in the attribute member for a group RRS feed

  • Question

  • Hello,

    I am facing a weird issue during the export of a group to a log file (xml).

    I have configured my ADLDS management agent such as the export run profile exports data into a XML Ffile:

    Everything is fine in the XML, I see my new accounts, the attributes updated for accounts but for an unknown reason the group which should contains accounts does not contain the DN values.

    It contains the tags <dn-value> and <dn> but <dn> is empty

    e.g:

    <delta operation="update" dn="CN=GroupX,OU=Users,DC=ZZZZ">
     <anchor encoding="base64">XDSQDQDQ</anchor>
     <dn-attr name="member" operation="add" multivalued="true">
      <dn-value>
       <dn/>
      </dn-value>
      <dn-value>
       <dn/>
      </dn-value>
     </dn-attr>

    During the export, FIM updates the attribute "member" of the group:

    Member attribute seems to be caught by FIM during synchro profile and export profil bt not translates correctly in the final xml file.

    Any ideas?

    Thanks for your reply.

    Thursday, December 5, 2013 3:33 PM

All replies

  • That is odd. Try using CSExport to export the cs objects in a Pending Export state. Do you get the same results? If it gives you the data that may be another way to accomplish your task.

    But this sounds like a bug, err I mean a job for Microsoft Support!


    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    • Proposed as answer by UNIFYBobMVP Thursday, August 13, 2015 11:44 AM
    Thursday, January 2, 2014 6:22 PM
  • Thinking the same thing as David - sounds like a bug - but that's curious because I've never had a problem with the AD MA doing exactly the same thing, albeit with FIM R1 most recently.  What version of FIM are you using, and have you checked the release notes of any subsequent versions to see if any such issue is mentioned?

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using FIM Event Broker for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Friday, January 3, 2014 1:15 PM
  • I just noticed this odd behaviour myself. We have an old ILM 2007 installation that I need to migrate to FIM 2010. The testing process makes extensive use of exporting to log files, but when I tried to run the same test scripts against FIM 2010 they failed. One of the failures was because of these missing member dn:s.

    I'm running this on FIM2010 R2 version 4.1.3419.0. This is on a 64-bit Win2k8 system.

    Monday, January 27, 2014 1:37 PM