none
Synchronization Service Installation Failure - Error 25009 - sp_dbcmptlevel RRS feed

  • Question

  • Hello,

    The title pretty much explains it all. I'm using SQL Server 2014 as a remote hosting DB server. I have the FIM Service and Portal installed and had no issues. But when installing the Synchronization Service, specifying the same DB server as the FIM Service and Portal, I get the following error:

    Error 25009.  The Forefront Identity Manager Synchronization Service setup iszard cannot configure the specified database.  Usage: sp_dbcmptlevel [dbname [, compatibilitylevel]].  I get this message at the very end of the install process.

    I would imagine I'm going to get an answer that the synchronization service is not support on SQL Server 2014, but I'm looking for a workaround.  The only think I can think of is the synchronization service database is supposed to run in a compatibility mode no longer support by SQL Server 2014.

    But, I checked the installation I have on SQL Server 2008 R2 and the Synchronization service database is running is 2008 compatibility mode, just like the FIM Server db on the SQL Server 2014 installation.

    Anyone have any ideas?


    • Edited by Greg Wilkerson Friday, May 15, 2015 2:55 PM Added information
    Friday, May 15, 2015 2:52 PM

All replies

  • Hi Greg,

    FIM Service is indeed not supported on SQL 2014.

    Supported platforms:

    Microsoft SQL Server 2008 64-bit Standard or Enterprise, Service Pack 1 (SP1), SQL Server 2008 R2, Standard or Enterprise or later.
    noteNote
    Microsoft SQL Server® 2012 is supported when using FIM 2010 R2 SP1 or later

    I am not aware of any workarounds. Maybe installing on SQL 2008 R2, backup and restore to 2014 would work (remember about SQL jobs also), but I don't know.


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Friday, May 15, 2015 4:13 PM