locked
Power BI Analysis Services Connector Failed, unknown error RRS feed

  • Question

  • Hi there, i´m installing the Power BI AS Connector con a server following the next guide:

    http://blogs.msdn.com/b/powerbi/archive/2015/03/11/power-bi-analysis-services-connector-deep-dive.aspx

    No matter what i always get the next error, when stablishing the conn.

    Registering the Analysis Service Connector failed: Unknown [UTC TIMESTAMP: 31/03/2015 04:08:54 PM]

    For reference:

    - AS Server domain joined

    - Local AD synced with Azure AD

    - PBI Connector with valid user credentials.

    Sorry for my bad english.

    Thx in advance.


    Tuesday, March 31, 2015 4:25 PM

Answers

All replies

  • Hey Oscar,
    Sorry about this. Can you share a screenshot of the error message? Are you getting this error message when you configure the AS Connector?

    Thanks,

    Mini

    Tuesday, April 7, 2015 4:41 PM
  • Thanks Mini for your reply, heres the error:

    http://postimg.org/image/4njd715op/

    Any ideas?

    Tuesday, April 7, 2015 9:02 PM
  • Thanks, Oscar.
    I have shared the info with the team. I'll get back to you as soon as I get a response from the team.

    Thanks,

    Mini

    Tuesday, April 7, 2015 9:25 PM
  • Hey Oscar,
    Can you go to Windows event logs & check for the Data Management Gateway? then share these event logs with us.

    where to look for event logs - check this - http://blogs.msdn.com/cfs-filesystemfile.ashx/__key/communityserver-blogs-components-weblogfiles/00-00-01-60-20/0743.14.png

    I presume you have re-tried installing/configuring the connector. Most likely the issue is a timeout issue. The event logs will help us understand the situation better. We haven't seen this issue before & so we need more information from you.

    Thanks,
    Mini

    Tuesday, April 7, 2015 10:42 PM
  • Hello again Mini, there´s an error in the log.

    http://www.filedropper.com/dmglog

    An image in case the link doesn´t work.

    http://s21.postimg.org/j99ymqk47/log_error.png

    Thanks again!

    Tuesday, April 7, 2015 11:12 PM
  • Thanks, Oscar. I have shared the event long with the team. If we need any more info, I'll get in touch. As soon as I hear back from the team, I'll respond to you.

    -mini

    Tuesday, April 7, 2015 11:53 PM
  • Any update on the case Mini?... thanks
    Tuesday, April 14, 2015 10:34 PM
  • Hi Oscar,

    the events you shared did not help in diagnosing the issue. can you please do the following & share the trace files with us? Looks like an uncommon issue & so we need your help to debug it.

    1. Run command prompt as Administrator
                  a. cd /d "C:\Program Files\Microsoft Data Management Gateway\1.0\Shared"
                  b. dmgcmd -BeginEtw
    2. Restart Gateway service - go to local services, search for 'Data Management Gateway Host Service' & restart it
    3. Wait for about 2-3 minutes after service restarted
    4. Run connector, then turn off the trace in command line 
                  a. dmgcmd -EndEtw (run this command to turn off trace)
    5. Get the trace file "C:\Program Files\Microsoft Data Management Gateway\1.0\Shared\*.etl"

    Share the .etl file with us for further investigation.

    Thanks,

    Mini

    Tuesday, April 14, 2015 11:16 PM
  • Hi there Mini, this is the resulting log.

    http://www.filedropper.com/gatewaylog20150414173748000001

    Thanks again for your help

    Tuesday, April 14, 2015 11:49 PM
  • Thanks. Shared it with the team to debug. I'll get back to you once I have any updates.

    -mini

    Wednesday, April 15, 2015 1:01 AM
  • Hi Oscar,

    Thank you for reporting this issue. We have diagnosed the bug & are working on a fix. We'll very soon release an update that fixes your bug. Stay tuned!

    Thanks,
    Mini

    Thursday, April 16, 2015 1:28 AM
  • Hey Oscar,

    We have fixed the issue! And released a new version with not only your fix but also added a bunch of other enhancements. You can download the new version here - http://www.microsoft.com/en-us/download/details.aspx?id=45333

    You do not have to uninstall the previous version, just download & install this new version.

    You can read more about this new release here - http://blogs.msdn.com/b/powerbi/archive/2015/04/17/what-s-new-in-the-april-release-of-the-analysis-services-connector.aspx

    Thanks,

    Mini

    Saturday, April 18, 2015 5:29 PM
  • Thank you very much Mini and the support team, issue solved!

    Monday, April 20, 2015 5:57 PM
  • Hey Oscar,

    Great to hear that your issue has been resolved :) Now, we are waiting for your feedback about the Connector. Do share your feedback/questions with us.

    Happy to help!

    Thanks,
    Mini

    Monday, April 20, 2015 11:14 PM
  • I also keep getting error message "Register the Analysis Services Connector failed." after having entered the Analysis Services-connector settings and pressing next in the setup wizard. Have installed the latest version and also tried restarting the Data Management Gateway Host Service with no succes.

    Regards,

    Richard

    Tuesday, June 16, 2015 4:58 PM