locked
WSUS Synchronize failing RRS feed

  • Question

  • We are facing issues with WSUS not synchronizing on SCCM 2012. We have WSUS, SCCM and SQL installed on same server.

    Error message WSUS server not configured. Please refer to WCM.log for configuration error details..
     Source: CWSyncMgr::DoSync.  The operating system reported error 2147500037: Unspecified error              

    Checked the wcm.log and it gives below message: 

    System.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)~~   at Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow(SoapException soapException)~~   at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.ExecuteSPGetConfiguration()~~   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServerConfiguration.Load()~~   at Microsoft.UpdateServices.Internal.ClassFactory.CreateWellKnownType(Type type, Object[] args)~~   at Microsoft.UpdateServices.Internal.ClassFactory.CreateInstance(Type type, Object[] args)~~   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.GetConfiguration()~~   at Microsoft.SystemsManagementServer.WSUS.WSUSServer.SetUpstreamServerSettings(Boolean SyncFromMicrosoftUpdate, Boolean ReplicaServer, String UpstreamWSUSServerName, Int32 UpstreamWSUSServerPortNumber, Boolean UseSSL, Boolean HostBinariesOnMU, Int32 ReportingLevel, Int32 MaximumAllowedComputers)                                                                                                                            

    When i try to open a WSUS console its giving connection error.  I tried to start the windows internal database service but its not starting.  In event viewer its giving error message as

    The description for Event ID 3313 from source MSSQL$MICROSOFT##SSEE cannot be found.

    Can someone please suggest.                                                            

    • Moved by arnavsharma Friday, November 8, 2013 9:16 AM POsted in SCCM 2007
    Thursday, November 7, 2013 10:17 PM

Answers

All replies

  • Have you tried removing SUP role then removing WSUS role and cleaning DB while removing the role?

    And installing WSUS again.


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, November 8, 2013 9:17 AM
  • Have you completed "post installation action" after installed WSUS? Can you see that it is listening to 8530/8531 in IIS?

    Tim Nilimaa | Blog: http://infoworks.tv | Twitter: @timnilimaa

    Friday, November 8, 2013 10:04 AM
  • Have you checked the SUPSetup.log and WSUSCtrl.log? Any errors?
    • Edited by dekac99 Friday, November 8, 2013 10:35 AM
    Friday, November 8, 2013 10:35 AM
  • Don't use the Windows Internal Database for this - use SQL. As Arnav says I would remove everything and start this again. Here's how you implement Software Updates using ConfigMgr 2012

    http://www.gerryhampsoncm.blogspot.ie/2013/04/sccm-2012-sp1-step-by-step-guide-part.html



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Friday, November 8, 2013 10:44 AM
  • Its been almost two years since this post has been live. I am experiencing this same issue. How did you guys fix this? Any help would be greatly appreciated!
    Wednesday, April 15, 2015 4:35 PM