none
Monthly Protection to Tape not running. RRS feed

  • Question

  • I'm having a bit of a problem getting Protection to Tape to run. We have Protection groups that keep 14 days worth of data on disk. Once a month on the last day of the month we want a full copy to be backup up to tape. I have setup the Long Term Tape protection for 1 month retention range with a Backup frequency of Monthly. I then scheduled it for the last day of the month at  2 am. The back to tape never seems to run. I don't get any errors...it just doesn't run. I know the tape library works as some test job worked, but I doesn't seem to run. Is this being cause by the fact that we only keep 14 days of data short term or is something else going on?
    Tuesday, June 1, 2010 5:44 PM

Answers

All replies

  • If I go under Protection, highlight the protected items, and then tell it to Create a Recovery Point using Long-Term Storage everyone works fine. So the problems seems to be that for some reason the scheduled jobs to send it to tape aren't being fired off.
    Tuesday, June 1, 2010 6:58 PM
  • Hello Robert,

     

    For any long term backups of Monthly or longer,  If you change the protection group for any reason within 48 hrs of the scheduled time, it will not run as expected.

    For next month, create a customer filter for tape backups about 5 days before the last day of the month, then check the scheduled jobs and make sure it's listed. 


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, June 1, 2010 9:46 PM
    Moderator

  • I encountered a similar behavior using DPM 2010 RTM. For a PG, the long term backup schedule is set to every 1 week (Fri 11:00 PM) and every 1 month (Last Mon 1:00PM - which is today). Neither of these 2 ran, although the file recovery points to disk (11:30 PM M, T, W, T) seemed to have kicked in as scheduled.

    Earlier today, I explicitly ran PowerShell to force a backup to tape:

    New-RecoveryPoint -DataSource $datasource -ProtectionType LongTerm -Tape

    ArchiveFromSC Job has been triggered.
    ArchiveFromSC Job has been triggered.
    ...

    There are no traces of any of this on the Monitoring tab (Alerts or Jobs). On the Recovery tab, only the backup to disk around 11:30 PM is available.

    Any ideas if this behavior is correct or is a fix or workaround necessary?

    Thanks!


    TechNet Forum Moderator - http://www.leedesmond.com
    Tuesday, June 1, 2010 10:30 PM
  • Mike,

     

    Thanks for the reply. I will give that a try and see what happens.

    Tuesday, June 1, 2010 11:12 PM
  • Hello Desmond,

    As Mike mentioned, was the PG intent modified/set 48 hours prior to the scheduled time? Also for the ad hoc jobs, can you try creating a filter for completed/failed jobs for that particular day and scan for the Tape Backup jobs?

    Thanks,


    Pranay[MSFT] This posting is provided “AS IS” with no warranties and confers no rights.
    Thursday, June 3, 2010 2:14 PM
  • Pranay,

    > As Mike mentioned, was the PG intent modified/set 48 hours prior to the scheduled time?

    Yes that is correct. Nevertheless, a manual backup to tape was carried using the context sensitive menu and separately with PowerShell. Both without any success.

    > Also for the ad hoc jobs, can you try creating a filter for completed/failed jobs for that particular day and scan for the Tape Backup jobs?

    A Job filter was created with All options selected for the dates in question. Unfortunately, none of the Tape* options are returned from the query. Under the Alerts tab, there appears to be no records related to the affected PG either (Critical/Warning / Information).

    On a protected member, manually Create a recovery point / Short term disk protection / Create a RP after synchronization (or without synchronization will cause it to fail. Clicking on "Click to view details" next to Replica path shows only:

    Source (Protected Server)
    C:\ on FQDN of server

    Destination (DPM Server)
    C:\Program Files\Microsoft DPM\DPM\Volumes\Replica\File System\vol_1sljf lsflj slfjjasdfasdfs

    Is there a reason why this is happening constantly?

     

    Thanks for helping to look into these issues further.

     


    TechNet Forum Moderator - http://www.leedesmond.com
    Thursday, June 3, 2010 4:08 PM
  • Summarizing: 1. Scheduled and ad hoc tape jobs do not get triggered 2. Ad hoc disk jobs fail

    Can you please share the error code for the failure of the ad hoc disk jobs? You can find it in the alerts tab.

    Thanks,


    Pranay[MSFT] This posting is provided “AS IS” with no warranties and confers no rights.
    Monday, June 7, 2010 5:05 AM
  • Can you please re-open the thread once you have the requested data?
    Thanks, Praveen D [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 23, 2010 10:03 AM
  • One of the errors noted was:

    Type: Tape backup
    Status:  Failed
    Description:
    Failed to perform the operation since the tape free tape is not available in Tape Library Hewlett Packard MSL G3 Series library  (x64 based) (ID 24050).

    Library: HP MSL G3 Series Library (x64)
    Tape Label (barcode):   -   (i.e. blank with a hypen only)

    The link does provide some information on http://technet.microsoft.com/en-us/library/ff634237.aspx. In the case in question, there are several physical slots with tape either marked as "Tape available" or "Expired", all without a green check under "Offsite Ready". A lot of them actually have ample space to hold additional backup to tape.

    Questions:
    1. how can one determine the actual free space left on each tape (slot)?

    2. why are tapes with ample space not used (causing the error above)?

    3. "Expired" tapes do not seem to be re-used auto by DPM; is this behavior expected and how to resolve automatically e.g. by script

    4. on the URL above, it indicated that "you can periodically check for Free tape threshold reached alerts in the Alerts tab of the Monitoring task area.". Is this threshold setting scriptable or changeable by the UI since manual monitoring is tedious, time-consuming and error prone?

    Such info is essential to correctly help forecast tape requirements and make it more IT Administrator "friendly".

    Thank you for your help!

     

     


    TechNet Forum Moderator - http://www.leedesmond.com
    Thursday, June 24, 2010 10:30 PM