none
Windows 10 explorer.exe question. RRS feed

  • Question

  • Hi.

    I'm having some troubles on the execution of explorer.exe, let me explain you.I'm working on a desktop application that starts on user logon and so on Fullscreen, but between the user logon and the application execution there's a few seconds that desktop is displayed.

    Well, what I want is to prevent explorer.exe from running on logon and instead executing it from myself with my program.

    I've disabled explorer.exe modifying the registry key for HKEY_LOCAL_MACHINE → Software → Microsoft → Windows NT → CurrentVersion → Winlogon to null. 

    It works, on logon there's nothing displaying until my app pops up.

    The problem is that when I execute the explorer.exe from myself, it runs the file explorer and not the desktop and the taskbar.

    If I don't disable explorer.exe and instead I let it run, manually kill the process and then execute explorer.exe manually it starts the desktop and the taskbar correctly and not the file explorer.

    Does anyone know why is a file explorer popping up instead of desktop and how can I solve it?

    It doesn't need to be my solution, if there's another way to NOT show the desktop between the user logon and the app start its okay.

    Thank you in advance.

    Thursday, September 5, 2019 2:07 PM

All replies

  • maybe I misunderstood your requirement, but do you want the user to only run your program?
    Then look at: Use Shell Launcher to create a Windows 10 kiosk
    when this is not what you intend: how are you starting your program? autostart or logon script?
    is it possible your program really takes so long to start (maybe not running from a slow drive)?
    Thursday, September 5, 2019 2:18 PM
  • I want the user to only run my program BUT with the possibility to close it and start a normal windows experience after closing my program.

    To do so, i'm lunching my program from a Scheduled Task on userlogon, and as i said, i've modified the registry key to not lunch explorer.exe on logon.

    The problem is that when i execute explorer.exe from my program on close it starts the file explorer and not the desktop and taskbar.

    Thursday, September 5, 2019 2:28 PM
  • When you start explorer from your program, it is the parent process, which probably (together with the disabled Winlogon) is the reason why the explorer instance behaves differently.

    I still don't understand why you want to disable the start of explorer.
    Thursday, September 5, 2019 2:37 PM
  • I want to disable the start of explorer because there's a few seconds where user can see the desktop between logon and app start.

    It's not a strict feature, but it looks much nicer.

    If i don't get to properly start explorer.exe I will let it run and just assume that user will have to see the desktop for a few seconds.

    Thursday, September 5, 2019 3:52 PM
  • They changed how it works in windows 10, please see the link which is not provided by Microsoft, and is provided on an as is basis, I can make no guarantees about its content not changing.

    https://helpdeskgeek.com/how-to/restart-the-explorer-exe-process-correctly-in-windows/

    Thursday, September 5, 2019 4:31 PM
  • Hi,

    Please try using logon script to kill the explorer.exe process and launch your application. Then execute the explorer.exe manually when needed.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, September 8, 2019 6:01 AM
    Moderator
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 12, 2019 5:44 PM
    Moderator