stopped-extension-dll-no-implementation in forefront identity manager 2010 RRS feed

  • Question

  • Hi,

    I have created one extension rule in .net it builds successfully but when we copy and paste   the .dll file in this C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Extensions.

    first we run HRMA full import this gives 1 record added second we run full sync of HRMA this giving some status:stopped-extension-dll-no-implementation and does not add any record in metaverse.   Public Sub MapAttributesForExport(ByVal FlowRuleName As String, ByVal mventry As MVEntry, ByVal csentry As CSEntry) Implements IMASynchronization.MapAttributesForExport

    Select Case FlowRuleName

    Case "ExportFirstName"

    If mventry("firstName").Value = "Lovely" Then


    "mDBUseDefaults").Value = "Sunita"

    End If

    ' TODO: remove the following statement and add your scripted export attribute flow here

    'Throw New EntryPointNotImplementedException()

    'Case Else

    ' TODO: remove the following statement and add your default script here

    'Throw New EntryPointNotImplementedException()

    End Select

    End Sub

    ' TODO: Add export attribute flow code here


    Anil Kumar


    Friday, June 8, 2012 11:40 AM

All replies

  • If this is after an import, can I assume that you are projecting new identities into the metaverse and have import attribute flow rules defined in the MA?  The code snipped you provided is for export rules, not import.  Check the code in MapAttributesForImport(), and double-check that the DLLs referenced in the MA and the metaverse provisioning (if applicable) match the names of the compiled DLLs.

    If you don't see the problem, please post the full event log error message or the detailed view of the error message from within the FIM interface.


    Friday, June 8, 2012 1:22 PM
  • You might also check that all the required interface methods are implemented. Verify each of these are included in your code.


    Even if they're not used, the IMASynchronization Interface requires these be present. In VS you can right-click and Interface and choose the 'implement' option to have these stubbed out for you, or just create a new VS solution from the Sync Service manager.

    Frank C. Drewes III - Architect - Oxford Computer Group

    Sunday, June 10, 2012 5:34 AM