none
Send On Behalf of not woking with MRU Listed Items, Have to Select from GAL to work...

    Question

  • When we try to send a message on belief of another user, we can select the From user from the GAL and it works fine and the from user in the emil says its from that user. 

    If we select the from user from the MRU list (the same user that just did work), that message will come back as undeliverable with the Error:

    Scott Townsend (the person I was sending to)

    You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk.


    Diagnostic information for administrators:

    Generating server: 

    /O=EMAILORG/OU=MAILSERVER/cn=Recipients/cn=S_Townsend

    #MSEXCH:MSExchangeIS:/DC=com/DC=AD-DOMAIN:SERVER-EXCHANGE[578:0x000004DC:0x0000001D] #EX#

    Exchange Server : Exchange 2010 

    Client: Outlook 2016

    Thank you,

    Scott<-

    Thursday, May 26, 2016 10:45 PM

All replies

  • Does it work in OWA? Is Outlook in Online or cache mode?


    Blog:    Twitter:   

    Thursday, May 26, 2016 11:29 PM
  • This is an Issue with a few users that we just Upgraded to Windows 10 and Outlook 2016. We use Cached mode. 

    it works fine on my Win8.0 and Outlook 2013.

    I have not tried OWA.   I'm convinced it has to do with how the MRU is populated and is passing the data back for the Next Click to use. 


    • Edited by Scooter_ Thursday, May 26, 2016 11:57 PM
    Thursday, May 26, 2016 11:32 PM
  • This is an Issue with a few users that we just Upgraded to Windows 10 and Outlook 2016. 

    it works fine on my Win8.0 and Outlook 2013.

    I have not tried OWA.   I'm convinced it has to do with how the MRU is populated and is passing the data back for the Next Click to use. 

    If this is happening in Outlook cache mode, ensure the OAB is downloaded. If necessary delete the *.oab files on disk and do a full download of the OAB after re-opening Outlook

    Blog:    Twitter:   

    Thursday, May 26, 2016 11:53 PM
  • It is in Cached mode.  We will try deleting the .OAB and see how that goes. 

    Thanks!

    Thursday, May 26, 2016 11:58 PM
  • Do clear any stored autocomplete/MRU entries as well. They can store outdated information, thus causing issues like the one you describe.
    Friday, May 27, 2016 6:59 AM
  • When we first choose the From field there is no one listed in the MRU. So you have to select the user you want to send as. 

    Its the second time we send an email that the entry shows up in the MRU and selecting it fails. 

    The user is out of the office so getting to it to remove the OAB might not be till next week.  Though These machines are free Installs, so the OAB should be only a week or so old when the machine was installed with Outlook 2016. 

    We can Click the X on the MRU and then select from the From and it works. Then another attempt to use the MRU Fails. 

    An Interesting thing to note.   When it works the From field that the recipient sees is just the From user (User B) we selected. When it Fails, the sent Item says that its from User A on Behalf of User B.   Its only the Failed messaged that show the On Behalf message. 

    Friday, May 27, 2016 3:05 PM