none
Age of Empire 2: The Age of Kings and Age of Empire 2: The Conquerors Expansion are not working. RRS feed

  • Question

  • The installed games fine. Now when I go to play the games a  loading screen pops up and then shortly after closes. The games never starts up or loads.

    Steps I tried:

    Read though many forums on this problem and nothing seems to help.

    Tried the game with  boot start up programs turned off.

    Ran though all the compatibility test. (not compatible)  But I seen other forums where people said the game worked for them with Windows 7.

    Downloaded  latest DirectX and  Netframework.

    Updated all my drives.

    Check Microsoft's game compatibility list. (not listed) But I send feedback on this to them.

     

    Computer Details:

    Dell Inspiron 19

    Processor:  Dual-Core CPU E5400 @ 2.70GHz 2.69GHz

    RAM: 4GB

    OS: Windows 7 64-bit

     

    Note: Age of Empires 1 works fine.

     

     

     

     

    • Moved by Xinyan Ma 马欣妍 Wednesday, April 20, 2011 7:19 AM forum cleanup (From:MSDN, TechNet, and Expression Profile and Recognition System Discussions)
    Saturday, July 3, 2010 11:40 PM

All replies