none
Project Server 2013 RRS feed

  • Question

  • Hello, Everybody. 

    I just installed Project Server 2013 and I'm a newbie on it. I have two questions:

    1. How do I assign full permissions to an user in order to manage all the projects created in the PWA? This users are part of the Project Management Department so all people here must have full permission in all projects. They must also have permissions to grant permission in order to other people in the organization can view the projects.

    Note 1: I do not want that the Project Management Department have access to modify the PWA settings. Just full control in the projects.  When they create a new project and want to grant permission, they get the following message: "this site hasn't been shared with you".   

    2.  If I want them to connect to Project Server 2013, Must they have Project Professional or Standard on their local machines?

    Geraldo,

    Regards,



    Sunday, May 25, 2014 4:50 PM

Answers

  • The first question would be which permission mode are you in? See this for more details: http://technet.microsoft.com/en-us/library/jj219510(v=office.15).aspx

    Essentially, what you are describing is the Portfolio Manager role. They are allowed to see all projects. In Project Server security mode, you can modify the category permissions for the My Organization category/Portfolio Manager intersection to enable open, save and publish rights, allowing them to edit any project.

    Project Professional 2013 is required to connect to Project Server 2013.

    Hope this helps.

    Treb Gatte, Project MVP | @tgatte | http://AboutMSProject.com

    • Marked as answer by Geraldo17 Wednesday, May 28, 2014 4:35 PM
    Sunday, May 25, 2014 9:28 PM
    Moderator
  • Hi Geraldo,

    It seems like your giving permissions from the PWA home page with the "share" feature. If you go to server settings in PWA then manage groups, you should have just 1 team member group. Any user should be member of this group by default. Then go to the portfolio group and add the appropriate users.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    • Marked as answer by Geraldo17 Wednesday, May 28, 2014 3:56 PM
    Monday, May 26, 2014 6:19 PM
    Moderator
  • Hi Geraldo,

    1- You can indeed back up all your configuration thanks to dedicated tools and back it up in a brand new PWA instance. You'll find on the market free tools such as this one.

    2- Please find the link below for changing PWA language:

    http://technet.microsoft.com/en-us/library/ff700192(v=office.15).aspx



    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, May 28, 2014 4:54 PM
    Moderator

All replies

  • The first question would be which permission mode are you in? See this for more details: http://technet.microsoft.com/en-us/library/jj219510(v=office.15).aspx

    Essentially, what you are describing is the Portfolio Manager role. They are allowed to see all projects. In Project Server security mode, you can modify the category permissions for the My Organization category/Portfolio Manager intersection to enable open, save and publish rights, allowing them to edit any project.

    Project Professional 2013 is required to connect to Project Server 2013.

    Hope this helps.

    Treb Gatte, Project MVP | @tgatte | http://AboutMSProject.com

    • Marked as answer by Geraldo17 Wednesday, May 28, 2014 4:35 PM
    Sunday, May 25, 2014 9:28 PM
    Moderator
  • Ok! Thanks for your help, Treb.

    I'm working in SharePoint permission mode.

    I added an user to the Portfolio Manager role but when I click a project I go to the Project Permissions Tab in order to grant permission to others users but I got the same message:  "this site hasn't been shared with you"

    What permission mode Should I choose?

    Geraldo

    Regards,


    Sunday, May 25, 2014 11:16 PM
  • Go to the particular Project's site with Farm Administrator or Project Server Administrator account.

    Check if the other user for which you are facing issues is part of appropriate group which has required permissions.

    If not go to Server/PWA Settings, Connected SharePoint Sites and and by highlighting the particular Project click Synchronize Site Permissions.

    Check the scenario post synchronization is done.


    Abhijeet, MCTS | abhijeetm@outlook.com

    Monday, May 26, 2014 11:55 AM
  • Hi Geraldo,

    I'd advice to switch to the Project Server permission mode. Thus assign users in question to the default portfolio security group and they'll see all projects. Then to grant permissions for other users, I'd advice that the project owner (ie project manager or PCO) add the users in the Project team, so they'll have access to the project plan and the project site.

    As Trebb said, you'll need MS Project Pro to connect to Project Server.

    See reference below to switch permission mode :

    http://khurramjamshed.blogspot.ca/2013/04/switch-to-projectserver-permission-mode.html

    http://technet.microsoft.com/en-us/library/jj219486.aspx


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, May 26, 2014 12:13 PM
    Moderator
  • Ok! Thanks You!! Treb, Guillaume and Abhijeet. I've been learning Project Server 2013 with You. I have done all You told me and is working fine.

    I set the Project Server Permission Mode. Now I see more permissions in my site. But when I add an user to the Portfolio Manager group, they can't access to the PWA Home Page. It says "this site hasn't been shared with you". I thought that if They were in that group, They would access to the PWA Home Page.

    Sorry for the annoying questions. But I'm new on Project Server. 

    Geraldo

    Regards,

    Monday, May 26, 2014 2:25 PM
  • Hi Geraldo,

    Are those users also members of the team member group?


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, May 26, 2014 2:35 PM
    Moderator
  • No, They don't.

    But There are two groups:  Team Members (Project Web App Synchronized) and Team Members for Project Web App.  

    Geraldo.

    Regards,

    Monday, May 26, 2014 5:25 PM
  • Hi Geraldo,

    It seems like your giving permissions from the PWA home page with the "share" feature. If you go to server settings in PWA then manage groups, you should have just 1 team member group. Any user should be member of this group by default. Then go to the portfolio group and add the appropriate users.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    • Marked as answer by Geraldo17 Wednesday, May 28, 2014 3:56 PM
    Monday, May 26, 2014 6:19 PM
    Moderator
  • Thanks!! It worked fine!!! 
    Monday, May 26, 2014 9:29 PM
  • You're more than welcome Geraldo!

    Please mark any helpful reply as an answer so other users with the same concern can refer to it.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, May 26, 2014 10:03 PM
    Moderator
  • Hello, Everybody!

    1. I would like to know if there is a way to "export" the PWA to another SharePoint Server Farm without     configure everything again. 

    2. Can I change the PWA language?

    Geraldo

    Regards,

    Wednesday, May 28, 2014 4:39 PM
  • Hi Geraldo,

    1- You can indeed back up all your configuration thanks to dedicated tools and back it up in a brand new PWA instance. You'll find on the market free tools such as this one.

    2- Please find the link below for changing PWA language:

    http://technet.microsoft.com/en-us/library/ff700192(v=office.15).aspx



    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, May 28, 2014 4:54 PM
    Moderator
  • Thanks for your help, Guillaume.

    Geraldo.

    Wednesday, May 28, 2014 5:10 PM
  • Hi Geraldo,

    If you have a Dev/Test/Prod/Training type setup and anticipate having to continually keep them in sync, I'd take a look at paid tools. They tend to give you more granular control over what to move.

    I've used FluentPro very successfully at my former employer and at current client sites. They also allow you to export the configuration into a file so that you can manage this using a source control tool.

    Treb Gatte, Project MVP | @tgatte | http://AboutMSProject.com

    Thursday, May 29, 2014 5:08 PM
    Moderator
  • Hello, everybody.

    I'm having troubles with my PWA site. I'm trying to access to my Project Server site and when I type the URL in my browser I got an error: 

    Sorry, something went wrong

    File Not Found.

    Correlation ID: a4cf9a9c-a96b-c04e-14c6-383eed9ecea3

    I don't know what file is missing. 

    Geraldo,

    Regards.


    Geraldo Peralta

    Saturday, June 14, 2014 2:46 PM
  • Hello!! 

    Someone here...?


    Geraldo Peralta

    Monday, June 16, 2014 8:43 PM
  • Hello Everybody.

    Can I import settings and configurations from Project Server 2007 to Project Server 2013?

    Reagrds.


    Geraldo Peralta

    Thursday, June 19, 2014 4:00 AM