locked
MOSS 2007 Search Scope Error RRS feed

  • Question

  • Poblem: if I am looking on my SSP, the item count for both default scopes shows for the column Item Count: 'Total: error'. There are no items in my scopes, it show 'not available'.

    Getting below error

    View Scope page error:

     

    Search Scope Error

     

     

    Rule

    Behavior

    Item Count (approximate)

    All Content

    Include

    (all items)

    contentclass = urn:content-class:SPSPeople

    Exclude

    error

    ContentSource = BDCCStarSearch

    Include

    error

    ContentSource = BDCCStarSearchDelta

    Include

    error

    ContentSource = BDCCStarSearchCurrent

    Include

    error

    Total: error

     Tried below solution but didn't work:

    1.       Stop Office SharePoint Service on all servers (command line option StsAdm.exe -o osearch -action stop)

    2.       Stop and Start MOSS timer service

    3.       Start office SharePoint Service Search service on index server first. (my observation is stsadm.exe command line tool works better StsAdm.exe -o osearch -action start -role index)

    a.       Sometimes you configure Index location on index server (use new location). Use “configure automatically” option and provide domain account which is member of local admin group on the index server (command line option StsAdm.exe -o osearch -defaultindexlocation E:\spsindexdata)

    4.       Start Office SharePoint Services Search Service on Query Server(s) next. (command line option StsAdm.exe -o osearch -action start -role query)

    a.       Sometimes you configure Index location on Query server (use new location). Use “configure automatically” option and provide domain account which is member of local admin group on the Query server. (command line option StsAdm.exe -o osearch -propogationlocation d:\spsindexdata)

    5.       You might want to wait couple of minutes.

    6.       Edit your Shared Service Provider (SSP) settings. Select Index Server in drop down list. Provide service credentials. Click OK

    7.       Wait about 10 minutes and check your server again. Check if Scope count Error is gone.

     

    Please help me in providing the solution for this.

    • Moved by Mike Walsh FIN Friday, May 21, 2010 11:25 AM Search q (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Friday, May 21, 2010 11:04 AM

All replies

  • I was facing same issue... I resolve by checking below check box...

    Please verify on Central administration Page "Operations>Services on Server>Office Sharepoint server Search" verify if "use this server for indexing content" and "use this server for serving search queries" is cheked.

     http://www.sharepointdev.net/sharepoint--search/scope-error--item-count-error-32716.shtml  


    Moderator Note: NEVER propose your own posts as answers. The "Propose as Answer" function is there so that people can propose the good answers of other people. It is not there for self-proposing.
    • Proposed as answer by Jyoti_18 Monday, April 11, 2011 12:07 PM
    • Unproposed as answer by Mike Walsh FIN Monday, April 11, 2011 12:41 PM
    • Edited by Mike Walsh FIN Monday, April 11, 2011 12:42 PM Moderator Note about never self-proposing added
    Monday, April 11, 2011 12:00 PM