Unable to mount DB after moving to new drive


  • Is this the right form?  I couldn't find one for Exchange 2007

    My client is running Exchange 2007 SP1 on a Windows 2003 R2 SP2 server. 

    The server was running out of drive space fast (down to 3GB) so I wanted to move the exchange DB to another server which has 2TB of free space. Sounds simple enough. I ran through the wizard to move everything. 

    Exchange Management Console - Server Configuration - Mailbox. In there, I have my First Storage Group and Second Storage Group. First storage group is my Mailbox Database, 2nd storage group is my Public folder. 

    First, I moved my First Storage group from c:\program files\Microsoft\Exchange\mailbox\first storage group to D:\exchange\mailbox\first storage group. Repeat for my Mailbox Database. My second storage and public folder went into my D:\exchange\mailbox\second storage group. 

    I should also mention that my D: drive is a mapped network drive on another server (not sure if that makes any difference). 

    Unfortunately now, I'm unable to mount the database and public folder. I get this error: 
    (replace EXCHANGE07\Second Storage Group\Public Folder with EXCHANGE07\First Storage Group\Mailbox Database - for when I try to mount the Mailbox Database). 

    Microsoft Exchange Error 
    Failed to mount database 'Public Folder'. 

    Public Folder 
    Exchange is unable to mount the database that you specified. Specified database: EXCHANGE07\Second Storage Group\Public Folder; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1023) 

    So now...First Storage Group - I moved it back to its original location at c:\program files\Microsoft\Exchange\mailbox\first storage group and when I go to mount the Mailbox Database, I get this: 

    At least one of this store's database files is missing. Mounting this store will force the creation of an empty database. Do not take this action if you intend to restore an earlier backup. Are you sure you want to continue? 

    Well, I click NO! I don't want to create a new empty database. My Mailbox Database has everyone's email in it. 

    My next step - which I'm still pondering, is just move the Mailbox Database back to the c:\program files\Microsoft\Exchange\mailbox\first storage group where it originally was. But I feel I have a 50/50 change of it mounting. And I'd still be stuck in the same boat with no drive space. 

    I thought moving the database would be simple. It took about 1.5 hours - it was successful. But now I have this crazy mounting issues. 

    Any suggestions on how to fix this? 

    Thanks in advance for your replies and help.

    Friday, June 28, 2013 3:22 AM

All replies

  • When you mount a database, you need the missing (uncommited) transaction log file. Do you have them?

    You can check which one you need with eseutil /mh database.edb

    Bruce Jourdain de Coutance - Consultant Exchange

    Friday, June 28, 2013 8:50 AM
  • Here is my output, but I'm not sure what I'm looking for in this:

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.01
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: S:\Program Files\Microsoft\Exchange Server\Mailbox\First Stor
    age Group\Mailbox Database.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,12
     Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
         DB Signature: Create time:09/19/2008 16:41:55 Rand:4242692 Computer:
             cbDbPage: 8192
               dbtime: 1145099304 (0x4440d428)
                State: Clean Shutdown
         Log Required: 0-0 (0x0-0x0)
        Log Committed: 0-0 (0x0-0x0)
       Streaming File: No
             Shadowed: Yes
           Last Objid: 759701
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x974CD,4BE,160)  06/27/2013 16:46:43
          Last Attach: (0x974C2,9,86)  06/27/2013 16:08:51
          Last Detach: (0x974CD,4BE,160)  06/27/2013 16:46:43
                 Dbid: 1
        Log Signature: Create time:09/19/2008 15:33:30 Rand:167038 Computer:
           OS Version: (5.2.3790 SP 2 NLS 1.1)

    Previous Full Backup:
            Log Gen: 618990-619010 (0x971ee-0x97202) - OSSnapshot
               Mark: (0x97202,1D7,8D)
               Mark: 06/27/2013 04:01:18

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 1.188 seconds.

    Friday, June 28, 2013 8:57 AM
  • And I should also mention an edit here:

    I kept thinking that I could not move the database to a mapped drive - perhaps that was causing the problem. So, I moved everything back to my original C:\ drive. I then created an iSCSI drive from my main server that has 2-3TB of drive space and I carved out 250GB for my new iSCSI drive. That works fine (initiator and target). 

    I was successful at moving and mounting my second storage group (public folder) to my new S:\ drive which is my new iSCSI drive. 

    I was also able to successfully move my Mailbox Database to my S:\ drive as well. However, when I try to move the First Storage Group to my S:\ drive, I get this error: 

    Summary: 1 item(s). 0 succeeded, 1 failed. 
    Elapsed time: 00:00:00 

    First Storage Group 

    There are no source files under the path:E:\Exchange Server\Mailbox\First Storage Group. Use the command Move-StorageGroupPath -ConfigurationOnly in the Exchange Management Shell to set the new path in Active Directory only. 

    Exchange Management Shell command attempted: 
    move-StorageGroupPath -Identity 'EXCHANGE07\First Storage Group' -LogFolderPath 'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group' -SystemFolderPath 'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group' 

    Elapsed Time: 00:00:00 

    I did run this command from my Exchange Management Shell: 

    Move-StorageGroupPath -ConfigurationOnly 'EXCHANGE07\First Storage Group' -LogFolderPath 'S:\Exchange Server\Mailbox\First Storage Group' 

    No issues w/that. Appeared to work. Didn't give any output of success of failure - just returns me to a command prompt. 

    But I'm still unable to mount the Mailbox Database and I get the same error as before: 

    Microsoft Exchange Error 
    Failed to mount database 'Mailbox Database'. 

    Mailbox Database 
    Exchange is unable to mount the database that you specified. Specified database: EXCHANGE07\First Storage Group\Mailbox Database; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1023) 

    Friday, June 28, 2013 8:58 AM
  • You cannot use Mapped Drive to host Exchange database, iSCSI drive are OK.

    Your base look OK (clean shutdown, no log req)


    move-StorageGroupPath -Identity 'EXCHANGE07\First Storage Group' -LogFolderPath 'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group' -SystemFolderPath 'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group' -ConfigurationOnly

    That will update the location of the log and database, it won't move any file.

    Use robocopy, and copy all file from  c:\program files\Microsoft\Exchange\mailbox\first storage group  to your new path, check that you get both EDB and .LOG files.

    Use the EMS and do a Mount-Database -Force -identity 'your database name'

    In Exchange 2007, you can get the database name with Get-MailboxDatabase | ft Identity

    Bruce Jourdain de Coutance - Consultant Exchange

    • Edited by Bruce JDC Friday, June 28, 2013 9:20 AM added
    Friday, June 28, 2013 9:20 AM
  • The first command worked.  That's the move-StorageGroupPath.  

    Copied all the files over - no problem there.

    The second command I ran:  Mount-Database -Force -identity 'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb' resulted in red text below, and I'm not even sure I understand all that.

    Mount-Database : Cannot bind parameter 'Identity'. Cannot convert value "S:\Pro
    gram Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Databa
    se.edb" to type "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". E
    rror: "'S:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\
    Mailbox Database.edb' is not a valid value for the identity.
    Parameter name: Identity"
    At line:1 char:32
    + Mount-Database -Force -identity <<<<  'S:\Program Files\Microsoft\Exchange Se
    rver\Mailbox\First Storage Group\Mailbox Database.edb'
        + CategoryInfo          : InvalidArgument: (:) [Mount-Database], Parameter
        + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Exchang

    Friday, June 28, 2013 2:51 PM
  • Just a small update here....  I went to the Mailbox Database in the EMC and righ-clicked to mount the database, seeing if that would work again.  Well, appears to have worked - but see how the icon is:

    It is mounted, because if I right click it again, it'll just give me the option to un-mount the database.  However, email isn't I could have a 2nd issue now.  Or maybe it's not mounted all the way?  The Public Folder is fully mounted.  I can log into my OWA and see the public folders and email so that tells me the Public Folder is working.  The icon looks normal.  But that icon for the Mailbox Database - not too sure what it's trying to tell me.  I was hoping the Mailbox Database icon would be the same as the Public Folder icon.

    Friday, June 28, 2013 3:44 PM