locked
Office 2010 Searching RRS feed

  • Question

  • I'm hoping someone might have a solution for this.  I have just sequenced office 2010 on a Windows XP SP3 station x86 and then on Windows 7 x64 platform.  When I check the virtual office package for all the intended functionality I am coming up short in outlook.  I can open the virtual outlook and perform searches within it just fine.  The results come back as expected.  When I try to search from a desktop level though I never see the results that I would expect to see.  The information is not published to the local system and remains only in the bubble.

    1.  This is the RTM version of office
    2.  Used the RTM version of the Office App-V deployment tool kit each for the specific platform
    3.  Used the documentation from here to a T: <!-- [if gte mso 10]> <mce:style>

    http://support.microsoft.com/kb/983462

    4.  From testing other functionality they seem to be in working order accept SharePoint workspace.

    5.   I can see the proxies launching when outlook does and the services are showing up in my taskmanager. I would assume this is a moot point though with the indexing working in OneNote.

    Sharepoint workspace:  When I click the search box in XP it comes up with the 4.0 search with this filled in:

    store:SharePointWorkspaceSearch
    If you go to the control and and look at the index options for SharePointWorkSpace it shows: sharepointworkspacesearch://long sid

    On Windows 7 if you click the search box it asks to enable and does not show up under the index options.
    <!-- [if gte mso 10]> <mce:style>

    The OffVirt commands run were the ones displayed on the support page but change to fit my environment.  Another words GUIDS and versions and names were changed to match what I had done.  Tool kit was installed on both sequencer and client.

     

    Thursday, May 6, 2010 6:32 PM

Answers

  • Znack

    I believe that is the case.  I've read over all the documentation available and from what I can determine the quick search for mail related items is only to work inside of outlook and not from say the desktop.  If that is the case then yes the indexing only fails within sharepoint workspace.

    I broke up the sequence as well to just install outlook and sharepoint workspace.  I got the exact same results.

    I just sequenced the Sharepoint Workspace by itself and with or without tweaking this application to meet Microsoft's recommendations I find that this functionality is for XP not working. Within Windows 7 even on the sequencer box this functionality is disabled.  I cannot find any proof which states this function is intended to work on a sequenced edition of 2010.  So for anyone else that runs into this issue if you really want to deploy SharePoint Workspace virtually.  Then I recommend you use this:

    http://technet.microsoft.com/en-us/library/ee649104(office.14).aspx

    Set the "Prevent Indexing Certain Paths" so that the search functionality is both hidden and disabled.  As this is the only functionality I can find broken this is the route I am choosing to take.  As if you want to deploy this application you will have to remove parts of the 2007 office suite to allow it to install.  If you make the application virtual then you can avoid this.  If anyone else can find a means of getting it to work properly please post what you did to make it work.  

    Monday, May 10, 2010 2:35 PM

All replies

  • Hello,

    A bit uncertain on where the problem lies. does the indexing seem to fail for the sharepointworkspace only?

    /Znack

    Saturday, May 8, 2010 2:34 PM
  • Znack

    I believe that is the case.  I've read over all the documentation available and from what I can determine the quick search for mail related items is only to work inside of outlook and not from say the desktop.  If that is the case then yes the indexing only fails within sharepoint workspace.

    I broke up the sequence as well to just install outlook and sharepoint workspace.  I got the exact same results.

    I just sequenced the Sharepoint Workspace by itself and with or without tweaking this application to meet Microsoft's recommendations I find that this functionality is for XP not working. Within Windows 7 even on the sequencer box this functionality is disabled.  I cannot find any proof which states this function is intended to work on a sequenced edition of 2010.  So for anyone else that runs into this issue if you really want to deploy SharePoint Workspace virtually.  Then I recommend you use this:

    http://technet.microsoft.com/en-us/library/ee649104(office.14).aspx

    Set the "Prevent Indexing Certain Paths" so that the search functionality is both hidden and disabled.  As this is the only functionality I can find broken this is the route I am choosing to take.  As if you want to deploy this application you will have to remove parts of the 2007 office suite to allow it to install.  If you make the application virtual then you can avoid this.  If anyone else can find a means of getting it to work properly please post what you did to make it work.  

    Monday, May 10, 2010 2:35 PM