locked
2010 SP1 Upgrade RRS feed

  • Question

  • Error when upgrading to SP1.  Mixed environment with Exchange 2003.  1 domain.

    EXCHANGESETUP.LOG

     [07/28/2011 16:17:46.0212] [2] Processing object "IHFA.ORG/Users/DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}".
    [07/28/2011 16:17:46.0214] [2] [ERROR] Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0296] [2] [ERROR] Unexpected Error
    [07/28/2011 16:17:46.0296] [2] [ERROR] Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0299] [2] [WARNING] The object IHFA.ORG/Users/DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852} has been corrupted, and it's in an inconsistent state. The following validation errors happened:
    [07/28/2011 16:17:46.0300] [2] [WARNING] Database is mandatory on UserMailbox.
    [07/28/2011 16:17:46.0300] [2] [WARNING] Database is mandatory on UserMailbox.
    [07/28/2011 16:17:46.0300] [2] Ending processing get-mailbox
    [07/28/2011 16:17:46.0300] [2] Ending processing set-mailbox
    [07/28/2011 16:17:46.0320] [2] Active Directory session settings for 'Get-Mailbox' are: View Entire Forest: 'True', Configuration Domain Controller: 'NEPTUNE.ihfa.org', Preferred Global Catalog: 'NEPTUNE.ihfa.org', Preferred Domain Controllers: '{ NEPTUNE.ihfa.org }'
    [07/28/2011 16:17:46.0320] [2] Beginning processing get-mailbox -Filter:'name -eq $name' -IgnoreDefaultScope:'True' -ResultSize:'1'
    [07/28/2011 16:17:46.0322] [2] Searching objects of type "ADUser" with filter "(&((|((RecipientTypeDetails Equal RoomMailbox)(RecipientTypeDetails Equal EquipmentMailbox)(RecipientTypeDetails Equal LegacyMailbox)(RecipientTypeDetails Equal LinkedMailbox)(RecipientTypeDetails Equal UserMailbox)(RecipientTypeDetails Equal DiscoveryMailbox)(RecipientTypeDetails Equal SharedMailbox)))(Name Equal DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852})))", scope "SubTree" under the root "$null".
    [07/28/2011 16:17:46.0335] [2] Previous operation run on global catalog server 'NEPTUNE.ihfa.org'.
    [07/28/2011 16:17:46.0335] [2] Preparing to output objects. The maximum size of the result set is "1".
    [07/28/2011 16:17:46.0351] [2] [WARNING] The object IHFA.ORG/Users/DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852} has been corrupted, and it's in an inconsistent state. The following validation errors happened:
    [07/28/2011 16:17:46.0351] [2] [WARNING] Database is mandatory on UserMailbox.
    [07/28/2011 16:17:46.0351] [2] [WARNING] Database is mandatory on UserMailbox.
    [07/28/2011 16:17:46.0352] [2] Ending processing get-mailbox
    [07/28/2011 16:17:46.0352] [1] The following 2 error(s) occurred during task execution:
    [07/28/2011 16:17:46.0353] [1] 0.  ErrorRecord: Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0353] [1] 0.  ErrorRecord: Microsoft.Exchange.Data.DataValidationException: Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0364] [1] [ERROR] The following error was generated when "$error.Clear();
              if ($RoleIsDatacenter -ne $true)
              {
                if (test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
                {
                  # upgrade the discovery mailboxes to R5 version, this will fix the RecipientDisplayType property of the discovery mailbox which was wrong in R4.
                  get-mailbox -RecipientTypeDetails DiscoveryMailbox -DomainController $RoleDomainController | where {$_.IsValid -eq $false} | set-mailbox -DomainController $RoleDomainController
                  $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
                  $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
                  $mbxs = @( get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1 );
                  if ( $mbxs.length -eq 0)
                  {
                    $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                    if($dbs.Length -ne 0)
                    {
                      $mbxUser = @(get-user -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
                      if ($mbxUser.Length -ne 0)
                      {
                        enable-mailbox -Discovery -identity $mbxUser[0] -DisplayName $dispname -database $dbs[0].Identity;
                      }
                    }
                  }
                }
                else
                {
                  write-exchangesetuplog -info "Skipping creating Discovery Search Mailbox because of insufficient permission."
                } 
              }
            " was run: "Database is mandatory on UserMailbox. Property Name: Database".
    [07/28/2011 16:17:46.0364] [1] [ERROR] Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0364] [1] 1.  ErrorRecord: Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0364] [1] 1.  ErrorRecord: Microsoft.Exchange.Data.DataValidationException: Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0364] [1] [ERROR] The following error was generated when "$error.Clear();
              if ($RoleIsDatacenter -ne $true)
              {
                if (test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
                {
                  # upgrade the discovery mailboxes to R5 version, this will fix the RecipientDisplayType property of the discovery mailbox which was wrong in R4.
                  get-mailbox -RecipientTypeDetails DiscoveryMailbox -DomainController $RoleDomainController | where {$_.IsValid -eq $false} | set-mailbox -DomainController $RoleDomainController
                  $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
                  $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
                  $mbxs = @( get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1 );
                  if ( $mbxs.length -eq 0)
                  {
                    $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                    if($dbs.Length -ne 0)
                    {
                      $mbxUser = @(get-user -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
                      if ($mbxUser.Length -ne 0)
                      {
                        enable-mailbox -Discovery -identity $mbxUser[0] -DisplayName $dispname -database $dbs[0].Identity;
                      }
                    }
                  }
                }
                else
                {
                  write-exchangesetuplog -info "Skipping creating Discovery Search Mailbox because of insufficient permission."
                } 
              }
            " was run: "Database is mandatory on UserMailbox. Property Name: Database".
    [07/28/2011 16:17:46.0364] [1] [ERROR] Database is mandatory on UserMailbox. Property Name: Database
    [07/28/2011 16:17:46.0365] [1] [ERROR-REFERENCE] Id=SystemAttendantDependent___590e51a8a98846d3a7fa8ddcc5472c74 Component=EXCHANGE14:\Current\Release\PIM Storage\Discovery
    [07/28/2011 16:17:46.0365] [1] Setup is stopping now because of one or more critical errors.
    [07/28/2011 16:17:46.0365] [1] Finished executing component tasks.
    [07/28/2011 16:17:46.0469] [1] Ending processing Install-MailboxRole

     This is on the Mailbox Role part.

    Thursday, July 28, 2011 4:25 PM

Answers

All replies

  • Try resolution from thread here, homemdb attribute is probably null.

    Exchange 2010 SP1 update issues

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/10ad4a1e-3108-4016-85cc-8e679e2e8fc9

    Failed Exchange 2010 SP1 install
    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/842e4d3d-14de-47d6-a96c-84ee1b3d4348

     


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by AdminIHFA Thursday, July 28, 2011 8:00 PM
    Thursday, July 28, 2011 4:39 PM
  • Hi AdminIHFA,
    You have two options to choose from:

    1. Add the Database attribute to the mailbox Discover*
    get-mailbox Discovery* | set-mailbox -Database SOME_DB  (where SOME_DB is a name of one of your Databases)

    2. Delete the mailbox DiscoverySearch* (you will find in the Users Container)
    (but you need create a new Discovery mailbox later=


    I would choose the first one,
    Martina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.
    Thursday, July 28, 2011 5:06 PM
  • I found that the HomeDB was null AFTER I created a new Discovery (which had the correct DB info).

    Re-starting the setup...


    SUCCESS!  Thank you!
    • Marked as answer by emma.yoyo Friday, July 29, 2011 3:36 AM
    Thursday, July 28, 2011 5:29 PM
  • Thanks for the update AdminIHFA,

    Good Luch witht the installation and don´t forget to install RU3

    :Martina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.
    Thursday, July 28, 2011 6:15 PM