none
Power Query Not Updating New Access Queries RRS feed

  • Question

  • I connected to an Access Database using Power Query. Initially, I only had 3 tables within the Database. I've have added some queries to the Access Database but when I open Power Query I only see the 3 original tables. It will not pickup the new queries.

    I have refreshed, reconnected, and reinstalled the program but I still only the original 3 tables. How can I get Power Query to pick up the new Queries? I am a first time user with no programming background.

    Wednesday, June 14, 2017 12:53 PM

Answers

  • Hi 2stew. I tried your scenario locally (connecting to an .accdb, then adding a query to it and re-connecting) and was able to see the new queries. This may sound like a dumb question, but is it possible you're pointing to an out-of-date copy of the .accdb file?

    Also, can you share screenshots of what you're seeing as you connect the first time, add a query, and then connect again?

    Ehren


    Monday, June 19, 2017 6:27 PM
    Owner

All replies

  • I connected to an Access Database using Power Query. Initially, I only had 3 tables within the Database. I've have added some queries to the Access Database but when I open Power Query I only see the 3 original tables. It will not pickup the new queries.

    I have refreshed, reconnected, and reinstalled the program but I still only the original 3 tables. How can I get Power Query to pick up the new Queries? I am a first time user with no programming background.

    Why would Power Query pick up new Access Queries? To Power Query, an Access query is just another table (view) in the database. Therefore, like any other table, you have to create a query(ies) in Power Query to pick up any new table(s) or view(s).
    Wednesday, June 14, 2017 11:55 PM
  • Hi 2stew. If you start over and do "From Access Database", then choose your Database, what do you see?

    Ehren

    Friday, June 16, 2017 5:32 PM
    Owner
  • Tried to but it still will not pick up the new queries.
    Saturday, June 17, 2017 3:13 AM
  • I still only see the first three tables, I also tried clearing the cache but that did I not work,
    Saturday, June 17, 2017 3:15 AM
  • Hi 2stew. I tried your scenario locally (connecting to an .accdb, then adding a query to it and re-connecting) and was able to see the new queries. This may sound like a dumb question, but is it possible you're pointing to an out-of-date copy of the .accdb file?

    Also, can you share screenshots of what you're seeing as you connect the first time, add a query, and then connect again?

    Ehren


    Monday, June 19, 2017 6:27 PM
    Owner
  • I reconnected using the "browse folder". Still only seeing the first 3 tables. I'll send some snap shots of your request tomorrow.
    Monday, June 19, 2017 11:38 PM
  • Hi 2stew,

    Is this still an issue?


    Regards,

    Michael Amadi

    Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to vote it as helpful :)

    Website: http://www.nimblelearn.com, Twitter: @nimblelearn

    Wednesday, March 28, 2018 5:21 PM
    Moderator