locked
Error: The server returned a non-specific error when trying to get data from the data source. RRS feed

  • Question

  • Hello,

     

    I’m trying to link two lists in SharePoint Designer, Requests and Assignments, and create a data view webpart. The lists are from templates that I imported from an old site.

     

    I can link the lists, no prob. However, when I try to see the fields for the linked source, I receive this error:

     

    "The server returned a non-specific error when trying to get data from the data source. Check the format and content of your queuy and try again. If the problem persists, contact the server administrator."

     

     

    Do you have any idea what might cause this?

     

    Here’s the troubleshooting I’ve done so far:

     

    •             The problem occurs in both our dev site and the prod site (same farm).

    •             The problem still occurs when pairing either the Request or Assignment list with a non Request/Assignment list.

    •             The problem still occurs if I don’t select most of the fields on each list from SPD.

    •             The problem still occurs for the Request/Assignment lists  when I remove the data.

    •             The problem still occurs for the Request/Assignment when I remove most of the fields from the list.

     

    •             The problem does not occur when I connect non Request/Assignment lists.

    •             The problem does not occur when I use non Request/Assignment list templates.

    •             The problem does not occur when I view the Request/Assignment lists separately.

     

    •             The GUIDs are correct for the lists

     

     

    Any ideas?

     

    Thanks!

     

    Friday, November 4, 2011 7:03 PM

Answers