none
windows could not update the computer's boot configuration error. help? RRS feed

  • Question

  • Hi everyone.  I've been pulling my hair out with this and I'm just about at my breaking point after 15 some hours of messing with this but I thought I would give it one last shot.

    I have a Lenovo Tablet 2 that originally came with Windows 8 and later was upgraded via the store to 8.1.  When I went to do a complete format and re-install it asked me for media.  This product does not come with media. I figured the worst thing was that I would have to go the long way and install Windows without the recovery partition and reinstall all the drivers manually.  Boy was I wrong.  I booted to my UEFI enabled USB Windows 8.1 installer stick which was created using the new Mediacreationtool that Microsoft released to make either an ISO or USB stick.  Knowing this is UEFI only (more on that later), I downloaded the ISO and created the USB stick using RUFUS.  That booted fine and i blew away all the partitions and started the install.  Install goes fine until the very last step and says "windows could not update the computer's boot configuration".  The end.  Game over.  I can't get past this.  I've tried the following:

    1. Created a DaRT disc and did a complete clean of the drive
    2. tried a Windows 10 Disc - same thing
    3. Tried to edit the BCD using bcdedit command (more on that later) and nothing.

    I've probably done a half dozen other random things and I'm still back at the same position here.  The big issue with this device is that it is 32BIT UEFI only BIOS.  Terrible to work with because everything considers UEFI to be a 64bit only function so there isn't much that I can even get to boot.  

    Back to BCD Edit.  Anything I try to do just gives me the result of "The boot configuration data store could not be opened.  The volume for a file has been externally altered so that the opened file is no longer valid.".  I cannot createstore, edit the store, or do anything with it.  

    Again, i'm at wits end here.  I contacted Lenovo and it's out of warranty so they told me to pound sand.  I asked them just for a recovery media which every device should come with and damn the OEMs for not doing that aymore and they told me to go pound the same sand.  Help would be GREATLY appreciated.  This thing is slowly walking it's way to the trash can.  It's a mental thing at this point now and I have to get this working.  Please help.  Thank you.

    Saturday, January 31, 2015 10:52 PM

All replies

  •  The big issue with this device is that it is 32BIT UEFI only BIOS.  Terrible to work with because everything considers UEFI to be a 64bit only function so there isn't much that I can even get to boot. 

    The UEFI firmware is 64bit. Some manufacturers use special code to make it so you can only boot 32bit OS on it, which is likely what you have here.

    Regarding the error, can you try your installation with SecureBoot disabled?

    Monday, February 2, 2015 5:46 PM
  • Thank you for the reply.  Yeah I know UEFI is supposed to be only 64bit but for some reason they made it 32bit.  Makes it really hard to work with when things like this happen.  

    I have definitely tried it without secureboot on and off, same result.

    Thank you for your post.  Anything else would be greatly appreciated.  Thanks.

    Monday, February 2, 2015 9:07 PM
  • Hi FuzzyReets,

    Please make sure that Delete all partitions/volumes on the disk # (ex: Disk 0), since if you want to install Windows 8.1 as UEFI on until that disk # shows as unallocated space.

    As you mentioned that Windows support for UEFI was first introduced in 64-bit editions of Microsoft Windows system, the 32 bit EFI firmware are almost designed as OEM devices.

    Please refer to your manufacturer check the if OEM firmware or system is designed to prevent any changes to the boot manager.

    If these devices have special limitations, then a customer wants to install a replacement or retail copy of Windows 8 on their OEM UEFI computer, we suggest you send your tablet to manufacturers for recovery.

    Regards



    Thursday, February 5, 2015 1:43 AM
    Moderator
  • Bump.  Please help me for the love all of things great.
    Monday, February 23, 2015 12:59 PM
  • Hi FuzzyReets,

    I dug online for your issue and seems like no good anwser yet. Since it's a special edition, we could do nothing if there is any OEM limitation.

    The best way for this is to send your tablet to manufacturers for recovery.

    Regards

    D. Wu

    Thursday, February 26, 2015 8:39 AM
    Moderator
  • Sounds upsetting.  Thanks for your reply though.
    Sunday, March 1, 2015 12:50 PM
  • Maybe a very long shot but it is possible to buy 3rd party BIOS replacement chips. This MIGHT be a way around limitations. Would need to do some online searches for this.
    Sunday, March 1, 2015 9:36 PM
  • I am in the same situation with a different brand of tablet, but with what appears to be identical symptoms. Did you ever resolve this sucessfully?
    Tuesday, April 18, 2017 2:14 PM