locked
WDS server stop working RRS feed

  • Question

  • Hello, When I boot into pxe boot i receive a pxeboot error about \boot\bcd error. The WDS server lives on a separate server than the DHCP server It was working. I deleted the boot image and reinstalled it. The problem still exits What is causing this problem?
    • Edited by techguy781 Monday, October 10, 2011 3:56 PM
    Monday, October 10, 2011 3:47 PM

Answers

  • I found the issue. The problems is that the WDS is on another subnet. I will have to rebuild it on my subnet. Thanks for the help.
    • Marked as answer by techguy781 Friday, October 14, 2011 12:56 PM
    Friday, October 14, 2011 12:56 PM

All replies

  • Try adding both an x86 and an x64 boot image to your server, and then run "sc control wdsserver 129" from an elevated command prompt. This will force the regeneration of the BCD files that WDS uses.
    Monday, October 10, 2011 5:42 PM
  • So do i need a windows 7 x64 dvd to make a x64 image? 
    Monday, October 10, 2011 5:45 PM
  • Using the sc control command didn't work. It's also loading from the x64 architecture. I set \boot\x86\wdsnbp.com in dhcp. It says no response from Windows Development Server

    Then file:\Boot\BCD

    Status:0xc000000f

    Tuesday, October 11, 2011 2:12 PM
  • Hi,

     

    From the problem description, I understand that you are unable to boot into the PXE boot and receive an error below:

     

    File: \boot\BCD

    Status: 0xc000000f

    Info: An error occurred while attempting to read the boot configuration data.

     

    Since you are not pasting the info, I guess you are experiencing this kind of issue.

     

    As we know, x64-based computers can run x86-based or x64-based boot images. Therefore, you could have two boot images – one for x86 and one for x64. The boot menu on x86-based computers will display only x86 boot images (because x86-based computers cannot run x64 boot images).

     

    Note: The default behavior is for x64-based computers to display both x86-based and x64-based boot images when both are available. To change this default setting, run the command :

     

    WDSUTIL /Set-Server/ Defaultx86x64ImageType: {x86|x64|both}

     

    At first, please verify the boot image you used is correct. At the same time, please let me know which DHCP option is pointing to the IP of the WDS server? Option 66 or Option 67?

     

    Please make sure the settings on your server are the same from the snapshot below:

     

     WDS1

     

    After making the changes above, please restart the Windows Deployment Services on your server to make sure the changes take effect. Then use the client to boot from the Network.

     

    Regards,

    James
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, October 12, 2011 8:44 AM
  • Here is what I've done. I uninstalled the WDS role. Readded the role. I added a boot.wim from a Windows 7 32 OS and a boot.wim from a Windows Server 2008 R2 x64 OS. I ran this command

    WDSUTIL /Set-Server/ Defaultx86x64ImageType: {x86|x64|both}.

    I still receive the same error

     

    066 Boot Server Host name (WDS server name)

    067 Bootfile Name \boot\x86\wdsnbp.com

     

    Our DHCP lives on a seperate physical server.

    The WDS lives on a VM server.

     

    Do still need to check the two DCHP options in WDS even though its on a seperate server?

    • Edited by techguy781 Wednesday, October 12, 2011 1:38 PM
    Wednesday, October 12, 2011 1:37 PM
  • Hi,

     

    From your last reply, I notice that your DHCP server lives on a separate physical server. You don’t need to check two DHCP options on the DHCP that is on a separate physical server. It’s for Microsoft DHCP service is on the server that is being configured as Windows Deployment Services server.

     

    So if DHCP is installed on a server that is located in a different subnet, there are two methods to deal with this situation:

     

    Method 1 (Recommended):

    ======================

    Configure you IP Helper tables. All DHCP broadcasts on UDP port 67 by client computers should be forwarded directly to both the DHCP server and the Windows Deployment Services PXE server. Also, all traffic to UDP port 4011 form the client computers to the Windows Deployment Services PXE serer should be routed appropriately (these requests direct traffic to the server, not broadcasts).

     

    Method 2:

    ========

    Using DHCP Options 60, 66, and 67

    Although Microsoft does not recommend this method, you can use the following DHCP options to direct PXE clients to an appropriate NBP to download:

     

    •  Option 60 = client identifier. You should set this to the string PXEClient. Note that this only applies if DHCP is on the same server as Windows Deployment Services.

    •  Option 66 = boot server host name

    •  Option 67 = boot file name

     

    For more detailed information, there is a link for your reference:

     

    Title: Managing Network Boot Programs

    URL: http://technet.microsoft.com/en-us/library/cc732351(WS.10).aspx

     

    Of course, restart the Windows Deployment Services is necessary here.

     

    Regards,

    James
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 14, 2011 9:15 AM
  • I found the issue. The problems is that the WDS is on another subnet. I will have to rebuild it on my subnet. Thanks for the help.
    • Marked as answer by techguy781 Friday, October 14, 2011 12:56 PM
    Friday, October 14, 2011 12:56 PM