locked
Branchcache Distributed service mode issue RRS feed

  • Question

  • Hello,

    We our in the pilot phase of implementing Branchcache Distributed Mode in several branch offices.

    When checking the status of BranchCache to some clients using the command "netsh branchcache show status all"

    it shows the "Service Mode" as shown below instead of "Distributed Caching"

    This happens to on a few desktop PCs (laptops are all fine, no issue and some desktops as well)

    I have checked the Branchcache service and its started (also tried stopping and starting again), checked the GPResult (looks fine) and didn't find a difference against a PC that has no issues. Tried forcing to enable the service but no change in status.

    Please help. Thank you! =)

    BranchCache Service Status:
    -------------------------------------------------------------------------------
    Service Mode                 = Policy Refresh in Progress(Set By Group Policy)     <---------- this is the problem
    Serve peers on battery power = Disabled
    Current Status               = Running
    Service Start Type           = Automatic
    This machine is not configured as a hosted cache client.

    Local Cache Status:
    -------------------------------------------------------------------------------
    Maximum Cache Size        = 5% of hard disk (Set By Group Policy)
    Active Current Cache Size = 111081511 Bytes
    Local Cache Location      = C:\Windows\ServiceProfiles\NetworkService\AppData\Local\PeerDistRepub (Default)


    Publication Cache Status:
    -------------------------------------------------------------------------------
    Maximum Cache Size         = 1% of hard disk
    Active Current Cache Size  = 0 Bytes
    Publication Cache Location = C:\Windows\ServiceProfiles\NetworkService\AppData\Local\PeerDistPub (Default)


    Networking Status:
    -------------------------------------------------------------------------------
    Content Retrieval URL Reservation          = Configured     (Required)
    Hosted Cache URL Reservation               = Configured     (Not Required)
    SSL Certificate Bound To Hosted Cache Port = Not Configured (Not Required)
    Content Retrieval Firewall Rules           = Enabled        (Required)
    Peer Discovery Firewall Rules              = Enabled        (Required)
    Hosted Cache Server Firewall Rules         = Disabled       (Not Required)
    Hosted Cache Client Firewall Rules         = Enabled        (Not Required)

    Monday, November 4, 2013 9:47 AM

Answers

  • Maybe you could apply a GPO restriction so that it doesn't apply to those problematic computers. Then use gpupdate /force in command line and reboot them. See if gpresult shows that the GPO is really gone. Then you can see if you can configure them manually using netsh instead of a GPO. If they start to work properly, you could try removing the GPO restriction and see what happens.

    Good luck !

    Konnan


    Understanding XP Mode, the key to success

    Friday, November 15, 2013 10:32 PM

All replies

  • Hi,

    From the message it seems like a temp issue. Have you tried to reboot to reapply the group policy?

    Also you could have a try to run the following command on a PC in issue:

    netsh branchcache set service mode=DISTRIBUTED


    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Wednesday, November 6, 2013 12:56 PM
  • Hello,

    Thanks for the reply. Yes, reboot has been done of course.

    Its been happening to around 6-8 desktop PCs spread across locations. Most laptops and desktops are ok though.

    netsh branchcache set service mode=DISTRIBUTED - I have done this, restarted also the Branchcache local service. No luck same status... gpresult is fine with the policies set..

    Wednesday, November 6, 2013 11:45 PM
  • Maybe you could apply a GPO restriction so that it doesn't apply to those problematic computers. Then use gpupdate /force in command line and reboot them. See if gpresult shows that the GPO is really gone. Then you can see if you can configure them manually using netsh instead of a GPO. If they start to work properly, you could try removing the GPO restriction and see what happens.

    Good luck !

    Konnan


    Understanding XP Mode, the key to success

    Friday, November 15, 2013 10:32 PM