none
Backup-GPO Gives Error on Windows Server 2019 RRS feed

  • Question

  • I have a PowerShell script that runs Backup-GPO cmdlet on all GPOs.  I was running it on Windows Server 2012 R2 (with Desktop GUI) and migrated it to run on Windows Server 2019 Core.  A few of my GPO give an error:

    Backup-GPO: The data is invalid. (Exception from HRESULT: 0x8007000D)

    I can run the command directly on the problem GPO and get the same result. I have tried other OS like Windows 10 and Windows Server 2012 R2, and they succeed. I am using the same account; the only difference is the OS.  

    What does this error mean for Backup-GPO, and how do I fix it?

    Thanks.

    Tuesday, May 21, 2019 5:50 PM

Answers

All replies

  • Hi,

    Thanks for your question.

    If you just want to continue and not be bothered with the errors (sub-optimal) you can try suppressing errors using -ErrorAction SilientlyContinue as a parameter on the backup cmdlet. 

    Also, you can try the commands below to see which GPO caused this issue.

    $gpoList = get-gpo -all
    Foreach ($gpo in $gpoList)
    {
          write-host Current GPO is $gpo.DisplayName.ToString()
          backup-GPO $gpo.DisplayName.ToString()
    }
    
    

    Best regards,

    Lee


    Just do it.

    Wednesday, May 22, 2019 6:01 AM
    Moderator
  • Yes, I already know which GPOs are causing the issue. My question is how to solve the issues.  What is it about these GPOs that the backup fails?  Or what is it about this OS that the backup fails on certain GPOs?

    Thank you.

    Wednesday, May 22, 2019 12:10 PM
  • It worked in my windows server 2019 standard version. And I can't find any information about backup-gpo error in windows server 2019 core. 

    I suggest you delete the failed gpo and recreated it.

    Best regards,

    Lee


    Just do it.

    Thursday, May 23, 2019 9:15 AM
    Moderator
  • I have about 22 GPOs with this error (but still a minority of all GPOs).  I tried to use Copy-GPO on one, but that GPO still fails to back up.  

    Like I said, the backup only fails on this 2019 core system.  It is the server I set up to run automated jobs.

    I tried a Windows Server 2019 with GUI, and it does not fail.  Do you think there is some feature that needs to be installed in core?  Should I open a ticket with Microsoft?

    Thanks, 
    Roger


    I would if I could.


    • Edited by rpseekell Friday, May 24, 2019 7:40 PM
    Friday, May 24, 2019 7:31 PM
  • Sorry. I can't get server 2019 core environment. Have you solved your issue.

    If you have new progress, I hope you can come back and tell me.

    Best regards,

    Lee


    Just do it.

    Monday, June 3, 2019 7:29 AM
    Moderator
  • I finally found a pattern: it is the GPOs with Folder Redirection.  Each one is a little different, so I haven't narrowed down yet if it is a specific Folder Redirection setting.

    Please let me know if you have a 2019 Core and a GPO with Folder Redirection if you get the error.  

    • Edited by rpseekell Friday, June 7, 2019 6:33 PM
    Friday, June 7, 2019 6:31 PM
  • I came across this post because I was having the same issue on Windows Server 2016 Core. I have also reproduced the issue on Windows Server 2012 R2 Core.

    It appears to be related to https://support.microsoft.com/en-ca/help/2987708/agpm-and-gpresult-not-working-in-windows-server-core which states Windows Server Core does not have the GPMC Interfaces installed that Backup-GPO seems to be leveraging.


    • Edited by Dev Ramdin Monday, June 10, 2019 2:36 PM
    • Marked as answer by rpseekell Monday, June 17, 2019 12:13 PM
    Monday, June 10, 2019 2:30 PM
  • I guess I'm stuck then. Thanks anyway.
    Monday, June 17, 2019 12:13 PM