locked
How to re-enable local adminstrator account? RRS feed

  • Question

  • I have a Vista Pro.  It was in a domain (AD2000), working perfectly.  For some test, I had to remove it from the domain.  But what I didn't know is that the ONLY local administrator account was actually disabled!

    So now I can't login as the local admin.  Is there any procedure to re-enable it?  I don't want to re-install everything.

    PS: I know its password.  It's the account which is disabled.
    Wednesday, May 13, 2009 10:20 AM

Answers

  • Hi,

     

    You can go to Safe Mode to access the Built-in Administrator account to enable disabled account to resolve this issue.

     

    1. Restart the computer.

    2. As soon as the system starts to reboot, press and hold the F8 Key until you a black screen menu appear.

    3. Select the Safe Mode option and press the ENTER Key.

    4. When the login screen appears, you should see the Administrator account there.

    5. This account does not have a password associated with it, by default.

    6. Please try to enable disabled account.

    7. Restart the computer.

     

    For more information about Built-in Administrator account, you can refer to the following KB:

     

    Information for advanced users about the changes to the built-in administrator account in Windows Vista

    http://support.microsoft.com/kb/942956/en-us

     

    Hope it helps.

    Thursday, May 14, 2009 3:35 AM
    Moderator
  • Administrator was the ONLY local admin account I have on this Vista, so, sorry Kowshal, your method doesn't work.

    As to Robinson's suggestion, hmmm, well.... I needed to have this PC to work as quick as possible, and by chance I found back a Ghost image, so since I saw that there's no answer to this thread an hour later, I erased the C: partition with the old Ghost image :p

    But I would try yours to see if that would work or not, for the record.
    Friday, May 15, 2009 5:54 PM

All replies

  • Hi,

     

    You can go to Safe Mode to access the Built-in Administrator account to enable disabled account to resolve this issue.

     

    1. Restart the computer.

    2. As soon as the system starts to reboot, press and hold the F8 Key until you a black screen menu appear.

    3. Select the Safe Mode option and press the ENTER Key.

    4. When the login screen appears, you should see the Administrator account there.

    5. This account does not have a password associated with it, by default.

    6. Please try to enable disabled account.

    7. Restart the computer.

     

    For more information about Built-in Administrator account, you can refer to the following KB:

     

    Information for advanced users about the changes to the built-in administrator account in Windows Vista

    http://support.microsoft.com/kb/942956/en-us

     

    Hope it helps.

    Thursday, May 14, 2009 3:35 AM
    Moderator
  • Well instead of a long procedure lets follow an other one.

    If you have booted into  the desktop as an administrator equivalent user try right clicking on "Computer" and then "in the pop  down menu select "Manage" and then in the "Computer Management" window look for "Local Users and Groups" then expand the tree and then click on "Users" there you can see all the users on  the computer. See if the account named "Administrator" has a little arrow pointing downward which means its disabled.To enable it just double click on the account name and then deselect the option which says "Account is disabled". You can also set a password for it there. That should do the job.

    NOTE: PLEASE NOT THAT YOU SHOULD HAVE A ADMIN EQUIVALENT ACCESS TO THE COMPUTER BEFORE YOU CAN DO THIS.
    • Proposed as answer by CODEVANDAL Friday, May 15, 2009 5:48 PM
    • Unproposed as answer by Horinius Friday, May 15, 2009 5:49 PM
    Friday, May 15, 2009 5:48 PM
  • Administrator was the ONLY local admin account I have on this Vista, so, sorry Kowshal, your method doesn't work.

    As to Robinson's suggestion, hmmm, well.... I needed to have this PC to work as quick as possible, and by chance I found back a Ghost image, so since I saw that there's no answer to this thread an hour later, I erased the C: partition with the old Ghost image :p

    But I would try yours to see if that would work or not, for the record.
    Friday, May 15, 2009 5:54 PM
  • Well Horinius i think you should have created another account while setting up windows coz i think thats the way windows setup works....just take a look again...and please post me back....
    Friday, May 15, 2009 6:16 PM
  • I've tried again with another Vista.

    Robinson's method works GREAT!!  Too bad that I didn't know that before, or I wouldn't have to erase C: partition with an old Ghost image.
    I was having a doubt when I read your method: logging into administrator account while it is disabled...  But it turns out "Safe Mode" is really special!  That's something worth learning.

    To Kowshal:
    Yes, there was another account but our internal policy is to erase all local account except admin.  One of the reason is not to confuse users; they only use domain account and can't use local account.
    You should have trusted me when I said it's the only account...

    And for the record:
    There's another method.  That's to use this "Offline NT Password" utility:
    http://home.eunet.no/pnordahl/ntpasswd/
    No, I'm not interested in resetting the password.  It's just that at one step, we'll be offered the option to unlock/re-enable user.
    But unfortunately this didn't work for that Vista of mine because the utility's O/S (which is Linux) was unable to load driver for the SATA controller of that PC.  So the utility was not able to read into the C: partition.
    Monday, May 18, 2009 12:49 PM
  • Excellent one. Thanks for the information. It save us from going through the repair process. Works!!!
    Friday, January 21, 2011 9:44 PM
  • thanks a lot  Robinson....! i have the similar issues this idea worked for me becoz i had only one account which was having limited account access.....so once again thanks....!
    N.Vijay Kumar.
    Tuesday, August 23, 2011 9:42 AM
  • I have the same problem as the poster above, I have renamed the local admin account to localadmin and its currently disabled due to invalid login attempts. I have tried to use safe mode as suggested here, however, since the local administrator account was renamed to localadmin I cannot use the default administrator account, when I try to log in w/ the locaadmin account it says its disabled, any work around?

     

    Thanks,

    Jason

    Tuesday, September 6, 2011 3:20 PM