none
Project Manager Sorry, this site hasn't been shared with you. RRS feed

  • Question

  • Hi,

    I have just created PWA site and add users in Project Manager group. When user try to access site getting message" Sorry this site hasn't been shared with you.

    pls guide. 

    thx


    iffi

    Monday, February 27, 2017 12:49 PM

All replies

  • Hi,

    You have to check the category associated with the security group. I think that by default, Project Managers see only projects they own, not all projects. To get access to a project, you have to set the PM as project's owner or add it to the project team.

    More generally, you have to define your access policy: do you want the PMs to access all projects? In this case, you might change the category settings, or add to the security group the "my organization" category. As you can see, the security model might be a little complex to customize and it is strongly recommended to first design your access policy before updating the default security model, which can quickly become a mess. I'd also suggest you to keep as-is the default groups/categories and create new ones if you need to do some custimozations.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Monday, February 27, 2017 2:43 PM
    Moderator
  • Hi,

    how do i check category associated with the security group. i just want each project manager should see their own project and portfolio manager should have access/view to all projects/project managers.

    as i said i have already add user in Project Manager Group but still getting Sorry this site hasn't been shared with you.

    pls guide what could be an issue and how to fix it.

    thx


    iffi

    Tuesday, February 28, 2017 4:55 AM
  • Hi Imughal,

    Are you talking about the sites/pwa instance? If so, you have to share that site with each user. Use the share button next to the gear wheel and select the user(s) to share the site with. In the advanced options, choose the right group for the users (in your case Project Manager).


    Ben Howard [MVP] | web | blog | book

    Tuesday, February 28, 2017 6:23 AM
    Moderator
  • Hi,

    yea i am talking abt http://spserver/pwa site, i have added user in project manager group and also share site with users but still user getting access denied error. pls guide me its really frustrating. 

    thx


    iffi

    Tuesday, February 28, 2017 6:35 AM
  • I think you are doing everything correctly.  Please recheck and review the following URL

    https://support.microsoft.com/en-gb/help/2871976/error-accessing-project-web-app


    Ben Howard [MVP] | web | blog | book

    Tuesday, February 28, 2017 6:47 AM
    Moderator
  • Hi,

    i changed mode to project server.

    Set-SPProjectPermissionMode

    add user as project manager and now user can access site. i do not understand why it was not able to 
    access using sharepoint mode.

    thx


    iffi

    Tuesday, February 28, 2017 7:11 AM
  • When you provision a PWA instance, the permission mode is by default the SharePoint Permission Mode. You have to manually switch it to Project Server permission mode then.

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Tuesday, February 28, 2017 8:14 AM
    Moderator
  • Hi,

    it is good to go with Project Server permission. what is recommended project server permission or sharepoint permission.

    if i use project server permission do i have to add all my company users a resource or is there any way to link active directory OU to sync all resources into pwa.

    pls guide.


    iffi

    Tuesday, February 28, 2017 8:28 AM
  • Hi imughal,

    Both permissions modes have their pros and cons.  Using a search engine I very quickly found two articles which may help you.. ;)

    https://technet.microsoft.com/en-us/library/jj219510.aspx

    https://www.linkedin.com/pulse/20140827115234-173652244-sharepoint-vs-project-permissions

    If using PS perms mode you can link all people from an AD Group (not OU) into the team members group - that gives them access.


    Ben Howard [MVP] | web | blog | book

    Tuesday, February 28, 2017 8:34 AM
    Moderator
  • Try the following:

    1) Try accessing PWA site with Chrome and IE.

    2) On IE, make sure that the site is added to either a "Trusted Site" or "local intranet" in the security tab

    3) Do not try accessing from server, unless you have disable loopback check

    4) Try accessing from desktop and not server


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries


    Wednesday, March 1, 2017 3:31 AM
    Moderator