Windows 8.1 Event ID 6008 when shutting down normally


  • Hello,

    For the past few weeks I've been having problems with my PC hanging for 2 or 3 minutes when I reset it, coupled with an event ID 6008 when I shut it down. I finally got sick of it so I did a clean install of Windows 8, then upgraded to 8.1 and reinstalled my programs.

    The reset problem is solved, but I still get an Event ID 6008 error when I shut it down. (The previous system shutdown was unexpected.)

    I also get the following critical error:

    Event ID: 41 The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

    I have tried running the System File Checker and it found that all my files were verified with no problems. I don't really know what to do next, so any advice would be greatly appreciated.

    Thanks for your time.

    EDIT: I am also getting the following error when I shut down my PC normally:

    Event ID: 29 Windows failed fast startup with error status 0xC00000D4.

    • Edited by Yohannas Monday, May 05, 2014 5:02 AM
    Monday, May 05, 2014 4:59 AM

All replies

  • In order to diagnose your computers issue please follow the below instructions

    Before you do I suggest you at least make a restore point or backup (Just in case)

    Open an elevated command prompt and run the applicable trace.

    For shutdown tracing: (slow shutdown)

    xbootmgr -trace shutdown -noPrepReboot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

    All of these will shutdown, hibernate, or standby your computer and then reboot to finish tracing. 
    After you login to your PC, the new startscreen is shown and you have to click to the desktop to see countdown timer. 
    Again, wait until the timer finishes. After it does you can find the trace in C:\TEMP.
    Find the trace>compress it>upload it to skydrive (or some other file sharing service)>give us a link to it on the upload site

    Wanikiya and Dyami--Team Zigzag

    Monday, May 05, 2014 5:09 AM
  • Thanks for your reply. I've downloaded the tool and run the trace; which file(s) should I upload to the skydrive? There are two in C:/TEMP: xbootmgr.log and shutdown_BASE+CSWITCH+DRIVERS+POWER_1.etl.

    How do I upload them to the skydrive? I've never done that before.

    It also says that the logs contain personally identifiable information and I should be careful about sharing it..!

    Edit: Ok, I think this is right, but tell me if it isn't.

    Perhaps it's worth noting that that shutdown did not produce any of the usual error in the Event Viewer, perhaps because the trace did not properly shut down the system, or at least didn't appear to. It appeared to simply restart it - and a normal restart does not produce the errors, only a shut down.

    • Edited by Yohannas Tuesday, May 06, 2014 4:12 AM
    Monday, May 05, 2014 5:36 AM
  • Yohannas

    Sadly we need the ETL file not the log and you can of course use skydrive.  Don't worry about the personal info as it is only machine specific (like path, variables, etc.) 

    Just to be sure lets do this instead (please upload whatever etl file you now have).  From an elevated command prompt please type wprui.exe and that will launch the windows performance recorder (see snip)  It will launch another window and in it please check the following boxes as shown in the snip.  Also change the number of iterations to 3.  Then click start.  It should shutdown 3 times.  Take that file>zip>upload

    Wanikiya and Dyami--Team Zigzag

    Monday, May 05, 2014 6:33 AM
  • I'd just like to update this thread, despite it seeming to be dead!

    I have resolved the problem: it was caused because I hadn't installed the correct chipset for my Asus Z87-Pro motherboard. Such a simple solution to a complicated problem!

    Thanks to both of you for your efforts in helping me; I appreciate the time you both took!

    Tuesday, May 06, 2014 2:04 PM
  • Update 2: The computer managed to go a day without displaying those symptoms (= 2 shut downs.) Clearly the chipset was, in fact, not the cause of the problem: I have now tested it by shutting it down and restarting it 5 times in a row and every time I get the same errors as always. I have no idea what is causing it but if possible I would like to bring your attention back to this thread! 
    Wednesday, May 07, 2014 10:18 PM