locked
An unrecognized HTTP response was received when attempting to crawl this item RRS feed

  • Question

  • I have just done a dbattach upgrade of our servers and so far everything has come up very nicely.

    Except for the Search service. I cannot get Search to crawl our 4 web applications.

    The crawl finishes with errors everytime.

    I get the following error.

    "An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( Error from SharePoint site: HttpStatusCode GatewayTimeout The remote server returned an error: (504) Gateway Timeout. )"

    Does anybody recognize this.

    Server configuration:

    • WFE: windows server 2008 R2, Sharepoint 2010 enterprise, SSL(wildcard certificate)
    • DB: windows server 2008 R2, SQL Server 2008 R2


    Things i've already tried:

    • Used another browser
    • Set disableloopbackcheck to 1
    • iisreset
    • reset index
    • modified the hosts file
    • verified DB account
    • extended timeout settings
    • turned off "warn on ssl errors"

    Any help would be greatly appreciated. Need to go live in a couple of days.

    Cheers

    Thursday, August 26, 2010 9:39 AM

All replies

  • Have you tried accessing the site from the server where crawling happens (using the search account)

    Satheesh
    Thursday, August 26, 2010 10:26 AM
  • Yes, because this is a very small farm. only the database server is a separate server. crawling and querying happen on the same server.
    Thursday, August 26, 2010 11:37 AM
  • Have seen this before with inplace upgrades. Try to give the Content Access Account Read Access to user objects in Active Directory.


    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    Professional SharePoint 2010 Branding and User Interface Design
    Thursday, August 26, 2010 2:30 PM
  • i'll chcek it out
    Thursday, August 26, 2010 3:22 PM
  • It didn't work. I feel like i've tried everything.

    Don't want to reinstall the whole thing but I feel like there is not going to be any other way.

     

    Hope someone has an answer real soon.

    Friday, August 27, 2010 11:10 AM
  • What if you create a brand new web application?  Can you crawl that?
    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    Professional SharePoint 2010 Branding and User Interface Design
    Friday, August 27, 2010 12:49 PM
  • Just checked it. now the error is a bit different. I now get a 404 error.

    Here is a part of the log.

    • GetVirtualServerPolicy fail. error 2147750401, strStsUrl http://testing.portal.net:5555 
    • SetSTSErrorInfo ErrorMessage = Error from SharePoint site: HttpStatusCode NotFound The request failed with HTTP status 404: Not Found. hr = 80041201  [sts3util.cxx:5095]  d:\office\source\search\native\gather\protocols\sts3\sts3util.cxx     
      ***** Couldn't retrieve server http://testing.portal.net:5555 policy, hr = 80041201  [sts3util.cxx:1738]  d:\office\source\search\native\gather\protocols\sts3\sts3util.cxx     
      STS3::StoreCachedError: Object initialization failed.  Message:  "Error from SharePoint site: HttpStatusCode NotFound The request failed with HTTP status 404: Not Found." HR: 80041201  [sts3util.cxx:5189]  d:\office\source\search\native\gather\protocols\sts3\sts3util.cxx     
      ****** Server testing.portal.net:5555 security initialization failed, hr = 80041201 error Message Error from SharePoint site: HttpStatusCode NotFound The request failed with HTTP status 404: Not Found.  [sts3util.cxx:1358]  d:\office\source\search\native\gather\protocols\sts3\sts3util.cxx     
      CSTS3Accessor::InitServer: Initialize STS Helper failed. Return error to caller, hr=80041201  [sts3acc.cxx:1691]  d:\office\source\search\native\gather\protocols\sts3\sts3acc.cxx     
      CSTS3Accessor::InitURLType fails, Url http://testing.portal.net:5555, hr=80041201  [sts3acc.cxx:258]  d:\office\source\search\native\gather\protocols\sts3\sts3acc.cxx     
      CSTS3Accessor::Init fails, Url http://testing.portal.net:5555, hr=80041201  [sts3handler.cxx:312]  d:\office\source\search\native\gather\protocols\sts3\sts3handler.cxx     
      CSTS3Handler::CreateAccessorExD: Return error to caller, hr=80041201            [sts3handler.cxx:330]  d:\office\source\search\native\gather\protocols\sts3\sts3handler.cxx     
    • FLTRDMN: Errorinfo is "Error from SharePoint site: HttpStatusCode NotFound The request failed with HTTP status 404: Not Found."  [fltrsink.cxx:553]  d:\office\source\search\native\mssdmn\fltrsink.cxx     
      advising status change NSC_FLUSH (096bd807-65b2-4a6f-b6fc-32d9d5dba29f-crawl-0 Portal_Content crawl -1)  [gatherobj.cxx:4512]  d:\office\source\search\native\gather\server\gatherobj.cxx     
      processing status change (1) NSC_FLUSH, (096bd807-65b2-4a6f-b6fc-32d9d5dba29f-crawl-0, Portal_Content) thread id 0xa60  [statthrd.cxx:97]  d:\office\source\search\native\gather\server\statthrd.cxx     
    • CGthrPrj::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 096bd807-65b2-4a6f-b6fc-32d9d5dba29f-crawl-0 )  [cgatherprj.cxx:1698]  d:\office\source\search\native\gather\gthrsvc\cgatherprj.cxx     
      CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 096bd807-65b2-4a6f-b6fc-32d9d5dba29f-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx     
      CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 096bd807-65b2-4a6f-b6fc-32d9d5dba29f-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx     
    • The start address http://testing.portal.net:5555 cannot be crawled.  Context: Application 'portalaSolutions_Enterprise_Search_Service_Application', Catalog 'Portal_Content'  Details:  The object was not found.   (0x80041201)
    Friday, August 27, 2010 1:23 PM
  • Looks like you are using host headers.  Is it possible there's a misconfiguration in your AAMs? Are you using SSL?


    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    Professional SharePoint 2010 Branding and User Interface Design
    Friday, August 27, 2010 4:25 PM
  • thnx for taking the time.

     

    yes, I am using AAM and a SSL with wildcard certificates.

    I also modified the hosts file to point the adress to the same machine.

    Is there any specific procedure in setting that up correctly. I assumed everything was alright when I could browse to the sites without any problems.

     

     

    Friday, August 27, 2010 9:48 PM
  • John sounds like he is on the right track here with hostheaders/urls

    Can you list you AAMs , Content Source Start addresses and also please include what SSL certs you are using and whether they are self signed or purchased


    MSFT - SharePoint PFE
    Sunday, August 29, 2010 1:04 AM
  • AAM Setup

    Portal

    Default: http://Portal.domain.net

    Intranet: https://Portal.domain.net

    Blog

    Default: http://Blog.publicdomain.nl

    Intranet: http://blogwriter.domain.net

    Mysites

    Default: https://mysite.domain.net

     

    Content Sources

    Local Sharepoint Sites

    http://blog.publicdomain.nl

    https://mysite.domain.net

    Portal

    http://portal.domain.net

     

    I changed the Portal content Source to include the url for the default zone of the portal web application and now  I get another error.

    "The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error. ( Error from SharePoint site: WebExceptionStatus ConnectFailure Unable to connect to the remote server )"

    So I guess the AAM's have something to do with it as you stated. I feel like we're getting somewhere.

    I've read about this latest error but so far the suggestions i've read on blogs haven't worked.

    The SSL certs I am using are wildcard certificates. I don't really know if they were purchased or self signed.

    Monday, August 30, 2010 5:43 AM
  • I should also note that this whole installation has been done through Powershell cmdlets.
    Monday, August 30, 2010 12:25 PM
  • Just noticed that the search service is not included in any application pool.

    I'm gonna try to get it in an application pool, else I have to reinstall the whole thing.

     

    Weird. Wonder what could have caused that.

    Tuesday, August 31, 2010 3:15 PM
  • Hi Robert,

     

    Did you get a solution to this issue? We are having same issue with crawling. I tried all the options you mentioned in your first post but we are stilling getting the same error.

    We installed sharepoint 2010 on a single farm with sql server 2008 r2 installed on the same server.

    Could you please let me know if this issue is resolved for you.

     

    Thanks,

    Chaitanya

     

    Thursday, September 16, 2010 2:29 PM
  • Hi ChaiTanya,

    I've turned to other issues at the moment. I think next week i'll have some time to look into this again.

    I'm thinking about reinstalling the search service application through the UI and see if that fixes anything.

    If I find somehting i'll post it here.

    Cheers,

    Robert

    Thursday, September 16, 2010 3:43 PM
  • Hi Robert,

    Any luck with this issue? We are still facing the same issue. I tried to recreate the index but it didn't work. Please let me know if you find any solution.

     

    Thanks,

    Chaitanya

     

    Thursday, October 21, 2010 5:43 PM
  • Hi Kilaruc, can you specify what you have encountered while researching this error.

    Is it the same setup?? do you also have AAM etc etc.

     

    Maybe we're overlooking something

    Thursday, October 28, 2010 11:28 AM
  • Hi I have similar issue with sharepoint 2007 also.

    Tuesday, November 30, 2010 5:11 AM
  • We ended up using a workaround for this issue. 

    I installed this farm using a powershell script and specified separate accounts for the most important service applications. 

    After trying all the steps above, we finally decided to go back to using a single account for everything and start from there. 

    Suddenly I was able to crawl the farm and everything worked as expected. This is not best practice but we will go from here and configure all the service applications until we get it right with different accounts for different service applications. 

    regards, 

    Robert

    Wednesday, January 5, 2011 2:19 PM
  • I finally resolved this issue by deleting the old search application and recreating from the beginning.
    Tuesday, February 1, 2011 3:46 PM
  • I fixed it by resetting the index and doing a full crawl after.
    Friday, July 20, 2012 3:40 PM