none
RemoteAPP after windows 10 update 1803 are slow and right mouse button is not responding (it reacts only sometimes)

    Question

  • Hi,

    our workstations with Windows 10 pro are in this weekend updated to version 1803. For main system we use RemoteAPP aplications on Windows server 2012R2 (Windows server 2012R2 is full updated). After update on client station are RemoteAPP slower, and  right mouse button is unresponsive, or react verly long time... 

    It is a big problem for us.

    PS: after replace mstsc.exe and mstscax.dll from older version Windows 10 is all OK. but this is not a solution.

    Thanks.


    • Edited by Davidkaso Thursday, May 03, 2018 6:40 AM
    Wednesday, May 02, 2018 2:30 PM

All replies

  • Hi,

    We are also noticing the same issue within our organisation. After upgrading to Win 10 Enterprise to 1803 we have noticed that right click is not functioning correctly when using applications in RemoteApps. To right click you need to click multiple times and even then it very slow (at least 5 seconds) and react all of the time. Our RDWebApps is running server 2012 R2. We have attempted to reboot both server and client machines and this has not helped. 

    Any suggestions would be greatly appreciated. 

    Thanks

    Wednesday, May 02, 2018 10:50 PM
  • I'm seeing the same fault. Upgraded Windows 10 Pro 1803 on multiple machines. The applications top bar menu is extremely slow to drop down and general app performance is degraded. If I establish a full remote desktop session, instead of running it as a remote app, performance is fine. Redmond...we have a problem.
    Thursday, May 03, 2018 1:21 AM
  • Hot fix now: dislable on Windows server 2012 R2 "Use advanced RemoteFX graphics for RemoteApp" in gpedit.msc...
    Thursday, May 03, 2018 8:06 AM
  • Same problem here. Disabling "Use advanced RemoteFX graphics for RemoteApp" not solve
    Thursday, May 03, 2018 9:44 AM
  • Hi,

    We also see this problem with right mouse click- and also with left mouse if we left click on a menu button that should open a sub menu - clicking an action button that initiate an action (!) there is no problem!?

    Replacing with older (1709) version of mstsc (+ mstscax) did not solve the problem.

    Thursday, May 03, 2018 3:15 PM
  • We use RemoteAPP to present our ERP and after spending two days troubleshooting "Slow issues" i've finally narrowed it down.

    I shadowed a user while they worked and every time they were saying it was slow I could see the popup or changes that they were waiting for but they couldn't see it yet on their client side.

    I've now reimaged a few computers back to before 1803 and the problem doesn't exist.

    What is the fix other then disabling Advanced RemoteFX (which I am trying but thats not really a fix)

    Thursday, May 03, 2018 9:04 PM
  • We're currently facing the same issue as well. Over 1000 users affected! 

    We're currently testing some fixes suggested above, and opening a case with Microsoft. If anyone finds anything related to a working solution or a workaround, we would greatly appreciate an update. We will do the same on our end. 

    Thursday, May 03, 2018 11:25 PM
  • Hi,

    I want to confirm with you if such problem happens on all published RemoteApp?

    If possible, please try to re-publish or publish system built-in software, such as Calculator, and confirm that if same problem happens.

    Also, please check Event Viewer on client, confirm that if there is any relate event has been logged:
    Applications and Services Logs – Microsoft – Windows Server – RemoteApp and Desktop Connections

    Also, please check Application and System event log to find helpful information. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 04, 2018 7:09 AM
    Moderator
  • We are a cloud provider and disabling  Use advanced RemoteFX graphics for RemoteApp on Windows server 2012R2 is working....

    Then you must RemoteApp sing off...

    Friday, May 04, 2018 9:43 AM
  • Server 2016 has the same Problem. It is very slow und sometime Rightklick and Leftklick is not working.
    Friday, May 04, 2018 6:11 PM


  • Will test that out.

    Meanwhile, and as a workaround, I can confirm that replacing the mstsc.exe and mstscax.dll with the older version works fine.

    Also, rolling back is a possibility and doesn't nearly take a long to complete. (In case you're really stuck)
    • Proposed as answer by Steve R Morris Sunday, May 06, 2018 8:45 AM
    • Unproposed as answer by Steve R Morris Sunday, May 06, 2018 8:45 AM
    • Edited by GTMERP Tuesday, May 08, 2018 4:03 PM
    Friday, May 04, 2018 8:52 PM
  • Yes, we have had similar issues.

    We opened a support case with MS the morning of the first release when it was reported by an external remoteapp client. Have spend a fair amount of time with MS support and have submitted video etc.

    I would be interested if others find that if you start "Step Recorder" that remoteapp starts to behave. We found this by chance and hoping it helps MS pinpoint the issue quickly.

    Sunday, May 06, 2018 8:49 AM
  • Hi,

    @ all

    Please check Event Viewer and confirm that if there is any relate event has been logged.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 07, 2018 9:20 AM
    Moderator
  • Just adding my experience to this.  Update to 1803 on all our Win 10 Pro Clients.  Immediately noticed Remote Apps were behaving erratically.  When opening some drop down menus, they seem to just not open but in fact they ARE opening as you can click on any selection in the drop down as if it were being displayed.  If you muddle with clicking in an out of a drop down OR contextual right click menu it may or may not display. 

    This appears to be a RDP issue as older versions of RDP seem to work just fine.  Microsoft NEEDS to patch this IMMEDIATELY!

    So I had to teach my clients how to click on imaginary buttons/menus.

    UPDATE:

    Change the following group policy either locally or via GPO in an AD environment on all Terminal Servers/Remote Session Hosts:

     Set the following to Disabled

     Computer Configuration/Policies/Admin Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment: Use advanced RemoteFX graphics for RemoteApp – Disabled

     

    This appears to have worked in our environment.


    Monday, May 07, 2018 3:16 PM
  • Thanks, disabling RemoteFX works, now I'm barely able to work again but every time I minimize my remoteapp window - it turns all black next time i maximize it. Restoring and maximizing it again helps. I hope Microsoft will fix it soon.
    Monday, May 07, 2018 4:28 PM
  • Although, this worked for my workstation to fix the slow right click issue, if you set this option at the RDP servers, then users who use multiple displays with AX have an issue where if they have a pop-up from AX (ie on-hand screen) and drag that to another screen, that window becomes unresponsive.  

    This is obviously a frustrating issue because the "fix" works for me, but then breaks other users' RemoteApps.

    Tuesday, May 08, 2018 3:45 PM
  • We had similar issues where windows either went black or if they moved the window to another display, it then becomes unresponsive.  If anyone hears of a fix, I would love to know.  Thanks!
    Tuesday, May 08, 2018 3:46 PM
  • Just an update. This morning, we got a report of the problem with a user still on build 1703. So we're not sure if the issue is in some other KB. we'll be connecting to the user to compare the file versions of the mstsc.exe and mstacax.dll files. (This is a brand new situation, so will update as soon as we find out more)

    Also, Steve, you mentioned you opened a case with MS about it, it appears that Windows 10 support is via chat, and they directed us to post the issue in answers.microsoft.com , which isn't nearly enough given the urgency. I'm willing to pay (and probably get re-funded the fee, given it's an MS bug), to get higher level of attention. Can you share where you opened the case specifically?
    • Edited by GTMERP Tuesday, May 08, 2018 4:10 PM
    Tuesday, May 08, 2018 4:08 PM
  • If anyone finds the solution, my company is also affected!  Disabling the RemoteFX at the RDP servers just caused more issues for us.
    Tuesday, May 08, 2018 4:25 PM


  • Will test that out.

    Meanwhile, and as a workaround, I can confirm that replacing the mstsc.exe and mstscax.dll with the older version works fine.

    Also, rolling back is a possibility and doesn't nearly take a long to complete. (In case you're really stuck)

    I'm doing this at the moment since there aren't that many clients.

    But I really hope an actual solution from Microsoft very soon.

    Tuesday, May 08, 2018 6:43 PM
  • We're opening an actual case with MS as we speak. The first one, we had opened inadvertently for Home Users, so they weren't really on it. 

    Will keep you all posted on our findings as well. 


    • Edited by GTMERP Tuesday, May 08, 2018 7:59 PM
    Tuesday, May 08, 2018 7:57 PM
  • Ok all. someone was asking regarding whether enabling the Steps Recorder fixes the problem. We tested this, and it does in fact resolve it. 

    However, not sure if this is the best solution, as the Steps Recorder doesn't merely need to be open, but also actually recording, which I'm assuming will drain the workstation's memory, and will show a little red dot on every click. For those desperate, that is in fact a work around.

    Also, in more testing we found that the problem is exactly ONE, and nothing really random:

    Anything that produces a menu or a window, being modal or not, simply pops up behind the active Window. including drop down menus. 

    The fact the user clicks on the menu and nothing shows simply means that the menu is behind, but all the items are ghosted, but clickable. In our testing, moving the mouse down to the task bar after clicking the drop down will reveal the needed item. 

    We have test so far with the following apps, all with the same behavior:

    - Sage 100

    - Crystal Reports

    - MS Excel - Happens in the Ribbon Drop downs, on every other clicks, but is not as consistent in actually showing the menu when moving the pointer to the taskbar. 

    - Notepad - Seems to work on the actual menu bar (File, Edit, View, Help), but the issue shows itself when right-clicking within notepad. 

    Will post updates as we have them. 

    Tuesday, May 08, 2018 8:08 PM
  • Ive tested Windows 10 1803 on Remote Apps via Windows Server 2012 and Windows Server 2016. It only appears to happen on Windows Server 2012 Remote Apps.

    Also try the second work around here (https://support.gotomyerp.com/portal/kb/articles/critical-advisory-applications-are-slow-after-windows-10-update-to-1803). I used my original files from 1709. I wouldn't trust the download files. Replacing both mstsc.exe and mstscax.dll fixed the menu issues.



    • Edited by Zenithtwc Wednesday, May 09, 2018 12:19 AM
    Wednesday, May 09, 2018 12:04 AM
  • haha @Zenithtwc ... I'm actually one of the owners at gotomyerp. 

    The downloads are safe, grabbed from a clean OS right before the upgrade to 1803. 



    • Edited by GTMERP Wednesday, May 09, 2018 1:45 AM
    Wednesday, May 09, 2018 1:10 AM
  • We can follow up on this - have the same issues with update 1803 and no issues with 1709. Tried the fix with the old files from the site and then the right click works again.

    So far we are facing issues with

    - Excel 2016

    - old VisualBasic applications

    Working apps.

    - Navision 2013
    - Active Directory MMC (A bit slow response though)
    - Outlook 2016
    - PowerPoint 2016

    Just what we have quick-tested and users reporting.

    Waiting for a MS hotfix for this


    • Edited by MrStaun Wednesday, May 09, 2018 7:02 AM
    Wednesday, May 09, 2018 6:44 AM
  • I've tested with Server 2016 and problem presists
    Wednesday, May 09, 2018 9:23 AM
  • Having similar problems with Win 10 10.0.17134 and RemoteApps from a 2008 R2 server. Tried copying an earlier build's RDP files but I'm met with a screen filled by the "Preparing Your Desktop" message.

    Going to attempt to roll back to an earlier version of Win 10 as machines on 10.0.15063 don't have the issue.

    Wednesday, May 09, 2018 3:07 PM
  • We have a GPU assigned to our 2016 RDSH servers. This might be why its working for us. 
    • Edited by Zenithtwc Wednesday, May 09, 2018 11:00 PM
    Wednesday, May 09, 2018 10:59 PM
  • KB4103721, KB4103727, and KB4103731  doesn't fix the issues. But if you apply these patches, there is group policy that will need to be applied to at least the servers. 

    see: https://support.microsoft.com/en-us/help/4093492/credssp-updates-for-cve-2018-0886-march-13-2018


    • Edited by Zenithtwc Thursday, May 10, 2018 12:01 AM
    Thursday, May 10, 2018 12:00 AM
  • We have just solved the CREDSSP issue with appropriate patches, however this does not solve the 'slowness' issue. Both 2012 (R*) and 2016 services are effected. Appears to occur post 1803 clients update.

    We need a solution, as we'll have 1000+ clients effected, once the 1803 rolls-out completely.

    Bob

    Thursday, May 10, 2018 1:14 AM
  • Has any one had any more permanent success with this, aside from the workarounds? 

    My understanding is that the 1803 update can only be blocked for 60 days? 

    Thoughts ideas? 

    On our end, we still have the ticket with MS, and we'll update you guys also as soon as we hear back.

    Friday, May 11, 2018 10:46 PM
  • Hi,

    I want to confirm with you if such problem happens on all published RemoteApp?

    If possible, please try to re-publish or publish system built-in software, such as Calculator, and confirm that if same problem happens.

    Also, please check Event Viewer on client, confirm that if there is any relate event has been logged:
    Applications and Services Logs – Microsoft – Windows Server – RemoteApp and Desktop Connections

    Also, please check Application and System event log to find helpful information. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Dear Eve,

    I think that problem is in the rendering of (context) menus - if I click on the menu, it rolls down, but it isnt visible, however if I move the mouse or keyboard cursor down, it is roaming thru (invisible) menu, and if I click, desired action runs. 

    It is working well If I'm connected thru remote desktop (not RemoteApp).

    Problem is the same in our ERP as well as in ActiveDirectory Users and Computers (for example).

    My environment is three day old Azure VM with updated Windows 2016 Datacenter, as a clients we have Windows 10 Pro, on the 1709 version RemoteApp is working well, since I upgrade client to 1803 it is broken.

    Best regards,

    Jan

    Monday, May 14, 2018 9:00 AM
  • We are seeing same issue.  Across all workstations after 1803 update is installed.

    We are also seeing that default applications are "broken" where is a remote app is the default app.  So accessing an app by double clicking on a file in explorer or double clicking an email attachment is not working.

    I also hope this gets resolved quickly as users are now working but in a very crippled manner.

    Rob

    Monday, May 14, 2018 10:47 PM
  • We have exactly the same problem.

    We disable FX and it's work for part of them. But if user have some screen all is block, and app is too little, and block.


    Tuesday, May 15, 2018 10:15 AM
  • We're opening an actual case with MS as we speak. The first one, we had opened inadvertently for Home Users, so they weren't really on it. 

    Will keep you all posted on our findings as well. 


    Hi GTMERP,

    please do you have any response from MS? Error was posted on the second of May, I think it was pretty lot of time to take the action…

    It seems that Microsoft stop testing of their updates… In every update this year was some serious bug...

    Thank you for your effort in this...

    Tuesday, May 15, 2018 10:30 AM
  • Hi,

    We also have this issue. Look forward to any updates from MS that anyone receives.

    I've also escalated it with the software partner which we use (Wise Tech Global / Cargowise) in the hope that they can escalate it also with MS as they probably have more clout than we do.

    Would also encourage anyone else to do the same where you use RDP in a cloud environment with a software provider.

    Thanks,
    Stephen

    Tuesday, May 15, 2018 10:49 AM
  • Hi All, 

    we have not heard back from MS at all yet. WE're going to follow up with them today to see what we can find. Will let you know of any developments. 

    The problem is very much still there, and the clock is ticking, as, if updates can indeed only be blocked for 60 days, then it's only a matter of time before we're stuck with a disaster with our clients. 

    Forcing everyone to replace system files is doable, but not a small task for the average user, especially given permissions and ownership changes are required before anything can be replaced (even while admin on the workstation) 

    Tuesday, May 15, 2018 2:10 PM
  • Possible light at the end of the tunnel. 

    Microsoft has developed a fix, which we are currently testing out. Will update you if we have access, and how to obtain that fix. 

    Tuesday, May 15, 2018 5:13 PM
  • GTMERP, that's great news. Please follow up as soon as you can. I'd love to get my hands on it. We're in a very bad spot at the moment.

    Thank you!

    Tuesday, May 15, 2018 6:48 PM
  • Is this patch client side or server side?
    Tuesday, May 15, 2018 8:23 PM
  • It's a client side patch. 

    Unfortunately, it failed to install on our first attempt, so we're waiting for MS to send us a different version of it... 

    Tuesday, May 15, 2018 9:49 PM
  • I tried using the older version of the mstsc files, which I have done successfully in the past, but this time it did not fix the issue.

    I then disabled "Use advanced RemoteFX graphics for RemoteApp" in group policies like suggested in these threads and it fixed the issue immediately on both my Windows 2012R2 and Windows 2016 remote desktop servers. I didn't have to reboot the servers for it to take affect for new sessions.

    What a life saver! That setting also solved a couple other long standing issues that we've had with Windows 2016 servers where certain pop-ups would always appear behind the main screen. It also fixed a unique bug where if we maximized the RemoteApp, then minimized it, and then clicked on it in the taskbar to pull it up, the screen would appear frozen even though when we shadowed it, we could see things happening such as links highlighting when we put the mouse over them. Those issues didn't happen in 2012R2 but now they don't happen in 2016 as well. Bonus! I'll have to test it with different screen resolutions to be 100% sure that these other issues were fixed. Now what did we lose by disabling RemoteFX....? We've gone a whole day without any issues.

    Tuesday, May 15, 2018 11:41 PM
  • Disabling RemoteFX graphics as mentioned above seems to have solved this issue for us aswell. The affected terminal server is Windows 2016. We also have some 2008R2, but we haven't had any reports of problems there yet.

    Our program is based on Visual FoxPro, and the main problem was that the "pop-up" that appears when you click on a combo-box doesn't show. You can click the combo-box, then click in "thin air", and the selection that should be there is selected.. But you cannot see the selection-list.

    Wednesday, May 16, 2018 6:34 AM
  • Is it possible for you to make the fix Microsoft provided public?
    Wednesday, May 16, 2018 8:17 AM
  • Disabling RemoteFX graphics  - its not working in our case, please - other solution!
    Wednesday, May 16, 2018 9:36 AM
  • Hi

    Disabling RemoteFX helped us. BTW the application seems to be little bit faster after the change. I don't understand why.

    But MS please fix it.

    Wednesday, May 16, 2018 12:40 PM
  • Disabling RemoteFX "fixed" this particular problem for us but it creates many more display issues that are unacceptable to the number of users we're supporting to the point that having RemoteFX enabled might be the better option. 

    I'm really hoping we can get access to this hotfix today. 

    Wednesday, May 16, 2018 1:08 PM
  • Please loop me in to this hotfix as we desperately need it for Dynamics AX.
    Wednesday, May 16, 2018 1:19 PM
  • Hey guys, I'll make sure to share the HotFix as soon as we have a working one. Yesterday's test they sent us did not work, and wasn't the detecting the OS properly, we're waiting for them to send us another one, and as soon as we verify it's working, we'll post to let you know where to obtain the HotFix from.
    Wednesday, May 16, 2018 2:00 PM
  • Hi,

    We have also those problems with our remote apps on a 2012R2 server. Because we use grafhical CAD programs, we can not work without Remote FX. These Graphical programs are used by all our dealers so, this is verry bad for us as a company. So come on with the (hot) Fix.  

    Wednesday, May 16, 2018 2:05 PM
  • Hi GTMERP, thanks for the update on this.  We have had to push out some emergency GPO workarounds.  Ultimately the "fix" is to fix this RDP/RemoteFX issue itself.  Thanks for keeping us all in the loop!
    Wednesday, May 16, 2018 2:09 PM
  • Thanks GTMERP for the update. I'm refreshing this thread every few minutes hoping for a solution. 
    Wednesday, May 16, 2018 2:28 PM
  • Same issue with us...

    Server 2012 R2, All Clients Windows 10, pre 1803 work ok, anything updated to 1803 breaks Remote apps. Problem we find are any internal windows opened within the main program don't appear unless you click on any other program running locally on the client machine, then the hidden internal window appears until the next internal window is opened and you have to repeat the process of clicking outside the remote app again...

    In this instance, copying the 2 files mentioned previously to both system32 and syswow64 folders has temporally resolved the problem.

    we also have a test windows server 2016, and if copying the files doesn't work, then disable remotefx as this has solved it with our test setup.

    Wednesday, May 16, 2018 3:45 PM
  • Thanks GTMERP, we just ran into this same issue yesterday with Dynamics AX running as a remote app. Glad to see others are experiencing the same issue and I'm not the trail blazer. You guys have made my support life much easier. Will wait with anticipation for your update on the issue. 
    Wednesday, May 16, 2018 3:54 PM
  • Thanks GTMERP Watching and waiting for you to be the hero today
    Wednesday, May 16, 2018 5:31 PM
  • Nice day, as I write colleagues above. Yes, the problem with disable RemoteFW will only be solved in some cases, but as well as in my case when a customer uses a touch-based HW application and a graphics application, that's a step back.

    Please if someone comes up for a functional solution or write a patch update please write

    well thank you
    Wednesday, May 16, 2018 5:51 PM
  • we're at the same point as you guys, using WiseTech | CargoWise and already tried most tricks but nothing, please if someone have any patch or how to do it on client side...

    will be here awaiting for a hero

    Regards,
    Wednesday, May 16, 2018 6:04 PM
  • We've just got reports from a handful of our clients who've updated to 1803 that they're experiencing the same problems. Looking forward to a response from Microsoft on this one. 
    Wednesday, May 16, 2018 6:18 PM
  • While I'm waiting I've also replaced the mstsc.exe and mstscax.dll files in both the System32 and SysWOW64 folders with versions from the previous build of Windows 10 and it's resolved the issue on our end. I also downloaded a utility called "SysMate System File Walker" from snapfiles.com to help make copying the files a bit easier. Since they are system files, you have to take ownership of the files before Window will allow you to copy over them. This utility helps automate that process a bit. For folks with more than a few systems to take care of, I'd wait for the hotfix from Microsoft, but if you only have a few this will help. 

    • Edited by BCS-MAN Wednesday, May 16, 2018 7:15 PM
    Wednesday, May 16, 2018 7:12 PM
  • No problem guys, we're on it. 

    Also, for those interested, we did create this KB for our clients, feel free to peruse it:

    https://support.gotomyerp.com/portal/kb/articles/critical-advisory-applications-are-slow-after-windows-10-update-to-1803 

    and also, if the thread is TL;DR, we also discovered that the "Steps Recorder" running while in a RemoteApp actually fixes the problem, but, is probably not going to be too kind on your RAM. :) 

    Stand by for more updates as we receive them.


    Wednesday, May 16, 2018 8:01 PM
  • We also opened a case with MS. Disabling the Use Advanced RemoteFX graphics... made the remote apps responsive again, but like some of the others mentioned it introduced a new issue and that is if the RemoteApp is minimized, it turns black if you try to go back to it again (does not repaint).

    Steve J.

    Wednesday, May 16, 2018 8:12 PM
  • Steps Recorder prevents the slowness/drop down menu/right click problems? Interesting. I can't have that running on our servers but I wonder if there's some clue in that fact. 

    Thanks again GTMERP for keeping us in the loop. Microsoft seems unable to do that. 

    Did you get a new hotfix version today?

    Wednesday, May 16, 2018 8:19 PM
  • Just saw your KB on the gotomyerp site right before I saw your updated post here. Liked the visuals, makes it much more user friendly. Good job! :) 

    After seeing your URL and your username here, put 2 and 2 together and got 6... must be that new math! Lol 

    Wednesday, May 16, 2018 8:26 PM
  • @StopForcedUpdatingYouAreMakingMyLifeDifficult (phew, that was a "type"full ) :) ... The screenrecord would actually run on the user's workstation, not on the server, but the problem, is that it only works when you actually begin recording, and the longer you leave it, the more resources it's going to consume, so it's probably not the greatest solution. 

    @BCS-MAN: Thanks! Glad you found it helpful.

    IMHO, and until a fix is in place, as painful as it might sound, the best solution so far is to replace the file with an older version. doing that, does indeed brings back normal functionality without losing anything.

    Wednesday, May 16, 2018 8:34 PM
  • I did notice that after my Windows 10 system updated to 1803, every time I would drag a Remote Desktop window over to my second monitor it would cause it to reset the video connection to that monitor. My second monitor is connected to an external USB adapter that has a DisplayLink video connection. I just thought it was the USB device flaking out on me, until I ready some of these other posts.

    Because we all know that Microsoft couldn't possibly put out a bad update that would cause goofy hardware issues. ;) 

      
    • Edited by BCS-MAN Wednesday, May 16, 2018 8:54 PM
    Wednesday, May 16, 2018 8:52 PM
  • In the Microsoft Store install the "Remote Desktop App".

    It works well.

    Remote app is also possible.

    Greetings

    Thursday, May 17, 2018 11:10 AM
  • There are no peripherals available in the store application. It is not possible to use printer and other peripheral devices, such as serial port mapping.

    so it's just a problem for users who work as viewers :-(
    Thursday, May 17, 2018 11:23 AM
  • If we already know that we can roll back the remote desktop client files to the version prior to the 1803 update and get back full functionality. Why can't Microsoft simply push out an update that does this for us until such time that they can get their poo straightened out. Bad form Microsoft, for making your users deal with this problem for so long when their is an obvious immediate fix.

    Some companies actually use your remote app technology for business critical applications. This is not just a minor annoyance, it's a major business buster. I've been dealing with different bugs in the May 8th update for the past week and starting to get a bit irritated at the lack of urgency.   

      
    Thursday, May 17, 2018 12:32 PM
  • We too are experiencing this issue with 1803. Disabling RemoteFX graphics helps but limits the app's other features. Eagerly awaiting fix.

    Doug Kinzinger, MCSE

    Thursday, May 17, 2018 1:30 PM
  • We are also affected, how can we add to the same ticket so they are aware of how far reaching this issue is?
    Thursday, May 17, 2018 1:35 PM
  • Microsoft isn't communicating and they are making it worse day-by-day with pushing this update out to users. If you have a moment, please tweet @MicrosoftHelps, @Microsoft. Post it anywhere you can on social media. I've tried talking to them on several occasions and get no response other than a vague acknowledgment that they know there's an issue. 

    Thursday, May 17, 2018 2:39 PM
  • if you don't need any special things. Just use the app "Remote Desktop" from the Microsoft Store.

    You can add your feeds and keep using the remote app.


    • Edited by Numb13 Thursday, May 17, 2018 2:54 PM
    Thursday, May 17, 2018 2:49 PM
  • @Numb13 thanks for the recommendation but this isnt a workable solution in a business environment.
    Thursday, May 17, 2018 3:26 PM
  • What do you think we use it for.

    We are running "Microsoft Dynamics NAV".

    About 50users.

    All using remote app.

    Now because of the update we are all using the app from the store.


    • Edited by Numb13 Thursday, May 17, 2018 3:31 PM
    Thursday, May 17, 2018 3:28 PM
  • Unfortunately that doesnt work when you require full device integration. We also have several thousand users that rely on this to function. Hopefully Microsoft gets this figured out soon.
    Thursday, May 17, 2018 4:08 PM
  • Hey guys, 

    An update for now: We heard back from MS, and they are now asking us to deploy a 2016 to test to make sure that the issue happens there. I did send them a pretty snippy response, since I feel like it is their responsibility at this point to perform their testing now that we've actually proven this is an actual bug.

    We don't feel that building that server is necessary based on what you guys reported here. Since we don't have any 2016 available, the issue is in fact happening on 2016, correct? 

    I would appreciate a confirmation.

    Thursday, May 17, 2018 4:30 PM
  • I can verify that the issue is happening on 2016 server as well. We have many 2012 R2 servers it's happening on, and several 2016 servers too.

    Thursday, May 17, 2018 4:45 PM
  • The recommended way to report this to MS apparently is to use the Feedback Hub.

    If you have Windows 10 please send a feedback issue using these steps: 

    - Start | Feedback Hub

    - + Add New Feedback

    - What kind of feedback is it? Be sure to select 'Problem'. 

    - Provide info that you can. 

    Thanks guys. Hopefully if we all send in reports this will be bumped in priority. 

    Thursday, May 17, 2018 5:22 PM
  • We are noticing the same issue under ax 2009. 

    Please let me know if you find a better workaround.

    thanks,

    Thursday, May 17, 2018 7:07 PM
  • The same issue with SVR2016 and 10Pro clients. Rolling back clients to old version 10.0.15063.0 (1703) of mstsc.exe and mstscax.dll solves temporarily the problem, until next second Tuesday, of course :(

    What do we want?
    The whole case starting with Windows 8 is some kind of public beta test... The quality also equals the price - mostly "free" upgrade from Win7/8.
    I must say, for "free" is Win10 too expensive. MS should pay us. We all are free MS's test rats...

    And what about dialogs layering and RDA windows maximizing?
    This is a complete disaster...



    • Edited by Fireballcz Thursday, May 17, 2018 8:28 PM
    Thursday, May 17, 2018 7:10 PM
  • We can verify this as well on Server 2016.
    Thursday, May 17, 2018 7:40 PM
  • Thanks all. I had responded to Microsoft with that in the morning (just so that we don't waste any time). But thanks for confirming. I've actually sent the engineer the link to this thread... hopefully it'll help light a fire under them.  

    (Also submitted feedback via the Feedback hub, to support the cause) :) 


    • Edited by GTMERP Thursday, May 17, 2018 10:51 PM
    Thursday, May 17, 2018 8:10 PM
  • Headed to feedback hub now, thanks guys for staying actives, nice to have a community behind this. 
    Thursday, May 17, 2018 8:52 PM
  • Same here.  Thanks guys.

    Friday, May 18, 2018 1:14 AM
  • Have reported on the feedback hub also. Look forward to any updates...
    • Proposed as answer by Catano Friday, May 18, 2018 10:18 AM
    • Unproposed as answer by Catano Friday, May 18, 2018 10:19 AM
    Friday, May 18, 2018 8:16 AM
  • Same problem here using Server 2016 and Windows 10 Pro.  Update 1803 caused mouse commands to be delayed or not work at all (especially right click) when accessing Remote Apps.  We're stuck using Remote Desktop until this gets fixed, which has caused the productivity of dozens of users to decrease given the fact that not all application they need are hosted, and the need to switch between the Remote Desktop environment and the local machine.

    Very surprised and let down that this has taken so long to fix.  

     
    Friday, May 18, 2018 9:31 AM
  • Following...we have the same for 2012R2 and 2016.

    Interestingly Windows 2019 Insider preview 17666 does NOT have this issue. RemoteApps hosted on this server exhibit none of the issues

    Friday, May 18, 2018 12:07 PM
  • I came in this morning after rolling back the remote desktop executable and .DLL file on a couple clients yesterday and was greeted with a user that had the popup window on their screen that said "The Remote Desktop Services ActiveX control (mstscax.dll) does not match the version of the client shell." I had to reapply the older version of the files again to get it to go away and allow her to connect. Grrr!

    Hope you guys don't start experiencing this as well. 
    • Edited by BCS-MAN Friday, May 18, 2018 12:58 PM
    Friday, May 18, 2018 12:55 PM
  • We are asking our clients to roll back the Windows updates using "Recovery Options" until Microsoft fixes this.  We are also asking them to type MSTSC.EXE in the reason why apps are not working.  If they get enough people not installing or uninstalling the update due to an error that should prompt a more urgent response.
    Friday, May 18, 2018 2:49 PM
  • Same problem here. Have had to roll back mstsc.exe client manually or using scripts... please fix asap!
    Friday, May 18, 2018 3:17 PM
  • Hey @BCS-MAN. That's an interesting, and crappy discovery! Thanks for the heads up on it!

    We haven't started experiencing, but I wonder if you ran into some variable that we haven't run into yet. Will test out.

    Re: Microsoft, they still haven't gotten back to us since yesterday. Sent another request for update this morning.

    Friday, May 18, 2018 4:36 PM
  • Yeah, I did look at her Microsoft updates list in Control Panel under Programs and Features just to see if anything had gotten applied over night, but it only showed the May 8th update as the most recent which was applied on 5/14. So nothing ground breaking to report other than that. 

    The other user that I applied the updates too on the same day had no ill effects, so your hypothesis of an odd variable seems plausible. +1 for the crappy discovery. :)

    Now if we can just tilt the crap meter in the right direction on the Microsoft side, maybe we can finally flush this one and move on to the next clog!
    • Edited by BCS-MAN Friday, May 18, 2018 5:01 PM
    Friday, May 18, 2018 4:54 PM
  • @BCS-MAN: YAY for tilting the crap meter LOL 

    As for an update. This was from a couple minutes ago from Microsoft. They're just being completely useless. I keep sending them links to back to this thread where you guys have already tried all the suggestions they're giving to no avail. (I'm pretty sure they're not even clicking on the link).

    By the way: Can anyone confirm whether the 1803 update can be blocked for more than 60 days?  Someone told me that was the limit?  If it is, this makes this matter all that much more urgent!

    Friday, May 18, 2018 5:35 PM
  • And another reply from them... apparently, we're sitting ducks at this point. They do apologize for the "inconvenient" though :-D 

    I think at this point, the best route is to hammer them with reports about the problem, and if you can even open a case with MS yourselves. (you will get refunded, 100%, since this is a bug). But it will put some more pressure.

    Friday, May 18, 2018 5:41 PM
  • All, not sure if you have also been part of another thread which I just discovered: 

    https://social.technet.microsoft.com/Forums/windows/en-US/cdf12bbc-ff78-4d6e-9e12-63f99ae4d511/w10-1709-remoteapp-popups-hidden-behind-main-window?forum=winserverTS


    Friday, May 18, 2018 5:52 PM
  • Thanks GTMERP, though the news is disappointing (not unexpected). We have to keep the pressure on. I've made accounts on twitter, reddit, facebook, HN to try and get this more attention. Bit ridiculous I have to act like this to try and get information. 
    Friday, May 18, 2018 7:01 PM
  • I have Dynamics ax 2009, Windows server 2012R2.  Remote Desktop App for the Dynamics.

    The same issue, I click in the botton and it is not display the information.

    In this moment, I RollBack the update 1803 to my users and works.  
    I hope that Microsoft solve it soon.

    This recommendation no work for Dynamics Ax:Computer Configuration/Policies/Admin Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment: Use advanced RemoteFX graphics for RemoteApp – Disabled

    Friday, May 18, 2018 7:06 PM
  • So, this is major bug number 2. Check this one out https://social.technet.microsoft.com/Forums/en-US/cdf12bbc-ff78-4d6e-9e12-63f99ae4d511/w10-1709-remoteapp-popups-hidden-behind-main-window?forum=winserverTS

    Basically since November 2017, RemoteaApp had totally, completely and utterly been broken. Microsoft - I have no words for this level of incompetence. Remoteapp is a business/mission critical tool, and if you manage to keep this one f-ed for months at a time, it's almost like you're forcing your paying customers off this platform. 

    What's going on?????????

    Do you not have funds for a stable testing department? Do you even test your updates out just a little bit before you push them out? 

    It's imperative that you fix all these bugs ASAP. ASAP. 

    Friday, May 18, 2018 7:40 PM
  • It looks like remote apps are not the only issue with 1803. Check out this forum, apparently Microsoft put the 1803 update into the wrong channel initially and it was force installed for folks who didn't want it right away. What the heck Microsoft???

    https://social.technet.microsoft.com/Forums/en-US/bd7fc697-9417-434b-b90f-d1b6597a3087/1803-skipped-semiannual-channel-targeted?forum=win10itprosetup


    • Edited by BCS-MAN Friday, May 18, 2018 8:13 PM
    Friday, May 18, 2018 8:13 PM
  • So while we're on the topic of crappy patches, and while we're waiting :)   What do you guys use to stay abreast of what's coming up? 

    I have this: https://portal.msrc.microsoft.com/en-us/security-guidance which is useless, as it release information about patches on the actual day they're released, and then there's this:

    https://www.askwoody.com/tag/patch-lady-posts/

    Which seems a bit more hopeful, but still relying on random searches for stuff. 

    Anyone have any good resources they use to keep on top of what's coming up with patches? 


    • Edited by GTMERP Friday, May 18, 2018 9:22 PM
    Friday, May 18, 2018 9:13 PM
  • Pretty much same for me. wait and see approach and search the typical media sources for anything that looks promising. I actually think Microsoft doesn't even know what they are putting out or what will make the cut until the last minute anyway. This is evident by their lack of quality control and in house testing.   
    Friday, May 18, 2018 9:21 PM
  • I was afraid of this answer. 

    The "wait and see" approach, caused us 100 tickets in a matter of 4 hours on Wednesday morning after Patch Tuesday.... 

    We're just trying to find ways to be more proactive, but I can't seem to find any reliable sources to do so.

    p.s: I submit we categorize the term "Patch Tuesday" as a cuss word :-D 


    • Edited by GTMERP Friday, May 18, 2018 9:24 PM
    Friday, May 18, 2018 9:23 PM
  • There is this option, but I've not used it myself and it would require you to touch every machine unless you could somehow push out the install and settings in the background somehow. 

    https://www.rizonesoft.com/downloads/windows-10-update-switch/

    It allows you to set every connection to metered which would stop all background downloads of Microsoft updates until you wanted to let them through. It would be nice if they had a networks version with an admin console you could turn on and off yourself.

    Friday, May 18, 2018 9:41 PM
  • Our role, as it relates to the Windows 10 machines (or clients) is actually more an advisory one. We only have control of our own servers. (we're a cloud hosting provider), so the end user's workstations connecting to us are within their own domains, and controlled by their respective IT departments (Or the owner's cousin, Tommy :) 

    We're just trying to give advisories to issues that could interrupt connectivity to our service due to changes that are out of our control, so that our clients can appropriately address them.

    Thanks for that link, will check it out. We can always make it available as a recommendation for them to use in case they're not running central patching of some sort.

    Friday, May 18, 2018 9:46 PM
  • Still no news from Microsoft. I'm still asking affected users to make bug reports. Let's keep it up, I really don't think Microsoft is concerned with this problem or has a full understanding just how many people are affected. 
    Saturday, May 19, 2018 3:35 PM
  • Good monday everybody. Have anybody found something new about this?

    1803 spreading and causing lots of troubles in our organization...

    It would be really nice to get hotfix from Microsoft, because I would not like change permissions of files in system32.(Replacing mstsc.exe and mstscax.dll-2- )

    Please, take this serious...


    Monday, May 21, 2018 5:54 AM
  • I was thinking over the weekend, another option might be if your router has the ability you could block the Microsoft update URL'S from the router side just to get past the 60 day limit before the operating system forces the update. That is of course, unless Microsoft gets off their rear and fixes this issue.  
    Monday, May 21, 2018 11:56 AM
  • @GTMERP It looks like your article on your web site is tracking pretty high in the search topics. I'm wondering if you should post another one with a topic heading of "Microsoft Leaves Users In Limbo After Update 1803 Breaks Remote Desktop". Maybe that would get their attention!  

    This just in... users all over the web have been reporting serious issues with remote desktop usability after the latest Microsoft 1803 update. Microsoft on the other hand has basically gone dark on the issue after asking users to repeatedly try mundane tasks to try and correct the problem. Users have had to attempt troubleshooting on their own and report their findings back to Microsoft who doesn't seem interested at all in rolling back the problem forced upon their customers to help afflicted users.

    Other users have reported that the bugs affects all currently supported versions of remote desktop accept the current beta version of Windows 2019. Could this be a way for Microsoft to force users to the new platform? Or is Microsoft leaving their current user base to search for other alternatives while they put their heads in the sand?    


    • Edited by BCS-MAN Monday, May 21, 2018 1:54 PM
    Monday, May 21, 2018 1:41 PM
  • Hello,

    We have the same problem at our company.

    We have 50/50 Windows computers and Mac.

    The Mac computers uses Microsoft Remote Desktop.

    So I tried it on the W10 machines and with sucess.

    So if you are like us, have no solution at the moment. Then I recommend to try Microsoft Remote Desktop until RDP is fixed so the users can do their work :)

    Best Regards

    Alexander

    Monday, May 21, 2018 4:18 PM
  • Hey @BCS-MAN: 

    Not exactly the kind of "fame" I'm after here haha.

    Anyway, that KB location is actually for our knowledgebase, so publishing such an article there doesn't seem like the right place, but I'm checking with our web team to see if we can publish something on our blog and social media. 

    MS is being way slow in responding to this issue. Quite disappointing. 

    Monday, May 21, 2018 5:11 PM
  • Hi all, 

    No good news or anything, but just an update from about 5 minutes ago from Microsoft:

    \

    Will keep the updates coming as we have them.

    Monday, May 21, 2018 5:28 PM

  • Hey all, I'm not sure if you are monitoring the other thread, but at least there is some response from someone at Microsoft on it, and this is the latest response. Ron seems to be monitoring this thread as well. (Thanks Ron... we see you! :) ) 

    "The RS3 fix is slated to release today. I will monitor and update this thread ASAP.

    Also, I am aware of the RS4 issue discussed here - https://social.technet.microsoft.com/Forums/en-US/f3e9852b-393c-4aa0-9d2f-961a82cfc603/remoteapp-after-windows-10-update-1803-are-slow-and-right-mouse-button-is-not-responding-it-reacts?forum=winserverTS&prof=required

    We are investigating this RS4 issue and I will have more news shortly. 

    Thanks,

    Ron Stock
    Sr. Escalation Engineer | Support Engineering -  Cloud & Infrastructure Solutions | Escalation Engineering"


    • Edited by GTMERP Monday, May 21, 2018 7:14 PM
    Monday, May 21, 2018 7:06 PM
  • Nice, glad to hear they are actively working on a solution. Communication is key, they should be more proactive about keeping folks updated. Does no good to let irritated customers stew in their own juices for days on end, but it's always nice to have folks to commiserate with. :)  

    We're not a huge company, but we do have a pretty significant investment in Microsoft technology to the tune of multiple 6 figures. We use remote apps for all of our users to access Microsoft Dynamics AX from a terminal server farm. This keeps us from having to manage client installs on every machine and makes remote access to the application a snap, since we can simply push out the remote apps and they will run externally just as well as they do internally. Or at least they did until this last update. Grrr!

    • Edited by BCS-MAN Monday, May 21, 2018 9:00 PM
    Monday, May 21, 2018 8:13 PM
  • Starting to get dire on our end. Only working solution for us has been reverting to 1709 and some users no longer have that option.
    Monday, May 21, 2018 8:47 PM
  • Hello - I've been working on the other RS3 thread here-  https://social.technet.microsoft.com/Forums/en-US/cdf12bbc-ff78-4d6e-9e12-63f99ae4d511/w10-1709-remoteapp-popups-hidden-behind-main-window?forum=winserverTS&prof=required

    With the RS3 issue addressed, I'll start posting here to discuss the RS4(1803) context menu, z-order issue. The good news is we understand the root cause and we will have mitigation. I will keep you posted as we work through the bug process.

    Thanks,

    Ron Stock
    Sr. Escalation Engineer | Support Engineering

    Cloud & Infrastructure Solutions | Escalation Engineering

    Monday, May 21, 2018 10:10 PM
  • Thank you @Ron Stock! We're all eagerly waiting! 

    Thanks for your work on this! 

    Tuesday, May 22, 2018 12:04 AM
  • Ron, thank you very much for the information. We're excited to hear this is being looked at. 
    Tuesday, May 22, 2018 12:20 AM
  • Dont worry about changing permissions before files swap. You can return them by

    icacls "C:\Windows\System32\mstsc.exe" /setowner "NT Service\TrustedInstaller"
    icacls "C:\Windows\System32\mstscax.dll" /setowner "NT Service\TrustedInstaller"
    Tuesday, May 22, 2018 8:22 AM
  • Damn! Should not have updated our users to 1803. This issue is even worse than the old Z-index problem. Now we cant use our CRM system at all.
    Tuesday, May 22, 2018 10:18 AM

  • Other than context-menu issue, anyone noticed the taskbar windows-preview not appearing as well for RemoteApps ?

    I am hopeful nothing else breaks after fixing the newly identified issues.


    Tuesday, May 22, 2018 10:45 AM
  • Thanks Ron for your attention to this issue, it's causing a lot of pain.
    Tuesday, May 22, 2018 12:01 PM
  • Thanks for the post @Fireballcz, that's good information, but you still have to change the permissions on the files before the operating system will allow you to overwrite them.
    Tuesday, May 22, 2018 12:05 PM
  • You guys can use the script on the "Knowall IT" blog, which can take care of all the permissions. (Can't vouch for the quality of the files downloaded, but you can always point them to your own source..) http://www.knowall.net/blog/known-bug-with-windows-10-and-remote-desktop-rds-remote-apps-selected-windows-do-not-respond-fix/
    Tuesday, May 22, 2018 1:18 PM
  • I have also received reports from some of our users that are experiencing the taskbar windows preview not working.

    Normally if a user has several windows open in our application, they will see stacked tabs in the taskbar and when they hover over the stack it will preview the open windows. 

    They are reporting that this is not working, in addition to all the other issues that are occurring.


    Tuesday, May 22, 2018 1:31 PM
  • Yes, that is the issue I'm currently dealing with.  Disabling "Use advanced RemoteFX graphics for RemoteApp" fixed the drop down and right click issues for us, but the taskbar/windows preview issue is currently causing a problem for us as not all windows are showing up for us.
    23 hours 26 minutes ago
  • Just wondering... am I the only one compulsively hitting "Refresh" on this thread? :-D 
    17 hours 8 minutes ago
  • I'm right there with ya
    16 hours 44 minutes ago
  • I feel like I have self control. I only check it about once an hour... :)
    16 hours 27 minutes ago
  • Refreshing every 20 min's

    15 hours 25 minutes ago
  • Two or three times a day for me
    7 hours 34 minutes ago
  • My finger is on button.

    Hot Fix when you come and save me....

    7 hours 33 minutes ago
  • Same problems. Following...
    5 hours 12 minutes ago
  • technology was designed to help us as I recall :D

    5 hours 9 minutes ago
  • Can you share please?? 

    Thanks!

    3 hours 46 minutes ago
  • @menjoy: the workaround was already provided. If disabling the remoteFX setting at the server does not help (here, it does not), then tell you users to start psr (Press winkey+r and enter psr), start recording and the problem is gone for the time it's recording.
    3 hours 27 minutes ago
  • The only acceptable solution is a new windows update or a rollback of the previous update. Not everyone has access to all of their client's computers.
    2 hours 23 minutes ago
  • The only acceptable solution is a new windows update or a rollback of the previous update. Not everyone has access to all of their client's computers.
    I concur. Client computer tweaks etc. do not make the cut for an ideal solution. Besides lack of access to client computers, need for coordination with X number of users etc., there is also the reputation factor to think of. People're going to be pretty unhappy if the IT department keeps changing stuff on their computers all the time. And, it's a significant time sink as well, lots of users may not be too tech savvy and may require hand holding to walk through the patch, thereby consuming valuable time. 
    1 hour 53 minutes ago
  • Yes, I'm f5ing this thing every few minutes. 

    There's no way I can ask our users to open PSR and record to avoid this bug. That's not a workaround, that's just adding more problems to the pile. (Not to discount its cleverness)

    1 hour 52 minutes ago
  • I've limited my thread refresh to about 4 times per day, but only because limited updates from the Microsoft crew has dashed my hopes for an immediate solution. However, I do still need to get my daily dose of sarcasm and disappointment, so full speed ahead Mr. Sulu, maximum warp!

    On a side note, my users are now starting to see the forced update screen where they have to pick a date and time for the 1803 update. I'll just wait for the update to be applied and then roll back the remote desktop files. Luckily most of our users are still running Windows 7. We were just planning a new hardware refresh and operating system deployment to Windows 10 over the summer. This issue has placed that scenario on hold.   

    #HoldingSteady
    22 minutes ago