none
Unable to enable scripting for IE8 on Windows Server 2008 (32-bit) for application execution. RRS feed

  • Question

  • Greetings,

    I have an HTML2Txt conversion application that programatically calls IE to open an HTML source which produces a formatted text-only output of any web page/html file.  The app includes an Html2Txt.ocx that must be registered during installation.  The application was originally installed on Windows 2003 Server with IE7 and functioned without issue either via an interactive logon or as a child process (invoked as needed) to a windows service executing under the same user.  We are moving the solution off of Windows 2003 and I installed the app and parent service on a 32-bit Windows 2008 Server with IE9.  The service executed as expected but the HTML2Txt application failed with errors about IE.  I then downgraded IE to IE8 and it now functions without error if I execute it from a command prompt.  However, although the application executes without generating any errors and produces a formatted text-only output when invoked by the service, the output generated contains a statement identifying that the browser is not running scripts and any content generated by embedded JavaScripting is not present.  I have configured Internet Options to enable Active Scripting and reregistered the HTML2Txt.ocx as well as the jscript.dll in addition to adding the source domain to Trusted Sites.  I have also tried opening the source URL, saving it to a file and tried converting the local file and it always produces the same deficient output.  Since the output generated during a manual execution of the application produces the desired output, I feel confident that there is no compatibility issue and scripts are obviously executed at that time.  Since scripts are not run during the programatic execution of the app, how can I resolve this issue?

    Thank you for any suggestions you may have.

    Friday, August 28, 2015 5:53 PM

Answers

  •  

     

    Hi rapjr.

    First, to clarify some confusion.  Enhanced Protected Mode doesn't exist in your setup.  It was introduced in IE10.  Here's a snapshot of an official blog article giving the timelines of the original Protected Mode (with IE7) then later Enhanced PM (with IE10).

     

    https://googledrive.com/host/0B8BLd2qPPV7XNG44OGpEcFItdXM/IEBLOG-EPM-(introduced-in-ie10).png

     

    So I think you meant, you confirmed that Protected Mode (ordinary non-Enhanced) is disabled.  You didn't mention, but I suppose you are running Server2K8 with the default built-in Admin account.  Yes?  If so, it has the odd default (like Server2008-R2) that UAC is disabled.  That in turn somehow causes Protected Mode to be disabled too.  Even when its Internet Options setting has it enabled.  Check the screenshot in the thread I linked earlier, and below, to see this strange thing.  And this somehow leads to some buggy security/privilege behavior.  That's what that thread was about.

     

    https://googledrive.com/host/0B8BLd2qPPV7XNG44OGpEcFItdXM/Server2K8-InternetZonePM.png

     

    My thinking in mentioning it was, maybe you will want to try creating a different user account and log-in to that one to test your conversion app.  Wouldn't it be nice if that simple step solved the problem?

    Another thing I was wondering, again mentioned in the other thread, did you disable "Internet Explorer Enhanced Security Configuration" in Server Mgr?  It seems to block most everything.



    Thursday, September 3, 2015 4:24 PM

All replies

  • Hi,

    Tools>Internet Options>Security tab, turn off Enhanced Protected Mode for the Trusted sites zone.

    or

    navigate to the target site on the server 2008 installed IE version.

    f12>Console tab

    type

    navigator.platform

    expected: win64

    or

    Tools>Manage Addons>Show All addons.... locate your addon in the list... I expect that you have only the x86 version installed.

    EPM on server versions of windows enforce a higher security level for each zone and allows only 64bit versions of Java JRT and ActiveX controls to run.


    Rob^_^

    • Proposed as answer by Niko.Cheng Tuesday, September 1, 2015 6:49 AM
    Monday, August 31, 2015 9:15 AM
  • Rob,

    Thank you for the reply, I checked to verify that EPM for Trusted Sites zone is already diabled and in the "Developer Tools" (F12)-->Scripts-->Console, when I enter "navigator.platform" I get "Win32" response.  I suspect that I may not have stated my platform clearly as I would not expect a "win64" response since the platform is a "32-bit" Windows 2008 Server.  In the Manage Add-Ons, it only lists 2: "AcroIEHlprObj Class" (Adobe Systems) and "XML DOM Document" (Microsoft).  I am not sure if there should be anything else since everything works perfectly when I execute the application at a command prompt.  I suspect that the issue is not that the application doesn't work or is not configured properly, but that when executed as a child process to the parent service, it isn't granted the right permissions or something along that line.

    rapjr328


    • Edited by rapjr328 Thursday, September 3, 2015 3:20 PM
    Thursday, September 3, 2015 2:59 PM
  • yo mama,

    Thanks for your reply.  Can you please explain what clue I might find in the reference you have made to a "development/coding" solution involving IE11 that would apply to my "executing an existing 3rd-party application" issue involving IE8?  Maybe it is obvious, but I don't see it (which is probably why I am asking questions on this forum in the first place).

    rapjr328

    • Edited by rapjr328 Thursday, September 3, 2015 3:31 PM
    Thursday, September 3, 2015 3:30 PM