locked
Multiple monitor setup RRS feed

  • General discussion

  • I am using a 27 inch iMac to remote into a Windows 7 machines.  Both have two monitors (though the imac's primary monitor is much higher resolution)

    When I remote in using Microsoft's new Remote Desktop Client for OSX, I can only every get one monitor to display.  I have both Full screen and Use all monitors options checked. 

    How can I get two monitors working?

    • Changed type Jeremy_Wu Thursday, November 7, 2013 1:31 AM
    Wednesday, October 23, 2013 8:52 PM

All replies

  • Hi,

    To enable the usage of two or more screens connected to your Mac follow these steps:

    • Right-click the Remote Desktop you want to enable multiple screens for, and then click Edit.
    • Enable the options Use all monitors and Full screen.

    Hope this helps.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, October 31, 2013 12:17 PM
  • Why do I not have the option "Use all monitors" if I have a two monitor setup?
    Thursday, October 31, 2013 2:24 PM
  • Hi ChristopherRice,

    Please verify that the machine is running Windows 7 Ultimate or Windows 7 Enterprise.  This is required for true multi-monitor support.

    Thanks.

    -TP

    Friday, November 1, 2013 11:56 PM
  • I don't think you read my question thoroughly.  :-)
    Sunday, November 3, 2013 2:50 PM
  • I am using Windows 7 Professional.
    Sunday, November 3, 2013 2:50 PM
  • Hi ChristopherRice,

    please tell us what Apple OS you' re useing. there is a Bug in the new Apple OS Mavericks (10.9), so have the most (RDP dualscreen) Apps Problems.

    cheers Stephan

    Monday, November 4, 2013 3:48 PM
  • I am using 10.8
    Tuesday, November 5, 2013 1:02 AM
  • Hi,

    Since the target PC is running Windows 7 Professional true multi-monitor support will not work.  It needs to be Ultimate or Enterprise version. 

    You may be able to upgrade to Ultimate using Windows Anytime Upgrade.  On the Windows 7 machine try clicking Start and typing Anytime Upgrade, press enter and then click Go Online (or similar) to see pricing.

    -TP

    Tuesday, November 5, 2013 1:12 AM
  • Any plans to add support for other versions of windows?
    Tuesday, November 5, 2013 3:20 PM
  • I currently have Windows 7 Enterprise installed and the client still does not allow multi-monitor support. The client used to have a check box to use all monitors running on mountain lion.  The option is no longer there in Mavericks.  This is the real issue, Microsoft need to update the client.  
    Wednesday, November 6, 2013 2:38 PM
  • Agreed.  That would be nice.
    Wednesday, November 6, 2013 3:11 PM
  • Hi simpsonjr,

    As stated above, ChristopherRice is not running Mavericks, and is not running Enterprise, so his situation is different from yours.  Multi-monitor currently does not work with Mavericks.  This will be fixed in a future release.

    -TP

    Thursday, November 7, 2013 3:13 PM
  • Thanks for the clarification.  Any idea when the update will be released?  

    -JS

    Thursday, November 7, 2013 8:43 PM
  • same here... the new client worked great in 10.8 but now gone in 10.9. Giveth and taketh away!  
    Tuesday, November 12, 2013 10:40 PM
  • With the latest release we can now extend the RDP session across multiple monitors in Mavericks. The only stipulation is that you MUST have "Displays have separate Spaces" checked in Settings -> Mission Control (from the testing I've done).

    Friday, November 22, 2013 2:20 PM