none
SOLVED:Windows Mobile-based device and Canon Powershot cameras showing code 19 and MTP USB Device failed.

    Question

  • We have some symbol windows mobile-based handheld devices that we use in our business.  We connect these devices to our computers to copy files to.  This all worked fine until recently the devices come up as failed.

    It appears in device manager with a yellow exclamation point.

    Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged.  (Code 19)

    I've tried all the solutions I can find on the web and none of them work.

    Including:

    Uninstall the device in device manager and scan for changes.  It downloads the driver from windows-update and returns to code 19.

    Tried hardware troubleshooter which basically seems to automate the process of uninstalling and scanning.

    I've tried removing windows media player 12 feature and adding it back.

    I've tried deleting USB controllers from Device Manager and rebooting, it re-detects them all and still gets code 19 on the device.

    I've tried deleting upper and lower filter values in the registry which I found out later is mainly for CD/DVD devices, that didn't fix anything.

    I've tried removing and re-installing Windows Mobile Device Center and driver pack and that did not fix it either.

    Additionally Canon Powershot camera gives us similar results.  MTP USB Device failed.  

    This is so far happening on 3 of our workstations that we know of.

    At first we thought it was due to windows updates but nothing recent has been installed that looks related and we installed all available updates on a laptop with a fresh install of windows 7 and it does not exhibit this problem.  

    We also thought it might be Forefront Endpoint Protection as we just started installing that about 3 weeks ago.  However, that was also installed on the laptop with the fresh copy of Windows 7 and did not cause any problems.

    We've run out of options other than to try a repair install of windows 7 which I'd like to avoid, especially if this turns up on more than the 3 computers.


    Tuesday, September 13, 2011 5:50 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Do you have Kaspersky installed? Kaspersky Filter driver caused that any USB device could not connect.

     

    It is suggested to have a look at the following registry. Make a backup of it and remove the Upperfilters setting:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

    “Upperfilters” = klfltdrv

     

    If the issue persists, please find a working machine and compare the registry settings.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, September 14, 2011 3:37 AM
    Moderator

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Do you have Kaspersky installed? Kaspersky Filter driver caused that any USB device could not connect.

     

    It is suggested to have a look at the following registry. Make a backup of it and remove the Upperfilters setting:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

    “Upperfilters” = klfltdrv

     

    If the issue persists, please find a working machine and compare the registry settings.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, September 14, 2011 3:37 AM
    Moderator
  • Thank you!  This solved the issue.  I remember seeing a forum entry about Kaspersky somewhere about a week ago but it must have been slightly different because it either didn't apply to my computer or the registry location they pointed to was wrong.  
    Wednesday, September 14, 2011 6:09 PM
  • Hi,

    Glad the issue is resolved.

    Thank you for choosing Microsoft.

    Enjoy~


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, September 15, 2011 2:50 AM
    Moderator
  • This worked for me.my camera could not install before.
    Thursday, August 02, 2012 7:48 AM
  • Thanks Magon, worked for me too. Very hard to find a solution that applied to our situation so very much appreciated. We used to have Kaspersky so had the key left behind even though on endpoint now, hopefully other Canon users having problems will find this thread too. Many thanks
    Monday, November 26, 2012 4:25 PM
  • Magon Liu,

    Many thanks! This resolved the issue I was having after uninstalling Kaspersky with my iPhone as well.

    Best Regards!

    Friday, December 07, 2012 8:04 PM
  • Nice...this was a really painful issue that we didn't know how to resolve.  This fixed it!
    Wednesday, April 10, 2013 6:35 PM
  • Genial, ca fait 2 mois que je cherchais....many thanks !!!
    Tuesday, August 20, 2013 4:19 PM
  • Mil Gracias, al fin pude conectar mi Trimble Recon al centro de dispositivos de Windows Mobile, en mi caso solo elimine la clave:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

    “Upperfilters” = edevmon

    Yo tengo instalado Eset end point security.

    Gracias nuevamente !!!

    Thursday, February 06, 2014 9:45 PM
  • Magon, 

    this solved in a minute a long-time issue I had with my WP8 and my laptop (Win7 64-bit). I had previously Kaspersky installed, it had been removed but the registry entry remained.

    Now, it works perfectly.

    Thanks a lot for your very valuable support.

    Wednesday, February 26, 2014 11:29 AM
  • Hi Megan,

    I am experiencing the same issue. It says 'There is a problem with the driver for Canon PowerShot SD1200 IS. The driver needs to be reinstalled.' I have uninstalled Kaspersky, anything Canon related. Still nothing.

    Sunday, May 04, 2014 3:57 PM
  • I have found the regkey :.....DABF3DE3F69A} but cannot locate where "upperfilters" is.
    Thursday, June 12, 2014 4:32 AM
  • Indeed. I never found that upperFilter subkey either. Any other suggestions

    BTW, I've recently installed IObit Malware Fighter 3.3 and their USB disk guard is activated but I've turned that OFF and still the problem exists for me.

    Thanks!

    Wednesday, September 16, 2015 4:47 PM
  • I found another solution if you have installed Kaspersky

    1) Right click My computer

    2) Open device manager

    3) Remove problematic MTP device

    4) Open Kaspersky and Pause protection for 30 minutes

    5) Connect your Lumia phone and driver will install without any issue


    • Edited by Kichu2cool Wednesday, March 16, 2016 8:43 AM mistake
    Wednesday, March 16, 2016 8:42 AM
  • I never found that subkey either. I even searched through the whole registry for it.. I did however find a solution, I ended up installing the MTP developers unlock kit from msdn.microsoft.com. That ended up solving the problem on my laptop! Here is the link:

    https://msdn.microsoft.com/en-us/library/windows/hardware/dn614016(v=vs.85).aspx

    I hope that helps everybody else who is having this issue!

    For the record, my issue started after reverting back to windows phone 8.1 from windows 10 mobile. (the list of reasons is pretty lengthy, and I gave Win10M 4 separate tries for several months each... I just kept getting sick of the bugs and little things that they refuse to fix about it that make it a negative experience, and decreased experience from 8.1...) So this developer kit is a heaven send!

    Thursday, November 24, 2016 4:58 AM