"The type initializer for 'Microsoft.AnalysisServices.ManagementDialogs. ServerPropertiesLanguagePanel' threw an exception." on Windows 8.1


  • So I have this SQL Server 2012 Analysis Services with the relational engine and the Multidimensional instance installed... and I get the same error as this MS article, 

    Here is the article:

    It suggest going into “Msmdsrv.ini” and step 4 is vague, yet, it seems I get the exact same error message, so I wish they spent more time on the key piece of the workaround… step #4

      4.   Edit the value in the tag for the property that needs adjustment.

    It really isn't clear to me the tag that needs adjusting.  Any help would be much appreciated.

    I have SQL 2012 Dev Ed, and VS 2012 Ultimate, VS 2010 Ultimate,  installed.  I think I removed and re-installed VS 2012 because of an issue… Perhaps, it is just best if I remove everything and re-install?  I would hate to have to do this is I simply need to make a small change to the ini…

    Help? Please!



    I suppot PASS -

    Thursday, October 03, 2013 6:13 AM

All replies

  • Hi Scott,

    Thank you for your question. I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated. 

    Thank you for your understanding and support.

    If you have any feedback on our support, please click here.


    Elvis Long
    TechNet Community Support

    Sunday, October 06, 2013 1:01 PM
  • The KB article is unclear. What it's trying to say is that instead of trying to change an SSAS server property via the GUI in Management Studio, just edit the property in the msmdsrv.ini file. The KB article isn't trying to give you a fix for the error message. It's providing a workaround so you don't have to use that dialog giving you the error message.

    • Proposed as answer by Dan EnglishMVP Wednesday, October 23, 2013 3:37 PM
    Monday, October 07, 2013 9:09 PM
  • Hi Scott,

    This is a known issue with Windows 8.1. In every OS we have a unique LCID for but in this OS we see LCID 4096 as duplicate and due to which failure happens.

    4096  Basa Jawa (Indonesia)

    4096 Malagasy (Madagasikara)

    4096  ߒߞߏ (ߖߌ߬ߣߍ߬ ߞߊ߲ߓߍ߲)

    4096  português (Angola)

    4096 chiShona (Latin, Zimbabwe)

    4096  ⵜⴰⵎⴰⵣⵉⵖⵜ (ⵍⵎⵖⵔⵉⴱ)

    Currently product team is working on this and there is an Active Bug filled. I am not sure about the release dates and when we can get the fix. At this time since we dont have any workaround for this issue we request to change all the server property via msmdsrv.ini file.

    The KB article suggest to use msmdsrv.ini file to change any server properties which you would have done from the Object Explorer -> Property.

    I hope this answer your query.


    Raju Kumar

    Raju Kumar

    Tuesday, October 08, 2013 6:29 AM
  • Hi Raju,

    I'm experiencing the same issue Scott is above, except with Windows Server 2012 R2 Standard.

    I saw the workaround above from KB article to modify the settings in the msmdsrv.ini file.   My workaround is I'm using SSMS on a Windows Server 2012 Standard (without the R2) version on the same domain to access my two SSAS instances running on the Windows Server 2012 R2 Standard and this works fine in opening the properties window.

    I do not see any of the SQL Server 2012 SP1 CUs which we are currently at CU6 working here because it's an OS language problem which I would assume would need a hotfix on the OS in both my case and in Scott's case.

    Please let me know if I'm correct on the above statement for hotfix and/or if there is an anticipated time for resolve.


    Saturday, October 12, 2013 10:37 PM
  • Same issue as listed above on Windows Server 2012 R2 Standard.

    Is there any hotfix/update to be applied as of yet?


    Monday, June 02, 2014 2:12 AM