locked
Report Viewer stopped working RRS feed

  • Question

  • Seemingly overnight, and out of the blue, report viewer 2008 stopped working on my Windows Server 2012 R2 WSUS machine. I do believe updates were installed on the machine, but report viewer was still working for at least a few days after these updates. I've tried repairing the installation of report viewer 2008, but that doesn't help. What could be causing this issue?
    Tuesday, July 25, 2017 1:42 PM

All replies

  • Hello,

    What is the error message when you try to run reports in WSUS? Do you have CLR Types for SQL also installed?

    If possible would you please remove report viewer and reinstall it. 

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 26, 2017 5:13 AM
  • The error message says "An error occurred while generating the report. Try running the report again or contact your network administrator if the problem persists." And I don't believe CLR Types for SQL is installed. Where would I check if it is? (I'm pretty new to most of this. Still learning about WSUS and all the basics of a Windows Server environment.) Reinstalling report viewer did not help the issue. Thanks.
    Wednesday, July 26, 2017 1:58 PM
  • To update, I tried uninstalling and reinstalling .NET Framework 3.5 as well. It didn't help. I also tried using Report Viewer 2010 because I saw that as a solution to a similar problem, but WSUS won't use 2010. I'm at a loss now. There were security updates for .NET Framework 3.5 a few days before the issue started, but I can't find them in Programs and Features to uninstall. Any suggestions are greatly appreciated. I've been trying to figure this out for almost a week now.
    Thursday, July 27, 2017 5:43 PM