Windows Server 2012 R2 is reporting no free space in the storage pool when creating a virtual disk in dual parity but single parity sees the full capacity just fine.


  • 5 x 3tb empty drives
    no HW raid
    tried with and without formatting the drives.

    The only reason I'm even messing with the R2 is for the 'raid 6' feature.

    Along the same question: does Win 8.1 offers dual parity?

    Exact error in New Virtual Disk Wizard:
    Free space in this storage pool: 0.00 B
    and under Specify size: it will only accept zero
    and if Maximum size is selected an error: "The size should be a positive number." appears bellow the 'specify size...'
    Thursday, September 05, 2013 12:58 PM

All replies

  • Hi,

    Thank you for the post !As dual parity is a new function in Windows Server 2012 R2 which is still a preview version, any potential issue is important to us.

    Could you always reproduce this issue when creating the dual parity disk? If available please also provide a screenshot of the issue.

    Meanwhile I will try to reproduce the same issue. If it persists I will report this issue to our product team.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    Friday, September 06, 2013 4:22 PM
  • Thanks for your prompt reply.

    Yes, I can always reproduce the problem.

    I can't post screenshots as I'm a new TechNet user (can't post pics or links) but the error is exactly as I outlined above. Not much else to see.

    That's when I use Fixed Provisioning. With Thin Provisioning, even with only 1GB selected, I get an error at the Results page, after 'Create virtual Disk - Failed' progress bar: "Failed to create virtual disk - There are not enough eligible physical disks in the storage pool to create the specified virtual disk configuration."

    My hardware: Intel DG965WH motherboard, Intel Core 2 Quad Q6600 CPU, 4 x 2GB DDR2800 Gskill RAM, 5 x WD Red 3TB HDDs. 

    Data drives are attached to MB SATA connections with no RAID enabled. Tried both AHCI and IDE settings.

    OS drive in a separate SATA controller. Regular install (not a VM)

    ALL other 'RAID' modes work fine: single parity and single/dual mirror.


    Jut to add: I'm using Windows Server 2012 R2 Datacenter
    • Edited by PTNTP Friday, September 06, 2013 6:05 PM
    Friday, September 06, 2013 6:03 PM
  • Sorry for the delay and thank you for your response. I have already logged this issue and see if there is any update regarding this issue. Will post back once I get response. 

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    Monday, September 16, 2013 1:14 PM
  • Hi all,

    I have the same problem using Dual Parity (single works fine).  I also replicated the fault using 6 x .vhdx's and added them to a Hyper-V VM and ended up with the same response.

    Has anyone had found the trick to getting this feature working?

    1.  Storage Pool is made up of 6 vhdx's set as usage 'automatic'  (Pool Free Space = 54Gig)

    2. Virtual disk is 'dual parity', 'fixed'

    3. Size = failure point (no option, 'specify' or 'maximum'), does not enable 'create' button.

    Sorry no screens, guessing that newbie thing.


    Sunday, October 13, 2013 4:28 AM
  • Hi,all.

    You need at least 7 disks to create dual parity.
    If you run the create virtual disk wizard with less than 7 disks , you can't select dual parity after GA update.

    Masahiko Sada
    Microsoft MVP for Server Solutions - Windows Home Server

    Saturday, November 02, 2013 4:14 PM