locked
"We can't connect to the server for presentation right now" - after patchday on sunday - coincedence? RRS feed

  • Question

  • Hi everyone,

    we recently patched our systems to May patchlevel.

    Now external users get errors like. Internal users can upload and present:

    "We can't connect to the server for presentation right now" if we try to present powerpoint files. 

    Everything else is working fine. 

    Our environment:

    FrontEnd in local network

    Edge in DMZ

    Office Web Apps Server 2013 in local network

    What i tested:

    Checked certificates for expire date
    Checked OWA Webserver from external (hosting/discovery)
    Checked log from firewall

    Error on FE:

    No connectivity with any of Web Conferencing Edge Servers. External Skype for Business clients cannot use Web Conferencing modality.

    Cause: Service may be unavailable or Network connectivity may have been compromised.
    Resolution:
    Verify all Web Conferencing Edge Services in the topology are running, and network connectivity is available.

    Similar problem (after updates):

    https://support.microsoft.com/en-us/help/3165438/some-clients-can-t-connect-to-conferencing-modalities-after-you-install-security-bulletin-ms16-065

    But it seems like i'm the only one. Or does someone else have similiar issues?



    Regards Stephan

    OneDrive / Sharepoint Blog

    Wednesday, May 17, 2017 8:47 AM

Answers

All replies

  • Hi Stephan,

    Is there any error on OWA server as well? Also are you able to ping OWA from your FE Server?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. Thanks.

    Wednesday, May 17, 2017 10:41 AM
    • Proposed as answer by WVoos Wednesday, May 17, 2017 4:19 PM
    • Marked as answer by Stephan G Saturday, May 20, 2017 6:38 AM
    Wednesday, May 17, 2017 4:15 PM
  • Hi,

    thanks for the link i will the second option and then start with option 3.
    Danke für die Lösung / Thanks for the solution.

    The reg key is not a "normal" one. So can you confirm this is the right way to do this?

    Normally i would expect a key that exists in the folder v4.0

    Best regards

    Stephan


    Regards Stephan

    OneDrive / Sharepoint Blog

    Thursday, May 18, 2017 5:49 AM
  • Hi Stephan G,

    Would you please tell us which kind of certificate did you use for Lync Edge server external NIC, internal NIC and FE server? The issue may cause by the certificate.
    Here is a blog may help you:
    http://daniyar-tech.blogspot.com/2013/12/no-connectivity-with-any-of-web.html

    For client side, please check if all SFB clients had this issue or all clients had this issue.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 18, 2017 7:06 AM
  • Hi Alice,

    it is a certificate issue. But only because the NET Update now checks for EKUs which are no included in the normal "Webserver" Certificate that we got from our PKI (and MS).

    I will start with disabling the check and then issue new certificates with this new "option".


    Regards Stephan

    OneDrive / Sharepoint Blog

    Thursday, May 18, 2017 7:08 AM
  • Hi Stephan,

    Waiting for your response.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 18, 2017 7:11 AM
  • I could not restart the server yet as we are now in working hours. I have to make a request for restart. Luckily most colleagues use the screen sharing feature. This features continues to work from external



    Regards Stephan

    OneDrive / Sharepoint Blog

    Thursday, May 18, 2017 7:19 AM
  • Hi Stephan,

    wie did not test the solution with the reg key (just pulled it from the KB entry). In our test-infrastructure we immediately replaced the certificates ...

    The Reg-Key also comes from the KB entry. BUT I would assume that your entry is INCORRECT - I would create a DWORD entry named "RequireCertificate..." under .NETFramework\v4.0.30319

    Depending on your version of Lync/S4B it could also be that this key is needed under .NETFramework\v2.0.50727 - if I remember correctly, the older versions used Framework 3.5 (i.e. the .Net 2.0 runtime).

    Try it out - "probieren geht über studieren" ;-)


    • Edited by WVoos Thursday, May 18, 2017 8:19 AM typo/more infos
    Thursday, May 18, 2017 8:16 AM
  • Hi,

    i also assumed it is not right but the @ sign was all over the page ;)

    I assume i have to restart at least the services to accomplish a real "test". I can only perform this action during maintenance windows. But Weekend is coming :)

    After applying the "workaround" i will reply here if it worked (or not)


    Regards Stephan

    OneDrive / Sharepoint Blog

    Thursday, May 18, 2017 8:22 AM
  • Hmm, restarting the "Web Conferencing" Service was enough in our tests with the replaced certificates. Depending on your policies (and your boss) you may get away with that, as this does not work (for external users - via Edge!) at the moment anyway ...

    On the other hand - weekend is near :-)

    Thursday, May 18, 2017 8:56 AM
  • Great. The registry hack did it. And without a restart of the server itself. Only the "web conferencing service" helped. I created the registry entry like this. (also at the v2 folder)

    Thank you very much for sharing the knowledge.


    Regards Stephan

    OneDrive / Sharepoint Blog

    Saturday, May 20, 2017 6:38 AM
  • Hi Stephan G,

    I am glad to hear that your issue has been resolved and thanks you for marking the reply as an answer, it will help others who has the similar issue.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 24, 2017 9:33 AM