none
Internet Explorer Blocker Toolkits RRS feed

  • Question

  • Recently I've had to block Internet Explorer from upgrading to the latest version due to conflicts with mission critical applications running on file and application servers. More specifically I can't upgrade IE beyond IE8. I have applied and ran the Internet Explorer Blocker Toolkit for versions 9, 10 and 11. This was done after downgrading IE back to IE8. In addition I have hidden Internet Explorer version upgrades within Windows Update. However, each monthly update will by-pass the blocker toolkit, and force an upgrade when Windows Update automatically runs. Is there no other effective way to prevent IE from upgrading on selected servers and workstations other than what I've outlined. Please let me know if you have a better solution.
    Thursday, May 5, 2016 5:50 AM

Answers

  • Hi TwalkerFlight,

     

    Based on your description, I want to confirm that which system have you used? Have you use WSUS? If so, is the update approved in WSUS?

     

    You mentioned that IE blocker toolkits don’t work, but after my test, it works properly. I suppose that there is something wrong with configuration, please follow the guide step by step in this link and check the result.

     

    How to set IE 8 Blocker policy:

    https://blogs.msdn.microsoft.com/askie/2009/02/19/how-to-set-ie-8-blocker-policy/

     

     

    In addition, it seems that there is a GPO setting which may also help you:

     

    \Computer Configuration\Administrative Templates\Windows Components\Internet Explorer\Install new versions of Internet Explorer automatically

     

    Please disable the option and check the result.

     

     

    Best Regards,

    Tao

     


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, May 7, 2016 10:24 AM
    Moderator