none
MDT W10 v1607 The wizard selected UILanguage is not applied, always en-US applied.

    Question

  • Hello everyone and greetings from Mexico!

    I have tried to find a solution to this situation for some days without success, and to be honest I am already a little desperate.

    I did capture an W10 Enterprise image with English as core language, additionally I did include German, French and Spanish Language Packs for user to choose at  LTI deploy wizard.

    At deploy wizard I let the user to choose for the Language settings. I can check at summary that all the values are correct, and start the deploy. When it finish, the Welcome screen applied the correct language, but the administrator profile and new profiles, keeps the English.

    Trying to solve it, I did capture a small image with only the W10, LPs and updates and some personalization (Lockscreen, theme, etc), for tests, and the issue happens too with this one.

    Trying to force it, changed at unnatend sections Specialize>International-Core and  oobeSystem>International-Core with %UILanguage%, %OSDUILanguage%, delete the line oEnvironment.Item("UserLocale") = oEnvironment.Item("InputLocale") at  %DEPLOYROOT%\Scripts\UDIwizard.wsf, all ti without success.

    Are any of you experiencing something similar?
    It is quite frustrating because something that is relatively simple is not working for me.

    Thank you in advance for your help.

     

    Monday, March 6, 2017 3:53 PM

All replies

  • Hi César Del Río,

    How did you configure the unattend files?
    There are two parts for the UI. One is for "Setup" and the other one is for "System".

    Microsoft-Windows-International-Core
    https://technet.microsoft.com/en-us/library/cc766400%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396
    Microsoft-Windows-International-Core-WinPE
    https://technet.microsoft.com/en-us/library/cc766378(v=ws.10).aspx

    For MDT configuration issue, we could check the bdd.log for for information to troubleshoot this issue.

    For configuring MDT, we have a specific forum for you.
    Microsoft Deployment Toolkit
    https://social.technet.microsoft.com/Forums/en-US/home?forum=mdt

    For client configuration, we usaully could configure the language for all the users here.
    Control Panel\All Control Panel Items\Language\Advanced settings\Apply language settings to the welcome screen, system accounts and new user accounts.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 7, 2017 5:49 AM
    Moderator
  • Hi MeipoXu!

    Thank you for your comments!

    Regarding unattend.xml configuration:

    WinPE section.

    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>en-US</UILanguage>
                </SetupUILanguage>
                <InputLocale>0409:00000409</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
            </component>

    Specialize section.

    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>%KeyboardLocale%</InputLocale>
                <SystemLocale>%UserLocale%</SystemLocale>
                <UILanguage>%UILanguage%</UILanguage>
                <UserLocale>%UserLocale%</UserLocale>
                <UILanguageFallback>en-US</UILanguageFallback>
            </component>

    oobeSystem section.

    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>%KeyboardLocale%</InputLocale>
                <SystemLocale>%UserLocale%</SystemLocale>
                <UILanguage>%UILanguage%</UILanguage>
                <UserLocale>%UserLocale%</UserLocale>
                <UILanguageFallback>en-US</UILanguageFallback>
            </component>

    At Wizard Deployment, when the language settings are selected, when something different from English was choose, when the deploy ends, the welcome screen, sets the correct language, but the admin and new profiles, they keep the English:

     Lockscreen with time and date in Spanish

    Lockscreen in Spanish.

    Welcome Login page in Spanish

    Welcome Login page in Spanish

    Once logged, profile in English.

    Once logged, profile in English.

    Regarding the bdd.log, seems to me normal, except for  one section when the copied to local D:\\MININT\unattend.xml is updated with the wizard selected values.

    I don't know if it should be that way, but ImageLanguage001=en-US.

    Regarding my MDT configuration, my CustomSettings.ini

    [Settings]
    Priority=MigScenario, Default
    Properties=MigScenario, MyCustomProperty

    [Refresh]
    ScanStateArgs=/v:5 /o /c /localonly /ue:%ComputerName%\*
    LoadStateArgs=/v:5 /c
    USMTMigFiles001=MigApp.xml
    USMTMigFiles002=MigDocsRefresh.xml
    SkipDeploymentType=YES
    DeploymentType=REFRESH
    SkipTaskSequence=YES
    TaskSequenceID=PROW10-X64-001
    SkipComputerName=YES
    Computername=%ComputerName%
    SkipUserData=YES
    UserDataLocation=AUTO

    [Replace]
    ScanStateArgs=/v:5 /o /c /localonly /ue:%ComputerName%\*
    LoadStateArgs=/v:5 /c
    USMTMigFiles001=MigApp.xml
    USMTMigFiles002=MigDocsReplace.xml
    SkipTaskSequence=NO
    SkipDeploymentType=YES
    DeploymentType=REPLACE
    SkipComputerName=NO
    SkipUserData=NO

    [Default]
    ScanStateArgs=/v:5 /o /c /localonly /ue:%SerialNumber%\*
    LoadStateArgs=/v:5 /c
    OSInstall=Y
    SkipTaskSequence=YES
    TaskSequenceID=PROW10-X64-002
    SkipDeploymentType=YES
    SkipComputerName=NO
    Computername=%SerialNumber%
    SkipDomainMembership=NO
    JoinDomain=
    DomainAdmin=
    DomainAdminDomain=
    DomainAdminPassword=
    MachineObjectOU=
    JoinWorkgroup=WORKGROUP
    SkipComputerBackup=YES
    SkipUserData=YES
    ComputerBackupLocation=NONE
    SkipLocaleSelection=NO
    UILanguage=en-US
    UserLocale=en-US
    KeyboardLocale=0409:00000409
    UserLocaleAndLang=en-US
    SkipTimeZone=NO
    SkipAdminPassword=YES
    SkipBitLocker=YES
    SkipBitLockerDetails=YES
    BdeInstallSuppress=YES
    SkipApplications=YES
    SkipAppsOnUpgrade=YES
    SkipCapture=YES
    SkipProductKey=YES
    SkipPackageDisplay=YES
    SkipLocaleSelection=NO
    SkipRoles=YES
    SkipSummary=NO
    SkipFinalSummary=NO

    Regarding the Control Panel>Language>Advance setting, I Know, but it should be configured at the deploy.

    Thank you again for your time and comments, hope this additional information helps to figure it out, what I'm doing wrong.

    Tuesday, March 7, 2017 4:38 PM
  • Hi César Del Río,

    Please check the last reply of the following case.
    Windows 10´s language options are PAIN!
    https://social.technet.microsoft.com/Forums/windows/en-US/79e4066a-5ba6-4b99-8d0f-bf906e911f28/windows-10s-language-options-are-pain?forum=win10itprogeneral

    "He told, that currently Microsoft recommends to use native language images, so no language packs. If you live in Finland, use Finland wim-file, if you leave in Russia, use Russian install.wim etc. So, currently using Language Packs in Windows 10 is a bad policy."

    I think the configuration is only for OOBE. The new users will be applied with the default system language. I am afraid we have to deploy the corresponding language images for different languages.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 10, 2017 5:46 AM
    Moderator